Wacom new bamboo models are not recognized in Lucid

Bug #568064 reported by miguelangeldavila on 2010-04-21
168
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Tim Gardner
Declined for Maverick by Tim Gardner
Declined for Natty by Tim Gardner
Precise
Undecided
Tim Gardner
Quantal
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-wacom

The new Wacom Bamboo tablets models: CTT460, CTL460, CTH460, CTH661 are not suported in Ubuntu 10.04 Lucyd Lynx. Being an LTS version, this situation is unacceptable, since one can not wait three years for an upgrade of the OS to have support for these products, the new driver linuxwacom 8.6 supports these models and should be included in this edition of Ubuntu. This is not a whish list item, it is a bug related to Ubuntu Bug #1, I don't want to migrate again to Windows in order to work with the currently Wacom available line of tablets
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: miguelangel 1829 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero ó directorio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xee000000 irq 21'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,1458e601,00100001'
   Controls : 40
   Simple ctrls : 22
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=3a52b9f4-2a71-40ac-ae66-f249dbbf2b18
IwConfig:
 lo no wireless extensions.

 eth4 no wireless extensions.

 vboxnet0 no wireless extensions.
Lsusb:
 Bus 002 Device 003: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
 Bus 002 Device 002: ID 056a:00d4 Wacom Co., Ltd
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0409:013e NEC Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcCmdLine: root=UUID=dce8f43b-436e-43f6-8301-436a5a3aef26 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Regression: No
RelatedPackageVersions: linux-firmware 1.34
Reproducible: Yes
RfKill:

Tags: lucid kconfig needs-upstream-testing
Uname: Linux 2.6.32-22-generic x86_64
UserGroups: adm admin audio cdrom fax fuse lpadmin plugdev sambashare tape vboxusers
WifiSyslog:
 Jun 15 09:01:29 lucia kernel: [ 980.988864] RPC: Registered udp transport module.
 Jun 15 09:01:29 lucia kernel: [ 980.988867] RPC: Registered tcp transport module.
 Jun 15 09:01:29 lucia kernel: [ 980.988868] RPC: Registered tcp NFSv4.1 backchannel transport module.
 Jun 15 09:01:29 lucia kernel: [ 981.118564] svc: failed to register lockdv1 RPC service (errno 97).
WpaSupplicantLog:

dmi.bios.date: 03/07/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FG
dmi.board.name: M57SLI-S4
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFG:bd03/07/2008:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnM57SLI-S4:rvr:cvn:ct3:cvr:

Bryce Harrington (bryce) on 2010-04-22
tags: added: lucid
Richard Corner (rcorner) wrote :

See also bug #477105 and comments on that bug, where it is suggested that installing the latest kernel module from Wacom may fix the problem. I have not tried that yet. My Bamboo tablet (model CTH-460) is not working in Lucid (64-bit, kernel 2.6.32-21-generic).

summary: - wacom new bamboo models are not recognized in Lucyd
+ wacom new bamboo models are not recognized in Lucid
summary: - wacom new bamboo models are not recognized in Lucid
+ Wacom new bamboo models are not recognized in Lucid

I compilled and installed manually the current stable driver from linuxwacom succesfuly, but it is not the point. Each time the kernel will be updated, will be required to reinstall the wacom module manually, and this is a pain that will stay three long years (This is an LTS). Implementing a solution based on DKMS, is very complex for the user, and at this point the ease of use of Ubuntu is going to heck. I think for the welfare of users and the strength of Ubuntu, this should be an issue to resolve soon.

Richard Corner (rcorner) on 2010-05-01
tags: added: bamboo driver input tablet wacom
pererik87 (pererik87) wrote :

I compiled and installed the newest manually and it doesn't work so I don't know where im at. Maybe i need to hire someone to do it for me :/

strikton (ton-strik) wrote :

Today a new kernel was installed by the update manager and I compiled the driver as described in http://ubuntuforums.org/showpost.php?p=8283168&postcount=1, which worked fien in Lucid till now. Compilation ends with errors and now I have no driver and can't use my tablet. Snif!

Strikton:
I think that the procedure you put in the link is incorrect for Lucid, the procedure that worked for me was:

Download the latest package from linuxwacom.sourceforge.net, I used both the 0.8.6 and the development one and both worked, the most notable difference between is that the xsetwacom in the development version already has the option xsetwacom list xsetwacom list mod

[CODE]

cd linuxwacom-0.8.6

./configure --enable-wacom

cd src/2.6.30/ # Don't Care about the kernel version in Ubuntu which is 2.6.32

make

sudo cp wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/

sudo rmmod wacom # It is required because you already installed the module

sudo modprobe wacom

[/CODE]

After that you should register the wacom module in /etc/modules

If you have a Pen & Touch tablet may be you want avoid the finger cursor, it is uncomfortable when you use the pen. Create an execultable called .xinitrc in your home directory with the lines

[CODE]
xsetwacom set "Wacom BambooFun 2FG 4x5 Finger" touch off

# run the primary system script
. /etc/X11/xinit/xinitrc
[/CODE]

strikton (ton-strik) wrote :

A working solution (pfffff) can be found on http://www.ubuntugeek.com/wacom-bamboo-ctl-460-in-ubuntu-10-04-lucid-lynx.html.
Although this is for the Bamboo CTL-460 it is perfectly working for the CTH as well. Thank God (and Geek).

pererik87 (pererik87) wrote :

Could have gone better :P I give up!! argh.. Its, not like these models are new longer either.

make[1]: Entering directory `/usr/src/linux-headers-2.6.32-21-generic'
make[2]: Warning: File `/home/userX/linuxwacom-0.8.6-1/src/2.6.30/.wacom_wac.o.cmd' has modification time 2.2e+06 s in the future
make[2]: warning: Clock skew detected. Your build may be incomplete.
  Building modules, stage 2.
make[2]: Warning: File `/home/userX/linuxwacom-0.8.6-1/src/2.6.30/.wacom.mod.o.cmd' has modification time 2.2e+06 s in the future
  MODPOST 1 modules
make[2]: warning: Clock skew detected. Your build may be incomplete.
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-21-generic'
userX@userX-laptop:~/linuxwacom-0.8.6-1/src/2.6.30$ make
    Building linuxwacom drivers for 2.6 kernel.
***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built
make -C /lib/modules/2.6.32-21-generic/build M=/home/userX/linuxwacom-0.8.6-1/src/2.6.30
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-21-generic'
make[2]: Warning: File `/home/userX/linuxwacom-0.8.6-1/src/2.6.30/.wacom_wac.o.cmd' has modification time 2.2e+06 s in the future
make[2]: warning: Clock skew detected. Your build may be incomplete.
  Building modules, stage 2.
make[2]: Warning: File `/home/userX/linuxwacom-0.8.6-1/src/2.6.30/.wacom.mod.o.cmd' has modification time 2.2e+06 s in the future
  MODPOST 1 modules
make[2]: warning: Clock skew detected. Your build may be incomplete.
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-21-generic'

Gary M (garym) wrote :

Any reason this bug shouldn't be marked as a duplicate of bug #477105 ?

pererik87 (pererik87) wrote :

@Gary M - This is Lucid not karmic. If you want to mark it as duplicate you have to change one of them(or merge them).

pererik87 (pererik87) wrote :

See your point i do :P but only under the circumstances i mentioned i agree with you

Some days ago http://linuxwacom.sourceforge.net/ released the new 0.10.6 development series. They said this new driver is compatible with xorg 1.7 and more relevant for this thread, the drivers fot the new Wacom tablets. The current production driver (0.8.6) does not support finger tap (clicks) as the new one does. But I have not tested it.

I think the bug souldn't marked as duplicate of bug #477105, because as pereik87 said, they are related to different Ubuntu releases. Moreover, solutions that can provide participants in the threads are different for both systems. And even more, in this thread mention all the Wacom tablets new series, while the other was only specify a model: the P&T

I've created a wacom-dkms package in one of my ppas. It should build new wacom modules automatically. I'd appreciate if some people can test it for me.
To install it, enter into a terminal:
sudo add-apt-repository ppa:ripps818/wacom; sudo apt-get install wacom-dkms

Or, if you want to find the individual packages, just go to:
https://launchpad.net/~ripps818/+archive/wacom/

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

pererik87 (pererik87) wrote :

@Taylor "Ripps" L-Wren

sudo add-apt-repository ppa:ripps818/wacom; <b>sudo apt-get update;</b> sudo apt-get install wacom-dkms

Already installed @Taylor's package it works fine. Almost with the pen. The touch part must wait for the new linuxwacom driver

pererik87 (pererik87) wrote :

work great here also and i only have pen. saved me a lot of "bull", i owe @taylor a pint :P Wish someone could get this upstream in Software center thou.

Today two of my computers updated their kernel and the Taylor "Ripps" L-Wren wacom-dkms package works as espected, it is not necesary to recomple and reinstall the wacom driver anymore. Yeah. It is required to recommend the Taylor's package to the Ubuntu repositories.

pererik87 (pererik87) wrote :

I made a blog post about the taylor package and new wacoms on Ubuntu, its raking in a average of 5 hits a day on a blog with total average of about 40 hits per day. This is a problem for many more people than this bug report gives it impression of. This bug affects at least 2000 people, probably more.

Changed in xf86-input-wacom (Ubuntu):
status: New → Confirmed

The problem isn't with xf86 driver, but the kernel module.

affects: xf86-input-wacom (Ubuntu) → linux (Ubuntu)

I've made a bug report requesting that an add-on package be added to linux-backports-modules. Hopefully the kernel-team can get an update wacom module thorugh this. Please check out bug #606278.

I tested the Martin Owen's PPA solution and it works fine. In the touch an pen & touch tablets the table buttons works as mouse buttons (It does not recognizes the click, tapping directly in the pad). To install it do:

sudo add-apt-repository ppa:doctormo/wacom-plus
sudo apt-get update
sudo apt-get install wacom-dkms xf86-input-wacom

It is a mix of the solution from Taylor "Ripps" and Martin "doctorMo"

I hope it works for you

It's still issue in Maverick Beta?

Yvon TANGUY (vono22) wrote :

For me yes, in both Maverik and Lucid, my Wacom Bamboo Fun (CTH-661) doesn't work without the ppa (at least the kernel module available in ppa:ripps818/wacom).

@RussianNeuroMancer and @miguelangeldavila

After updating to Maverick (10.10) My Wacom Bamboo CTH-460 stopped working.

So, I applied Owen's PPA solution:

sudo add-apt-repository ppa:doctormo/wacom-plus
sudo apt-get update
sudo apt-get install wacom-dkms xf86-input-wacom

Then my tablet worked, but not the express key buttons on the left of the pad and the touch pad as well.

The touch pad was not working really good before, so I don't care. But the express keys were really useful.

I tried to configure express keys with xsetwacom, but it's not working. xinput --test on the pad does nothing while it works perfectly when probing for the stylus or eraser.

Is there a separate bug for Maverick ?

stefan (the-stevee) wrote :

just tried the wacom pen & touch and ubuntu maverick 10.10. basic usage worked with:

sudo add-apt-repository ppa:ripps818/wacom
sudo apt-get update
sudo apt-get install wacom-dkms

followed by a restart.

Stefan Bader (smb) wrote :

For Maverick, there is now a linux-backports-modules package that contains the recent wacom driver:

sudo apt-get install linux-backports-modules-input-maverick-<flavour>

installs a meta package that will keep the driver updated whenever the kernel updates (flavour is the kernel flavour installed, eg. generic).

For Lucid I am about to establish the same: see bug #606278. Whoever still runs Lucid and sees a call for testing in that bug report, please help to get this through by giving feedback. Thanks.

strikton (ton-strik) wrote :

This works fine, but is in my view still not acceptable, as touch (fingers) is not working.

strikton (ton-strik) wrote :

Apart from that, now the pen accepts no further clicking after one touch. And the buttons are not working anymore.

Still issue in Precise?

Raúl Soriano (gatoloko) wrote :

Precise works for me with a CTH-460-DE. Ripps ppa was properly disabled during upgrade to precise, and it's working without it.

Autodetection works, pen works, touch works, xsetwacom works (only tried to list devices and disable touch).

SapphirePaw (sapphirepaw) wrote :

My Bamboo Pen has worked for me in Precise since at least the final alpha (first one I checked). I'm on a fresh install of Kubuntu 12.04 x86-64 final now, which is still working.

xsetwacom also seems to work, as I changed the active area to fit screen proportions via kde-config-tablet.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Released
Luis Henriques (henrix) wrote :

From previous comments, I am tagging this as verified in precise.

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :
Download full text (21.0 KiB)

This bug was fixed in the package linux - 3.2.0-25.40

---------------
linux (3.2.0-25.40) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1003534

  [ Andy Whitcroft ]

  * [Config] control.stub is an intermediate product not a dependancy
    - LP: #992414
  * [Config] include include/generated/compile.h
    - LP: #942569

  [ Dave Martin ]

  * SAUCE: rtc: pl031: Enable module alias autogeneration for AMBA drivers
    - LP: #1000831

  [ Herton Ronaldo Krzesinski ]

  * Revert "SAUCE: ite-cir: postpone ISR registration"
    - LP: #1002484
  * SAUCE: async_populate_rootfs: fix build warnings
    - LP: #1003417

  [ Ike Panhc ]

  * [Config] add highbank flavour
    - LP: #1000831

  [ John Johansen ]

  * SAUCE: apparmor: fix long path failure due to disconnected path
    - LP: #955892
  * SAUCE: apparmor: fix profile lookup for unconfined
    - LP: #978038, #987371

  [ Mark Langsdorf ]

  * SAUCE: arm highbank: add support for pl320-ipc driver
    - LP: #1000831

  [ Rob Herring ]

  * SAUCE: input: add a key driver for highbank
    - LP: #1000831
  * SAUCE: ARM: highbank: Add smc calls to enable/disable the L2
    - LP: #1000831
  * SAUCE: force DMA buffers to non-bufferable on highbank
    - LP: #1000831
  * SAUCE: net: calxedaxgmac: fix net timeout recovery
    - LP: #1000831

  [ Tim Gardner ]

  * [Config] perarch and indep tools builds need separate build directories
  * [Config] CONFIG_XEN_ACPI_PROCESSOR=y
    - LP: #898112

  [ Upstream Kernel Changes ]

  * Revert "autofs: work around unhappy compat problem on x86-64"
    - LP: #1002482
  * Input: wacom - cleanup feature report for bamboos
    - LP: #568064
  * Input: wacom - remove unused bamboo HID parsing
    - LP: #568064
  * Input: wacom - add some comments to wacom_parse_hid
    - LP: #568064
  * Input: wacom - relax Bamboo stylus ID check
    - LP: #568064
  * Input: wacom - read 3rd gen Bamboo Touch HID data
    - LP: #568064
  * Input: wacom - 3rd gen Bamboo P&Touch packet support
    - LP: #568064
  * Input: wacom - ignore unwanted bamboo packets
    - LP: #568064
  * HID: wacom: Move parsing to a separate function
    - LP: #568064
  * HID: wacom: Initial driver for Wacom Intuos4 Wireless (Bluetooth)
    - LP: #568064
  * Input: wacom - add support for Cintiq 24HD
    - LP: #568064
  * Input: wacom - add LED support for Cintiq 24HD
    - LP: #568064
  * Input: wacom - add missing LEDS_CLASS to Kconfig
    - LP: #568064
  * Input: wacom - fix 3rd-gen Bamboo MT when 4+ fingers are in use
    - LP: #568064
  * power_supply: allow a power supply to explicitly point to powered
    device
    - LP: #568064
  * power_supply: add "powers" links to self-powered HID devices
    - LP: #568064
  * HID: wiimote: fix invalid power_supply_powers call
    - LP: #568064
  * HID: wacom: Fix invalid power_supply_powers calls
    - LP: #568064
  * ARM: 7178/1: fault.c: Port OOM changes into do_page_fault
    - LP: #951043
  * ARM: 7368/1: fault.c: correct how the tsk->[maj|min]_flt gets
    incremented
    - LP: #951043
  * hugepages: fix use after free bug in "quota" handling
    - LP: #990368
    - CVE-2012-2133
  * provide disable_cpufreq() functio...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers