gvfsd-archive incorrectly mounts bluray/udf iso

Bug #540390 reported by Wouter van Wijk on 2010-03-17
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs
Confirmed
Low
Unassigned
Baltix
Undecided
Unassigned

Bug Description

Binary package hint: gvfs

I tried to mount a bluray iso file via gvfsd-archive. It doesn't do it well. No files are listed in the mounted archive on my desktop. When I use this command:
mount -o loop -t udf myiso.iso /media/mountediso
it works ok and I can see all files in the directory.

Pedro Villavicencio (pedro) wrote :

Which version of Ubuntu are you running? how are you mounting the files?

Changed in gvfs (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Wouter van Wijk (woutervanwijk) wrote :

I'm running Karmic. I tried to mount the Iso's via the Archive Mounter in the contextmenu of the iso-files (in Nautilus). The iso is then mounted as a drive on the desktop, but the bluray-iso's are empty. The strange thing is that if I mount them via the commandline using the udf flag, all is ok.

description: updated
Changed in gvfs (Ubuntu):
status: Incomplete → New
Jalink (fantasyzer) wrote :

same here

richud (richud.com) wrote :

this bug is annoying and has been well known for ages!

if anyone fances fixing it could I suggest a feature of also being able to mount img files and img files with mbr/partitions (using an offset)

Paul M Edwards (paul-m-edwards) wrote :

This is still an issue in 10.10.

Federico Raimondo (fraimondo) wrote :

Confirmed on ubuntu 11.10 x86_64 up to date.

Changed in baltix:
status: New → Confirmed
Changed in gvfs (Ubuntu):
status: New → Confirmed
wrigley (wrigleyster) wrote :

a pleasant work around is to use the gnome-disk-image-mounter, which does the job perfectly, and also leaves a cleaner entry in the output of `mount`

wrigley (wrigleyster) wrote :

btw, gvfsd-archive and gvfs-mount still have trouble mounting iso-files. apparently sometimes the work, but most times they don't (with the files I have anyhow). but as stated above gnome-disk-image-mounter works brilliantly.

wrigley (wrigleyster) wrote :

sorry, about the spam: ...still don't work in 12.10

liquider (liquiderz) on 2013-01-30
affects: gvfs (Ubuntu) → gvfs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers