The printing in multifunction Samsung SCX-4200 is correctly recognized but Xsane doesn't recognize the device. Please add "usb 0x04e8 0x341b" into /etc/sane.d/xerox_mfp.conf

Bug #488070 reported by Gelam on 2009-11-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
sane-backends (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libsane

1) edubuntu version 9.10
2) xsane version 0.996-2 ubuntu1
3) recognition of the scanner
4)Answer of Xsane "non è disponibile nessun dispositivo"

I found, thay Samsung SCX-4200 scanner works fine with the xerox mfp driver (look at http://lists.alioth.debian.org/pipermail/sane-devel/2009-June/025028.html ).
Please add USB ID of SCX-4200 into /etc/sane.d/xerox_mfp.conf - this is just one line:

echo "usb 0x04e8 0x341b" >> /etc/sane.d/xerox_mfp.conf

I can confirm, that this works fine with my Samsung SCX-4200 (I've started xsane from root user, because scanner device file has wrong permissions, it seems udev rules should be tweaked...)

ProblemType: Bug
Architecture: i386
Date: Wed Nov 25 08:22:28 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Edubuntu 9.10 "Karmic Koala" - Release i386 (20091029)
Package: libsane
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: sane-backends
Uname: Linux 2.6.31-14-generic i686

Gelam (gennaro-lamuraglia) wrote :
affects: nautilus (Ubuntu) → xsane (Ubuntu)
affects: xsane (Ubuntu) → nautilus (Ubuntu)
affects: nautilus (Ubuntu) → xsane (Ubuntu)
Linas U. (linas77) on 2010-03-07
summary: - The printing multifunzione Samsung SCX-4200 is correctly recognized but
- Xsane doesn't recognize the device. If I insert the CD, the icon
- disappears from the resources of the computer and is not possible to
- visualize the content of the same CD.
+ The printing multifunzione Samsung SCX-4200 is correctly recognized but
+ Xsane doesn't recognize the device. Please add "usb 0x04e8 0x341b" into
+ /etc/sane.d/xerox_mfp.conf
Linas U. (linas77) on 2010-03-07
summary: - The printing multifunzione Samsung SCX-4200 is correctly recognized but
- Xsane doesn't recognize the device. Please add "usb 0x04e8 0x341b" into
- /etc/sane.d/xerox_mfp.conf
+ The printing in multifunction Samsung SCX-4200 is correctly recognized
+ but Xsane doesn't recognize the device. Please add "usb 0x04e8 0x341b"
+ into /etc/sane.d/xerox_mfp.conf
Linas U. (linas77) wrote :

Assigning to correct package - file /etc/sane.d/xerox_mfp.conf from sane-backends source package should be patched to support scanner from Samsung SCX-4200 Multifunction device.

description: updated
affects: xsane (Ubuntu) → sane-backends (Ubuntu)

Gelam, Thanks!!!!!

Just did the same for my Samsung SCX-4623F and now works perfectly. In my case it was:
echo "usb 0x04e8 0x3434" >> /etc/sane.d/xerox_mfp.conf

For everyone else with a Samsung multifunction/scanner, you can get the appropriate vendor ID and product ID with "sane-find-scanner":
$> sane-find-scanner
found USB scanner (vendor=0x04e8 [Samsung], product=0x3434 [SCX-4623 Series]) at libusb:001:010

In my case sane-find-scanner was always reporting the proper scanner found, but then it was not listed by scanimage -L. Also, scanimage -d xerox_mfp:libusb:001:010 was failing with "Invalid argument" (not after adding the line to xerox_mfp.conf)

After adding my scanner conf line to use the xerox_mfp backend as above, scanning works perfectly with the Simple Scanner in Lucid.

aldebx (aldebx) wrote :

I confirm this solution to be valid for Samsung SCX multifunction sets. Thank you!

Changed in sane-backends (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

Inspecting the source tells me this should be fixed in quantal and raring. Can you please confirm?

Changed in sane-backends (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
assignee: nobody → Rolf Leggewie (r0lf)
status: Triaged → Incomplete
Rolf Leggewie (r0lf) wrote :

and it seems to be in precise as well.

$ grep 341 /etc/sane.d/xerox_mfp.conf
usb 0x04e8 0x341b
usb 0x04e8 0x341f

Rolf Leggewie (r0lf) on 2014-03-26
Changed in sane-backends (Ubuntu):
status: Incomplete → Fix Released
assignee: Rolf Leggewie (r0lf) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers