Guest session does not warn about temporary nature of files

Bug #435930 reported by Dan Tomlinson on 2009-09-24
108
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Baltix
Undecided
Unassigned
lightdm (Ubuntu)
Wishlist
Gunnar Hjalmarsson

Bug Description

Hi all,

this is not a bug per se, rather a request for a feature. One of the users I support has allowed someone to use his desktop using the "Guest Session", not realising that files saved during this session do not persist after logout. The person in question proceeded to do a good few hours work on the machine, saving files to the Guest Session desktop. They were of course extremely dismayed when they logged in again, only to find that their work has disappeared.

I think it would be a nice feature if, upon logging into the Guest Session, a splash screen appeared telling the user in no uncertain terms that any files they saved during the session would not persist after they logged out. I am a linux sysadmin and I was unaware of this property of the Guest Session and had to search online for an explanation for the behavior which, I'm sure you agree, is not ideal.

Thanks in advance,
Dan T.

affects: ubuntu → gdm-guest-session (Ubuntu)
Changed in gdm-guest-session (Ubuntu):
importance: Undecided → Wishlist
Changed in gdm-guest-session (Ubuntu):
status: New → Confirmed
importance: Wishlist → Medium
status: Confirmed → Triaged
summary: - Guest session does not warn about temporary nature of files.
+ Guest session does not warn about temporary nature of files
Gunnar Hjalmarsson (gunnarhj) wrote :

Please see http://ubuntuforums.org/showthread.php?t=1558808

In that tutorial I address the need to inform the guests in advance, but I also let them know that they actually can save files persistently. Whether people prefer to keep that latter opportunity 'secret' or not, I believe that the method described in the tutorial is close to an implementable solution to this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Matt Fischer (mfisch) on 2012-06-13
Changed in lightdm (Ubuntu):
importance: Undecided → Wishlist
Joe T (joseph-thomson) wrote :

My brother just lost several hours' worth of work because of this "feature" of Ubuntu. Needless to say, the chances of him ever considering using Ubuntu in the future are now precisely zero. As you can imagine, he was fairly vocal about what he thought of Ubuntu, and quite frankly, I couldn't think of anything to say in Ubuntu's defense.

Why would "Linux For Human Beings" assume that anyone knew about this behaviour? I've been using Ubuntu for many years and didn't know about it. As it stands, this is nothing less than Ubuntu deleting your files without asking and without warning.

I can't see any reason why this would be considered anything other than a bug in Ubuntu's design.

Changed in gdm-guest-session (Ubuntu):
status: Triaged → Invalid
Joe T (joseph-thomson) wrote :

Hi Gunnar,

What was the reason this was changed to invalid in gdm-guest-session?

Cheers.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2012-12-20 16:16, Joe T wrote:
> What was the reason this was changed to invalid in
> gdm-guest-session?

Simply that gdm-guest-session isn't even included in the Ubuntu archive any longer.

A few cycles ago the guest session feature was provided by gdm-guest-session, but now that code is included in lightdm instead, and it's unlikely that the fix of this bug will be backported to stable releases with gdm-guest-session.

Only that. I do agree with you that it's important that this design flaw is fixed soon, whether you consider it to be a "wishlist" bug or not.

Joe T (joseph-thomson) wrote :

Ah okay. I figured it would be something like that, but I just thought I'd check in case :)

Arnau Vàzquez (arnauvp) wrote :

My mother hit this bug this week when a cousin came home for an afternoon of work and the next day... it was all gone!
They called me and I thought: it makes sense, Mac OS guest session also deletes everything, maybe they didn't read the warning... but let me check. WHAT? No warning anywhere. Hard to defend a design decision like this...

Then I thought: maybe it's because their system is using 11.10, for sure it must be resolved now and I can defend my beloved Ubuntu. Silly me! This bug, which is probably ridiculously easy to solve (**2 dialog boxes**), is opened since 2009, and not only that... in Launchpad it is considered a "nice to have". Left me speechless.

I've been using Ubuntu since 5.04 and I love how it has progressed, it's so polished now and so friendly *on the surface* for even the most unexperienced users [ok there's the Unity love/hate thing]. I thought it had managed to merge the best of the Open Source philosophy with a strong user-oriented product vision, and that it would only be a matter of time that people would see this, maybe with Ubuntu running on their phones, same as the iPhone brought people to OSX. But I was wrong, otherwise this would be a critical-level bug and no new distro would ship without it fixed.

Now you can say: why don't you fix it yourself, this is how OpenSource works, etc, etc. But please note:
1) AFAIK some people are paid to work on Ubuntu,
2) gunnarhj **already solved this bug** in his Forums thread as a comment **from 2010** points out. All it takes is a Product Owner / UX manager to say: bring it in. But I guess that figure doesn't exist (I thought it was Mark S.) and so the user experience for people who don't know what 'sudo' is suffers and Ubuntu/Linux remains a niche OS for the geeks.

Best wishes,
Arnau

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2013-01-11 12:42, Arnau Vàzquez wrote:
> All it takes is a Product Owner / UX manager to say: bring it in.

Hmm.. The author and maintainer of lightdm, Robert Ancell, already did that in a sense when blessing this bug by setting the status of the gdm-guest-session task to "Triaged". Hence doing so for the lightdm task.

I do agree that this is an annoying design flaw, and I plan to 'convert' my code in the tutorial (which now resides at https://help.ubuntu.com/community/CustomizeGuestSession) to a patch. Once merged it would at least give us a warning at startup.

Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in gdm-guest-session (Ubuntu):
assignee: nobody → Shashank VRSN Sabniveesu (shashank16392)
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2013-01-19 19:36, Shashank VRSN Sabniveesu wrote:
> ** Changed in: gdm-guest-session (Ubuntu)
> Assignee: (unassigned) => Shashank VRSN Sabniveesu (shashank16392)

Hmm.. You marked yourself as an assignee for a package that no longer exists. If you are about to propose a solution to this bug, you'd better assign the lightdm task to yourself.

I have an own idea for a fix, so if you get stuck, please let me know. Maybe we can collaborate.

Changed in hundredpapercuts:
status: New → Confirmed
Adam Niedling (krychek) on 2013-10-14
tags: added: saucy
Changed in lightdm (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Robert Ancell (robert-ancell) wrote :

Can design please comment on the wording of the warning. As proposed, it is a warning dialog like this:

Title: 'Warning: Data will be deleted'
Content: 'Please be aware that this is a "guest session". It means that your data will be automatically deleted when you log out, and possible altered settings will be reset.'
Optional content: 'There is an exception: Files that you save in the folder /var/guest-data will be preserved.'

The optional content is not shown on a default install (it requires a sysadmin to create /var/guest-data).

no longer affects: gdm-guest-session (Ubuntu)

Can we do this more "systemically" than a dialog box? Perhaps some sort
of overlay (similar to the shutdown / restart overlay) on guest login?

As for language:

"Temporary Guest Session"

"All data created during this guest session will be deleted when you
logout or reboot, and settings will be reset to defaults. [Please save
files in /var/guest-data if you would like to access them again
later.][Please create /var/guest-data if you would like to save files
across guest sessions.]"

Clearly, use the sentence that's appropriate depending on the existence
of /var/guest-data :)

Thanks,
Mark

On 09/12/13 04:10, Robert Ancell wrote:
> Can design please comment on the wording of the warning. As proposed, it
> is a warning dialog like this:
>
> Title: 'Warning: Data will be deleted'
> Content: 'Please be aware that this is a "guest session". It means that your data will be automatically deleted when you log out, and possible altered settings will be reset.'
> Optional content: 'There is an exception: Files that you save in the folder /var/guest-data will be preserved.'
>
> The optional content is not shown on a default install (it requires a
> sysadmin to create /var/guest-data).
>
>
> ** Also affects: ayatana-design
> Importance: Undecided
> Status: New
>
> ** No longer affects: gdm-guest-session (Ubuntu)
>

Changed in hundredpapercuts:
importance: Undecided → Wishlist
no longer affects: hundredpapercuts
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.9.6-0ubuntu1

---------------
lightdm (1.9.6-0ubuntu1) trusty; urgency=medium

  * New upstream release:
    - Support Mir sessions in xlocal seats by starting a unity system compositor
      for each session.
    - Add --screen and --fullscreen options to "dm-tool add-nested-seat"
    - Don't try to compile liblightdm-qt if liblightdm-gobject will not be
      compiled.
    - Stop greeters warning if sessions directories not present or lightdm.conf
      doesn't exist - this is valid.
    - Fix log name for Mir display servers
    - Fix double removal of source IDs
  * debian/guest-account:
  * debian/guest-session-auto.sh:
  * debian/lightdm.install:
  * debian/rules:
    - Warn users about the temporary nature of a guest session. (LP: #435930)
  * debian/lightdm.install:
  * debian/lightdm.maintscript:
    - Move configuration from /etc to /usr/share so dpkg doesn't keep it around.
 -- Robert Ancell <email address hidden> Wed, 22 Jan 2014 15:51:29 +1300

Changed in lightdm (Ubuntu):
status: In Progress → Fix Released
Julian Foad (julianfoad) wrote :

This needs, at least, a warning at log-out time as well.

The new warning at log-in time is better than no warning at all but is still TOTALLY INSUFFICIENT. Ubuntu deletes the user's data at log-out time. The user that saved work and logged out may not be the user that launched the guest session: "here, use this computer, I've launched a guest session for you". Or the user that saves work may leave the computer logged in, intending to come back to it, maybe knowing that their work will be lost if they log out or maybe not knowing; and then their friend comes along and logs out the session, and gets not even a warning that their friend's data is now being deleted.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Julian: Please note that this bug is closed. Bug #1270788 is about a logout warning, so you may want to add your comment to that bug report too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers