Avoid picking 60Hz refresh rates for CRTs

Bug #39140 reported by Euan MacGregor on 2006-04-11
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Baltix
Medium
Unassigned
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Currently in Dapper the live CD (post flight 6, I think it's 20060411) boots into X with a resolution of 1920x1440@60Hz. I really don't like the flicker of this, so I prefer the biggest resolution that has a higher refresh rate (in this case, 1600x1200@75Hz). Obviously for TFTs this isn't a problem.

$ sudo xresprobe nvidia
id: SyncMaster
res: 1920x1440 1600x1200 1280x1024 1024x768 832x624 800x600 720x400 640x480
freq: 30-96 50-160
disptype: crt

0000:01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT] (rev a2)
aka 0000:01:00.0 0300: 10de:00f1 (rev a2)

(I manually installed and enabled the nvidia driver after booting)

(with nvidia driver)

There is no way to decide what is best for user A or B. This request conflicts with what tons of other users asked the other way around.

Fabio

Changed in xorg:
status: Unconfirmed → Rejected
Mantas Kriaučiūnas (mantas) wrote :
Download full text (4.1 KiB)

Fabio Massimo Di Nitto at 2006-04-27 17:13:34 EEST wrote:
> There is no way to decide what is best for user A or B.
> This request conflicts with what tons of other users asked the other way around.

It's not true - there is a simple way to check if CRT monitor supports 75 or 85 Hz mode at recommended resolution, so, there is no reason to select higher mode with 60 Hz refresh.

according to TCO99 standard vertical refresh frequency *must* be >=85Hz (look at Section 2 (Visual ergonomic
- Image stability) of TCO99:

http://www.tcodevelopment.com/pls/nvp/Upload.Show?CID=776&MID=141

There is simple table of mandatory resolutions and vertical refresh for CRT monitors:
CRT Size VRefresh Resolution
14"-15" >=85 Hz >=800x600
   17" >=85 Hz >=1024x768
19"-21" >=85 Hz >=1280x1024
  >21" >=85 Hz >=1280x1024

Btw, TCO99 recommended vertical refresh is 100Hz and I think it would be very nice to select according display mode if possible (if monitor could work with mandatory resolution at 100Hz)

Monitors vertical refresh depends on maximal horizontal sync, I can provide simple table for recommended modes:

800x600 @ 85Hz hsync: 53 kHz (low quality 15" monitors and good 14" have maximum hsync ~54 kHz)
1024x768 @ 85Hz hsync: 68 kHz (good 15" and low quality 17" monitors have maximum hsync ~70 kHz)
1152x864 @ 85Hz hsync: 77 kHz (most 17" monitors and low quality 19" have maximum hsync ~85 kHz)
1152x864 @ 100Hz hsync: 89 kHz (high-end 17" monitors and most 19" have maximum hsync ~95kHz)
1280x1024 @ 85Hz hsync: 91 kHz (most 19" and low quality 21" have maximum hsync ~95kHz)
1280x1024 @ 100Hz hsync: 107 kHz (high-end 19" and most 21" have maximum hsync ~110kHz)
1600x1200 @ 85Hz hsync: 106 kHz (most 21" have maximum hsync ~110kHz)

For example my old 17" Hansol 701P monitor is made at 1998 and supports only TCO95, it has maximal horizontal sync 85kHz and I usually use 1024x768 @ 100Hz and sometimes 1152x864 @ 85Hz

As you see, it's always safe to choose resolution with 85 Hz vertical refresh for all monitors, which has maximal hsync >=68 kHz, only low quality 15" monitors can't work with 1042x768 @ 85Hz and low quality 14" monitors can't do 800x600 @ 85Hz, so we can discuss which mode would be better for monitors, which horiz sync is less 68 kHz

If there are posibility to know real monitors CRT size, then we can set resolution with 100 Hz vertical refresh on 17" monitors with maximal hsync >= 89 kHz and 19" monitors with maximal hsync >= 107 kHz

There are lots of hardware and eyes safety sites, which recommend to use 800x600 on 14"-15", 1024x768 on 17" and don't recommend to use vertical refresh lower than 85 Hz, look for example at http://www.hwupgrade.com/monitor/index4.html

According TCO99 and TCO2003 85Hz is *mandatory* and 100Hz is recommended, so Ubuntu Linux developers should care about users eyes.

A quick search reveals that this is usually recommended by most:

http://www.health24.com/medical/Condition_centres/777-792-810-1692,29508.asp

"Most people use CRT (Cathode Ray Tubes) screens like TV screens. These screens have a single electron ray that has to light up dot after dot, line after line.
It does t...

Read more...

Mantas Kriaučiūnas wrote:
> Fabio Massimo Di Nitto at 2006-04-27 17:13:34 EEST wrote:
>> There is no way to decide what is best for user A or B.
>> This request conflicts with what tons of other users asked the other way around.
>
> It's not true - there is a simple way to check if CRT monitor supports 75 or 85 Hz mode at recommended resolution, so, there is no reason to select higher mode with 60 Hz refresh.
>
> according to TCO99 standard vertical refresh frequency *must* be >=85Hz (look at Section 2 (Visual ergonomic
> - Image stability) of TCO99:

You totally missed the point here. Users did ask for both situations:

- higher resolutions lower refresh rate
- lower resolutions higher refresh rate.

The 2 clashes and there is no way to make both of them happy.

> I don't understand the resistance shown by Ubuntu developers to offering the medically best resolution to non-technical users by default...
>
> Btw, I'm developer of Ubuntu-based distribution - Baltix GNU/Linux and I will improve default resolution choosing for CRT monitors method in Baltix distro if Ubuntu developers don't care about users health.
>
> ** Also affects: Baltix
> Severity: Normal
> Priority: (none set)
> Status: Unconfirmed
>

You did spend a great deal of time on urls and stuff. You are a developer, why
don't you spend your time providing a patch instead of whining?

Fabio

--
I'm going to make him an offer he can't refuse.

Changed in xorg:
status: Invalid → New
Bryce Harrington (bryce) wrote :

Could you please test this with Gutsy-final? Also, try booting the system with no xorg.conf (i.e. move /etc/X11/xorg.conf to /etc/X11/xorg.conf.orig) and see if it selects the 75Hz mode as the preferred.

Changed in xorg:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

No reply from the submitter, closing the bug.

Changed in xorg:
status: Incomplete → Invalid

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in baltix:
status: New → Invalid

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have marked this Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in xorg (Ubuntu):
status: Invalid → Incomplete
Yuhong Bao (yuhongbao-386) wrote :

IMO the solution is to try to detect whether a LCD or a CRT is present and only pick the highest resolution in the list when the former is present.

Bryce Harrington (bryce) wrote :

I disagree; there are many CRTs for which highest resolution is the best option. CRTs are also very much on the wane now, so I don't think this is worth doing anything in Ubuntu to change.

If you disagree, I would encourage you to take the issue upstream and get it fixed more properly there.

Changed in xorg (Ubuntu):
status: Incomplete → Won't Fix
Changed in baltix:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments