brasero 0.8.0 from Intrepid contains lots of important bugfixes, please backport to 8.04 LTS (Hardy)

Bug #248083 reported by Mantas Kriaučiūnas on 2008-07-13
8
Affects Status Importance Assigned to Milestone
Hardy Backports
Wishlist
Unassigned
Baltix
Undecided
Unassigned

Bug Description

Brasero CD/DVD burner from Ubuntu 8.04 LTS Hardy has lots of bugs, new version 0.8.0 from Intrepid contains lots of important bugfixes, please backport. I'm pasting Ubuntu changelog:

brasero (0.8.0-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #247609)
    - Make brasero.desktop follow freedesktop
    - Brasero can't find a proper cd/dvd drive on Solaris
    - Build failure againts gtk+ trunk
    - Brasero crashes with libburn backend
    - Speed is not displayed
    - Can't add files from FAT32 partitions
    - Not displaying drive speed
    - toc image type not autodetected correctly
  * debian/patches/010_lpi.patch:
    - Refresh for new release
  * 013_disable_deprecated.patch:
    - Disable DGTK_DISABLE_DEPRECATED to fix FTBFS
  * debian/control:
    - Suggests gstreamer0.10-plugins-bad for normalize plugin

 -- Pedro Fragoso <email address hidden> Tue, 15 Jul 2008 00:51:52 +0100

brasero (0.7.91-0ubuntu1) intrepid; urgency=low
  * New upstream release (LP: #239524)
    - Fixed odd burning speeds (LP: #178482) (LP: #177124)
    - Cancel dialog buttons' wording is confusing (LP: #195083)
    - Support for DL DVDs (LP: #202206)
    - Brasero does not recognize .bin in the same directory
      when .cue is selected (LP: #202546)
    - Brasero does not save user settings (LP: #220352)
    - Can't set tmp dir and can't burn image if size > available
      on /tmp (LP: #226209)
    - Migrate from GnomeVFS to GIO (LP: #198771)
    - Preview disabled calls a video window (LP: #198497)
    - Brasero crashes in strlen () when debug mode is on (LP: #225405)
  * debian/control.in:
    - Remove Build depend on libgnomevfs2-dev (>= 2.14.2),
      libnautilus-burn-dev (>= 2.16.0), libnotify-dev
    - Bump Build depend libglib2.0-dev to (>= 2.15.6)
    - Bump Build depend libgstreamer0.10-dev to (>= 0.10.15)
    - Bump Build depend libtotem-plparser-dev to (>= 2.22.0)
    - Add Build depend on gnome-doc-utils (>= 0.3.2) and
      liblaunchpad-integration-dev
    - Bump Standards-Version to 3.8.0
  * debian/patches/007-fix-desktop-file-mime-typo.patch:
    - Dropped, merged upstream
  * debian/patches/010_lpi.patch:
    - Add launchpad-integration
  * debian/patches/012_gnome-doc-utils.make.patch
    - Add missing gnome-doc-utils.make to fix FTBFS
  * debian/rules:
    - Add --disable-scrollkeeper
  * Modify Maintainer value to match the DebianMaintainerField
    specification.
 -- Pedro Fragoso <email address hidden> Thu, 03 Jul 2008 23:03:40 +0100

You can look at original news file at http://svn.gnome.org/viewvc/brasero/trunk/NEWS?view=markup

Jean Levasseur (levasseur.jean) wrote :

Hi! There is a diff for new stable upstream version submitted by Pedro Fragoso (ember) for inclusion in intrepid (LP #247609). It has not been approved yet, but I still made a backport from it to hardy. Since I do not have a .dsc file from the intrepid version yet, I make a diff from the plain source (downloaded from ftp.gnome.org) to the one containing the debian/ directory. Builds well for me on hardy, and the source is sent to my ppa (https://launchpad.net/~foxmike/+archive) for testing.

Actually, there was a little mistake in the diff file uploaded, in the
version number in the changelog. Here is the updated diff (gzipped,
this time!).

Le mardi 15 juillet 2008 à 20:21 +0000, Jean Levasseur a écrit :
> Hi! There is a diff for new stable upstream version submitted by Pedro
> Fragoso (ember) for inclusion in intrepid (LP #247609). It has not been
> approved yet, but I still made a backport from it to hardy. Since I do
> not have a .dsc file from the intrepid version yet, I make a diff from
> the plain source (downloaded from ftp.gnome.org) to the one containing
> the debian/ directory. Builds well for me on hardy, and the source is
> sent to my ppa (https://launchpad.net/~foxmike/+archive) for testing.
>
>
> ** Attachment added: "Patch to apply to plain brasero-0.8.0 source"
> http://launchpadlibrarian.net/16047221/brasero-0.8.0.diff
>
> --
> brasero 0.7.91 from Intrepid contains lots of important bugfixes, please backport
> https://bugs.launchpad.net/bugs/248083
> You received this bug notification because you are a member of Ubuntu
> Backports Testing Team, which is subscribed to Hardy Backports.
>

Update:

I sent the package to my ppa. Anyone that wants to try it out:
https://launchpad.net/~foxmike/+archive

Regards,

Jean.

description: updated

This builds without changes from the intrepid source package. Confirmed this as a valid backport. Build, installs, and runs without issues. Tested version: 0.8.1-0ubuntu2

Changed in hardy-backports:
importance: Undecided → Wishlist
status: New → Triaged
Scott Kitterman (kitterman) wrote :

Ack from ubuntu-backporters.

Changed in hardy-backports:
status: Triaged → In Progress
Steve Langasek (vorlon) wrote :

 * Trying to backport brasero...
  - <brasero_0.8.1-0ubuntu2.dsc: downloading from librarian>
  - <brasero_0.8.1-0ubuntu2.diff.gz: downloading from librarian>
  - <brasero_0.8.1.orig.tar.gz: downloading from librarian>
I: Extracting brasero_0.8.1-0ubuntu2.dsc ... done.
I: Building backport of brasero-0.8.1 as 0.8.1-0ubuntu2~hardy1 ... done.

Changed in hardy-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers