[Needs Packaging] Please package gnome-getting-started-docs and gnome-initial-setup

Bug #1161583 reported by Mantas Kriaučiūnas
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Baltix
Triaged
High
Mantas Kriaučiūnas
Fedora
Fix Released
Undecided
gnome-getting-started-docs (Debian)
Fix Released
Unknown
gnome-initial-setup (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Please package gnome-getting-started-docs and gnome-initial-setup:
http://ftp.gnome.org/pub/GNOME/sources/gnome-getting-started-docs/
http://ftp.gnome.org/pub/GNOME/sources/gnome-initial-setup/

gnome-getting-started-docs package contains a very intuitive 'Getting Started' guide (with video guides), that can be viewed with Yelp. It is normally used together with gnome-initial-setup, but is also very useful as tutorial and 'users guide' for new (or not experienced) users.

I think Ubuntu GNOME Remix should include these packages as default, because they are very important for most users - GNOME Shell is too different from other desktop environments and most users needs simple training tutorial.

gnome-initial-setup licence: GNU General Public License version 2 or later
gnome-getting-started-docs license: Creative Commons Attribution-ShareAlike 3.0 Unported

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :

This package contains a 'Getting Started' guide that can be viewed
with yelp. It is normally used together with gnome-initial-setup.

spec file: http://mclasen.fedorapeople.org/gnome-getting-started-docs.spec
srpm: http://mclasen.fedorapeople.org/gnome-getting-started-docs-3.7.2-1.fc18.src.rpm

Revision history for this message
In , Yanko (yanko-redhat-bugs) wrote :

Missing BuildArch: noarch

Otherwise,
Source matches.
License matches (after upstream fixes it COPYING file)
Builds in mock
rpmlint is silent.

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :
Revision history for this message
In , Yanko (yanko-redhat-bugs) wrote :

W: incoherent-version-in-changelog 3.7.2-1 ['3.7.3-1.fc19', '3.7.3-1']
- assume will be fixed
As discussed on IRC
- the COPYING file upstream will be replaced by http://creativecommons.org/licenses/by-sa/3.0/legalcode.txt

Builds in mock.

APPROVED

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :

New Package SCM Request
=======================
Package Name: gnome-getting-started-docs
Short Description: Helps a new user get started in GNOME
Owners: magcius, mclasen

Revision history for this message
In , Gwyn (gwyn-redhat-bugs) wrote :

Git done (by process-git-requests).

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :

build done

description: updated
tags: added: needs-packaging
summary: - Please package gnome-getting-started-docs and gnome-initial-setup
+ [Needs Packaging] Please package gnome-getting-started-docs and gnome-
+ initial-setup
Revision history for this message
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Changed in debian:
status: Unknown → New
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Debian developer already packaged gnome-getting-started-docs, see:
http://anonscm.debian.org/viewvc/pkg-gnome/packages/experimental/gnome-getting-started-docs/

Changed in baltix:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
Changed in baltix:
importance: Medium → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Latest gnome-getting-started-docs packaging code is moved to unstable, see:
http://anonscm.debian.org/viewvc/pkg-gnome/packages/unstable/gnome-getting-started-docs

Changed in debian:
status: New → Fix Released
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

gnome-getting-started-docs (3.12.0-1) is already uploaded to Ubuntu 14.10 (Utopic) and are backported to ppa:gnome3-team/gnome3-staging
See https://launchpad.net/~gnome3-team/+archive/gnome3-staging

Please add Lithuanian translation and upload into Baltix GNU/Linux repository :)

Revision history for this message
Jeremy Bicha (jbicha) wrote :

gnome-initial-setup is available in Ubuntu 16.10; in fact it's included in Ubuntu GNOME 16.10. gnome-getting-started was packaged earlier. (Please file separate bugs next time!)

affects: ubuntu → gnome-initial-setup (Ubuntu)
Changed in gnome-initial-setup (Ubuntu):
status: Confirmed → Fix Released
affects: debian → gnome-getting-started-docs (Debian)
Changed in fedora:
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.