back up specific "hidden" files or directories

Bug #995925 reported by andré on 2012-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Back In Time
Fix Released
Medium
Unassigned

Bug Description

Cannot selection specific hidden files or directories when configuring a backup profile.

e.g. I want to backup ~/.mozilla/seamonkey/, but not all of ~/*

However the graphical interface does not show any hidden files, so I can't select them.
(The "hidden files" button in the main window does not affect the profile selection window.)
One can type the name with path, but nothing I have tried adds this name/path to the selection list.
If one selects by the selection window, it goes to Nautilus, but one can't select a directory unless it has no subdirectory.
Once a subdirectory has been selected, there is no way to modify the selection to arrive at the desired directory.

The fix would be to show all files (including "hidden"), either always or as an option.
If as an option, it could be according to the "hidden files" button in the main window.

Germar (germar) on 2013-09-11
Changed in backintime:
status: New → Triaged
importance: Undecided → Medium
Germar (germar) wrote :

I tried to fix this but there are some problems:
- for Gnome there is already a function to show hidden files in file-dialog if 'show hidden files' is active in main window. But due to a bug in Gtk this doesn't work.
- for KDE there is no function to show hidden files in file-dialog.

I spend couple hours to find a solution for these problems and I'm sorry to say that I failed. But with both Gnome and KDE you can right-click in file-dialog and activate 'show hidden files' to add them to include and exclude lists.

Changed in backintime:
status: Triaged → Confirmed
Germar (germar) on 2013-12-12
Changed in backintime:
milestone: none → 1.1.0
Germar (germar) on 2014-04-02
Changed in backintime:
status: Confirmed → Fix Committed
Germar (germar) on 2015-01-15
Changed in backintime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers