BiT icon no longer displayed in notification area

Bug #658424 reported by Calcipher on 2010-10-11
38
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Back In Time
Fix Released
Undecided
Unassigned

Bug Description

This might be a 'feature' that was implemented, but in Ubuntu 10.10x64 BiT no longer displays its icon in the notification area while it is working. The icon does display if BiT has a notification (e.g. cannot find backup medium).

Calcipher (calcipher) wrote :

Update: I am using BiT 0.9.99.80.

Dan (danleweb) wrote :

I just tested BIT 1.0.2 in Ubuntu 10.10 x64 and I do have the systray icon.

Calcipher (calcipher) wrote :

Ah, I'll just have to wait for the Maverick repo to be open then.

Dan (danleweb) wrote :

Well there is: try stable ppa :)

Calcipher (calcipher) wrote :

Stable repositories!? Pffft, what's the fun in that? (Actually, I just switched. Are you going to abandon the testing PPA?)

Dan (danleweb) wrote :

No, but testing PPA is for dev/testing versions, stable PPA is for stable versions.

Dan (danleweb) wrote :

PS: does it works now ?

Calcipher (calcipher) wrote :

I am not getting the icon during activity from BiT. Further, all of this made me realise two additional things. First, I haven't been getting the "Cannot find backup medium" (or whatever the wording is) messages when I do not have my external hard drive attached. Second, I have not gotten any notifications that my backups have been failing since my update to 10.10 (I have partial backups set to save so no biggie, but it seem to be having problems on some file in my Windows partition that was always updated fine before).

Anything I can do to test or should I just assume this is a problem with my install?

Dan (danleweb) wrote :

Try to run it manually and check error log.

Calcipher (calcipher) wrote :

Ok, sorry it took me so long to get back to you on this, but running gksu backintime-gnome from the command line and starting a backup results in the BiT icon showing up in the system tray. I don't think I mentioned it, but I use the BiT (as root) option over the standard one so that I can backup things from other accounts. Might this be why I've lost my tray icon normally?

Dan (danleweb) wrote :

This is true, if BIT take a snapshot as another user as the one logged in (even if it is root) the systray icon may not be work.

Calcipher (calcipher) wrote :

Ah, it used to show up in 10.04. You know, I always thought it was a bit weird because I could cancel BiT's stuff by right clicking on that icon despite the fact that the process was supposed to be as root. I do, however, miss the status updates and indication that it is running.

Dan (danleweb) wrote :

BIT does not support cancel !!!

BIT does try to display systray icon. Maybe the version of applications, libraries or python bindigs don't allow this.

Calcipher (calcipher) wrote :

Yeah, I realise it doesn't have cancel, but it was, at some point, possible to kill off the individual thing that the BiT icon was telling you it was doing by double clicking on the icon. Perhaps the 'cancel' was just to cancel the box that used to pop up.

As far as the invisible tray icon. Is there anything I can do to bring it back or is it gone for 10.10?

Dan (danleweb) wrote :

I don't really know because BIT does not do anything specific: it use the same code on all distributions/versions.
Just as a test: start the GUI (as root but while you are logged in as a normal user) and take a snapshot manually. Does systray icon show up ? If is does run "xhost +" from command line and can schedule automatic backups for every 5 min. Then wait to see is the systray icon show up every 5 min.

Calcipher (calcipher) wrote :

Sorry for the long delay here, I've been moving. When I ran the GUI (root) while logged in as a normal user I did/do get the systray icon. With xhost access control disabled I do get the notifications.

Dan (danleweb) wrote :

So the systray icon is always missing when run from cron.

Calcipher (calcipher) wrote :

I assume this is the case with the exception of times when xhost + has been run (indeed, running xhost - causes BiT to, again, not display its notifications/icon).

Dan (danleweb) wrote :

This means that BIT won't have to right to connect to X server.
There is nothing I can do about.

Calcipher (calcipher) wrote :

Is there something I can do about this and/or is this expected behavior?

Dan (danleweb) wrote :

You can read xhost man to see how to allow root to access xserver.
There is nothing I can do from BIT.

Calcipher (calcipher) wrote :

Yeah, sorry I poorly worded my question, but i was more trying to get at if this was a 'feature' of Ubuntu 10.10 or if it is some weird thing I did somehow.

Dan (danleweb) wrote :

I'm not sure that running root cron jobs alowed to access xserver in Ubuntu 10.04.
If it used to I think it was an error.

Calcipher (calcipher) wrote :

Well, given all of that, feel free to close the bug report with a 'won't fix' then. Thanks for the time and I suppose it isn't really that big of an issue.

I also see this behaviour but including when running from cron as my normal user. It means that there is no indication of a failed backup, so it could be failing for weeks before the user realises.

Philip Guyton (phil-lxnet) wrote :

Could this be a unity related issue? Appeared in Ubuntu 10.10 now default in 11.10.

I have just installed backintime 1.0.8-1 in clean install of 11.10 with Unity desktop and get no notifications either when running manually via gui snapshot button or when a normal user schedules a backup and that backup runs.

Great program by the way, I am an avid user and install for all my linux clients now.

But the notifications were great, having had feedback from clients who are reassured by them. Otherwise there is no indication of anything ever happening without opening the gui.

Thanks again. Let me know if I can do anything to help. I believe the notification system in Unity has changed a little, not sure of the details though. My example is on a clients machine but I am happy to setup and test what every you like to get this going again.

Philip Guyton (phil-lxnet) wrote :

Forgot to mention my finding of this:-
"Back In Time does not show progress in systray in Unity"
https://bugs.launchpad.net/ubuntu/+source/backintime/+bug/881851

Dan (danleweb) wrote :

By default Unity don't allow all notifications.

You can try this:
    http://www.addictivetips.com/ubuntu-linux-tips/enable-system-tray-notification-for-all-applications-in-ubuntu-11-04/
to re-enable them.

Regards,
Dan

Trevor Mettam (metamorfeus) wrote :

Bump!

This bug has manifested since my upgrade from 12.04 to 13.04 I never had a problem with the missing icon since v0.9 of BiT.

Is it perchance trying to use a stock icon image which no longer exists or has been renamed?

Germar (germar) wrote :

This is not a bug in Backintime but a "feature" in Unity. Ubuntu Unity doesn't allow applications to show a systray icon anymore by default. According to the link Dan posted in #28 you can run:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'backintime', 'backintime-gnome']"

to fix this.

Changed in backintime:
status: New → Confirmed
Trevor Mettam (metamorfeus) wrote :

Would that it were, but I am using the MATE desktop environment, and I'm still not seeing the BiT 'in-progress' icon on the system notification panel.

Germar (germar) wrote :

You're right. I just double checked with Mint 15 Mate Live-CD. I'll investigate further why it isn't shown on Mate (Cinnamon is fine)

Neil Padgett (sackwort) wrote :

I can't get BiT notifications to work in Ubuntu 13.10, and I've read that the systray-whitelist is now obselete. (http://www.webupd8.org/2013/02/unity-notification-area-systray.html). Is there any other way to get BiT notifications working?

Germar (germar) wrote :

Nope. If Canonical deleted whitelisting there is no way to show systray-icons anymore. They force everyone to use AppIndicators. But while BIT isn't ported to Gtk+ 3.x AppIncicators won't work neither.

Germar (germar) wrote :

@Trevor Mate dev's renamed all gnome tools. 'gnome-settings-daemon' is now 'mate-settings-daemon'. That's why the systray-icon-plugin doesn't start anymore. It will be fixed with next release.

Germar (germar) on 2013-12-12
Changed in backintime:
milestone: none → 1.1.0
Germar (germar) on 2014-04-02
Changed in backintime:
status: Confirmed → Fix Committed
Germar (germar) on 2015-01-15
Changed in backintime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers