BackInTime karmic package missing depends on menu

Bug #466088 reported by Ryan Ahearn
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Back In Time
Invalid
Undecided
Unassigned
backintime (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Martin Pitt
Karmic
Undecided
Unassigned

Bug Description

The Back In Time (root) launcher as shipped in karmic calls the program su-to-root. This program is not installed on a base Ubuntu machine, but menu (The package containing su-to-root) is not listed as a dependency.

Impact
--------
On a base Karmic or Lucid system both of the Backintime front-ends have an undeclared dependency, which results in them failing to launch as root from the menu system.

TEST CASE:
----
Install a base system and either of the BiT front-ends. Ensure the 'menu' package is not installed if it has been pulled in by another dependency. From the menu, choose to run BiT as root and no window appears.

Fix:
-----
The patch listed from git in an above post adds a dependency on menu for both front-end packages. Sponsorship is required because I am not a Ubuntu developer.

Regression potential is very low. This fix has been thoroughly tested in Debian and has some, but less, testing in Ubuntu.

description: updated
Changed in backintime:
status: New → Invalid
Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

Is menu installed by default as part of a desktop system? If not, this dependency may have other consequences.

Revision history for this message
Ryan Ahearn (ryan-c-ahearn) wrote :

No, it is not installed by default as part of a desktop system, which is why this is a problem. It's certainly not invalid though, either the dependency needs to be installed or the launcher for Back In Time (root) needs to not use su-to-root. Leaving it as is is just broken.

Changed in backintime:
status: Invalid → New
Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

This is a packaging bug because of a patch applied in Debian, not an upstream bug, which is why it's invalid in backintime but confirmed in backintime (Ubuntu). Please leave it like that.

Ubuntu MOTUs: the following trivial patch should suffice and will be applied in the next Debian upload, but needs backporting to a Karmic point release please:

https://robin.powdarrmonkey.net/cgi-bin/gitweb.cgi?p=backintime;a=commitdiff;h=526b5281411e500dbd603c4a08a25c970727faaa#patch1

Changed in backintime:
status: New → Invalid
Changed in backintime (Ubuntu):
status: New → Confirmed
Revision history for this message
Felix Zweig (f.zweig) wrote :

Why don't you just change the starter to use "gksu" instead of "su-to-root"?

Revision history for this message
Ryan Ahearn (ryan-c-ahearn) wrote :

If you use gksu you have to maintain separate versions of the launcher in the gnome and kde packages. Using su-to-root lets the launcher stay in the common package.

Revision history for this message
Felix Zweig (f.zweig) wrote :

Seems reasonable. However, the launcher starts "su-to-root backintime-gnome" and is included in the backintime-gnome package. backintime-kde also has it's own launcher, while backintime-common doesn't include one.

Revision history for this message
Ryan Ahearn (ryan-c-ahearn) wrote :

Good point, never mind my comment.

Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

su-to-root tries many different ways to get root, and respects local administrator's wishes. It can leverage sudo instead of plain su. Using it minimises dependency bloat for BiT (why depend on kdesudo when the administrator wants sux?) and mean that the two front ends are interchangable. The only reason for the karmic borkage is a missing dependency on

The common package has no launcher because it has no front end.

Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

that is, a missing dependency on menu.

Revision history for this message
Bart de Koning (bratdaking) wrote : Re: [Bit-team] [Bug 466088] Re: BackInTime karmic package missing depends on menu

Upstream we use gksu, it is changed to su-to-root in the ubuntu packages,
however it seems to be a very neat solution for a common encountered
problem.
Are there any strong arguments not to switch upstream, eg what is the
availability of su-to-root on other distributions, like Suse, or Fedora, or
is it a specific ubuntu implementation?

2009/12/4 Jonathan Wiltshire <email address hidden>

> that is, a missing dependency on menu.
>
> --
> BackInTime karmic package missing depends on menu
> https://bugs.launchpad.net/bugs/466088
> You received this bug notification because you are a member of Back In
> Time Team, which is subscribed to Back In Time.
>
> Status in Back In Time: Invalid
> Status in “backintime” package in Ubuntu: Confirmed
>
> Bug description:
> The Back In Time (root) launcher as shipped in karmic calls the program
> su-to-root. This program is not installed on a base Ubuntu machine, but
> menu (The package containing su-to-root) is not listed as a dependency.
>
>
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~bit-team<https://launchpad.net/%7Ebit-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~bit-team<https://launchpad.net/%7Ebit-team>
> More help : https://help.launchpad.net/ListHelp
>

Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote : Re: [Bit-team] [Bug 466088] Re: BackInTime karmic package missing depends on menu

On Mon, Dec 07, 2009 at 01:06:57PM -0000, Bart de Koning wrote:
> Upstream we use gksu, it is changed to su-to-root in the ubuntu packages,
> however it seems to be a very neat solution for a common encountered
> problem.
> Are there any strong arguments not to switch upstream, eg what is the
> availability of su-to-root on other distributions, like Suse, or Fedora, or
> is it a specific ubuntu implementation?

It was originally a Debian tool and I don't know whether it has been
integrated into any other distributions. A quick Google suggests not, so
you should probably not change it upstream.

You could generate it at build-time if the building system is Debian-based,
but that's probably over-engineering it. The patch isn't exactly a big
delta.

--
Jonathan Wiltshire

1024D: 0xDB800B52 / 4216 F01F DCA9 21AC F3D3 A903 CA6B EA3E DB80 0B52
4096R: 0xD3524C51 / 0A55 B7C5 1223 3942 86EC 74C3 5394 479D D352 4C51

Revision history for this message
Bart de Koning (bratdaking) wrote : Re: [Bit-team] [Bug 466088] Re: BackInTime karmic package missing depends on menu

OK, thanks for the information, most probably we will stick to gksu then...

2009/12/7 Jonathan Wiltshire <email address hidden>

> On Mon, Dec 07, 2009 at 01:06:57PM -0000, Bart de Koning wrote:
> > Upstream we use gksu, it is changed to su-to-root in the ubuntu packages,
> > however it seems to be a very neat solution for a common encountered
> > problem.
> > Are there any strong arguments not to switch upstream, eg what is the
> > availability of su-to-root on other distributions, like Suse, or Fedora,
> or
> > is it a specific ubuntu implementation?
>
> It was originally a Debian tool and I don't know whether it has been
> integrated into any other distributions. A quick Google suggests not, so
> you should probably not change it upstream.
>
> You could generate it at build-time if the building system is Debian-based,
> but that's probably over-engineering it. The patch isn't exactly a big
> delta.
>
>
> --
> Jonathan Wiltshire
>
> 1024D: 0xDB800B52 / 4216 F01F DCA9 21AC F3D3 A903 CA6B EA3E DB80 0B52
> 4096R: 0xD3524C51 / 0A55 B7C5 1223 3942 86EC 74C3 5394 479D D352 4C51
>
> --
> BackInTime karmic package missing depends on menu
> https://bugs.launchpad.net/bugs/466088
> You received this bug notification because you are a member of Back In
> Time Team, which is subscribed to Back In Time.
>
> Status in Back In Time: Invalid
> Status in “backintime” package in Ubuntu: Confirmed
>
> Bug description:
> The Back In Time (root) launcher as shipped in karmic calls the program
> su-to-root. This program is not installed on a base Ubuntu machine, but
> menu (The package containing su-to-root) is not listed as a dependency.
>
>
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~bit-team<https://launchpad.net/%7Ebit-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~bit-team<https://launchpad.net/%7Ebit-team>
> More help : https://help.launchpad.net/ListHelp
>

Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

Sponsors, release deciders:

Impact
--------
On a base Karmic or Lucid system both of the Backintime front-ends have an undeclared dependency, which results in them failing to launch as root from the menu system.

TEST CASE:
----
Install a base system and either of the BiT front-ends. Ensure the 'menu' package is not installed if it has been pulled in by another dependency. From the menu, choose to run BiT as root and no window appears.

Fix:
-----
The patch listed from git in an above post adds a dependency on menu for both front-end packages. Sponsorship is required because I am not a Ubuntu developer.

Regression potential is very low. This fix has been thoroughly tested in Debian and has some, but less, testing in Ubuntu.

Changed in backintime (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
StefanPotyra (sistpoty) wrote :

Simple bug fix, no need for a FFe, hence removing the subscription of ubuntu-release (and adding ubuntu-sponsors instead).

Revision history for this message
StefanPotyra (sistpoty) wrote :

oh, lucid has the same version as debian. Can you forward this bug report to debian please? I'll happily upload the ubuntu diff in the meantime.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Jonathan, sorry, forget that call please, just saw that you're taking care for the Debian package :)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backintime - 0.9.26-3ubuntu1

---------------
backintime (0.9.26-3ubuntu1) lucid; urgency=low

  [ Jonathan Wiltshire ]
  * debian/control: Add dependency on menu package (LP: #466088).
 -- Stefan Potyra <email address hidden> Sat, 10 Apr 2010 19:26:11 +0200

Changed in backintime (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
John Dong (jdong) wrote :

*put on SRU team hat*:

Accepted Karmic nomination. The patch (adding the menu dependency) looks reasonable to me. Please format it up as a SRU debdiff and upload to Karmic. Consider this an ACK on the patch.

P.S. Comment #13 should really be in the original bug description.

Revision history for this message
Benjamin Drung (bdrung) wrote :

No debdiff to sponsor, unsubscribing ubuntu-sponsors. Please resubscribe the team once there is a SRU debdiff to sponsor.

Revision history for this message
Jonathan Wiltshire (jwiltshire) wrote :

The patch for Karmic is exactly the same as for Lucid: http://launchpadlibrarian.net/43704116/backintime_0.9.26-3_0.9.26-3ubuntu1.diff.gz

I don't have any upload rights to do this directly and I'm not officially related to Ubuntu at all, I just want to see this sorted out for Karmic users. If you need it in some specific format, I'll do my best for you.

description: updated
Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

Hi,

I downloaded the lucid patch, adapted it to SRU format (target karmic-proposed and version set to 0.1) and uploaded.

Waiting for approval right now.

Cheers,
Fabrice

Revision history for this message
Jonathan Riddell (jr) wrote : Please test proposed package

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in backintime (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Karmic:
I have reproduced the problem with backintime 0.9.26-3 in karmic and have verified that the version of backintime 0.9.26-3ubuntu0.1 in -proposed fixes the issue.

I've also verified that backintime runs as root when launched from the menu to launch it as root.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backintime - 0.9.26-3ubuntu0.1

---------------
backintime (0.9.26-3ubuntu0.1) karmic-proposed; urgency=low

  [ Jonathan Wiltshire ]
  * debian/control: Add dependency on menu package (LP: #466088).
 -- Fabrice Coutadeur <email address hidden> Fri, 30 Jul 2010 07:33:21 +0200

Changed in backintime (Ubuntu Karmic):
status: Fix Committed → Fix Released
Lotta Koch (lotta)
Changed in backintime (Ubuntu Karmic):
assignee: nobody → Lotta Koch (lotta)
Changed in backintime (Ubuntu Karmic):
assignee: Lotta Koch (lotta) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions