[enhancement] Implement progress dialog

Bug #448305 reported by DenisP on 2009-10-10
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Back In Time
Fix Released
Wishlist
Unassigned

Bug Description

Back in time works nicely but what I miss is and progress dialog with the possibility to abort current backup in progress. In the current state there is not possible to abort backup process from inside the program. If user wants to abort backup process it must kill the processes manually. This is only thing that prevents me of using this nice tool. I think it would be nice if user could have some control and visualization of the backup process. Current implementation shows a icon in tray area but if it is clicked it only displays one dialog displaying current file processed.
I would like to propose to implement progress dialog like luckyBackup software provides. It uses also rsync to make backups and it has nice progress dialog and also warns user when there is not enough space on the destination for the backup to be stored properly. Take a look on this software on http://luckybackup.sourceforge.net it is also open source so you could perhaps implement progress dialog the similar way ti is done in lackyBackup.
I think approach to backup in back in time is the best there is for the linux desktop users only this one important feature is missing in to be complete.

Best regards!

Richard Bailey (rmjb) on 2009-10-12
summary: - Implement progress dialog with abort function
+ [enhancement] Implement progress dialog with abort function
Changed in backintime:
importance: Undecided → Wishlist

+1

It is also pretty hard for a newbie to see the current backup process because only some text is shown in the status bar.

Robert Pollak (robert-pollak) wrote :

See http://bashukhan.com/total-rsync-progress/ for the reason why Back In Time (which uses rsync) does not have a progress bar yet: The current Ubuntu 10.04 rsync version is 3.0.7, and some 3.1.x or 3.2 would be necessary.

There is also a blueprint for this: https://blueprints.launchpad.net/backintime/+spec/show-progress-bar .

The "provide abort function" part should be moved to a separate bug, as this could be implemented sooner.

Dave (dave2010) wrote :

"provide abort function" is covered in bug 435380

Dan (danleweb) on 2010-09-17
Changed in backintime:
status: New → Confirmed
summary: - [enhancement] Implement progress dialog with abort function
+ [enhancement] Implement progress dialog
ceg (ceg) wrote :

Duplicity as an optional backend provides progress information: http://mterry.name/log/2008/11/22/deja-dup-news/

Yegor Yefremov (yegorslists) wrote :

I've implemented the calculation of the total backup/copy progress (see my branch https://code.launchpad.net/~yegorslists/+junk/bit revision 780). I'm using rsync 3.0.5 in Ubuntu 9.04. At first I calculate the total amount of files using --dry-run and then current progress using --progess option. I've blogged about this method here: https://libbits.wordpress.com/2011/04/09/get-total-rsync-progress-using-python/

What do you think about this solution?

Gorka Navarrete (emrys) wrote :

Yegor, does your solution add a significant amount of time to the backup process?

Yegor Yefremov (yegorslists) wrote :

I don't think so. The most time consuming operation resulting from the patch is --dry-run to calculate the total amount of files. Verbosity (--progess) won't add too much overhead.

Germar (germar) on 2014-05-12
Changed in backintime:
status: Confirmed → Fix Committed
milestone: none → 1.1.0
Germar (germar) on 2015-01-15
Changed in backintime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers