attached images get deleted anyway

Bug #614012 reported by EdB on 2010-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Quam Plures
Fix Released
Medium
Tilman Blumenbach
b2evolution
Undecided
Unassigned
Whissip
Medium
Unassigned

Bug Description

See http://forums.quamplures.net/viewtopic.php?f=16&t=482
When you use File manager to delete a file that is attached to an item you get a warning saying it won't delete it because it is attached to something. You click OK (or whatever it is that means you want to continue) and it deletes the file anyway. The warning was that it would not delete it, but it did. So now you lost your attachment on an item.

We need to make it not delete the attached file, OR, make it so you can cancel or continue knowing the attached item will be deleted anyway.

Related branches

Tilman Blumenbach (tblue) wrote :

I tried to delete global/monument-valley/monuments.jpg -- the file manager tells me that it cannot delete that file because it is linked to two elements. So far so good, but it doesn't delete the file as you said...

Revision: 7524

EdB (edb) wrote :

Apparently it takes multiple files where at least one is not attached to an item to see it happen. You will then be able to delete the file that is not attached and it will delete all files anyway.

Tilman Blumenbach (tblue) wrote :

Confirmed! Looking at it right now.

Changed in quam-plures:
status: New → In Progress
assignee: nobody → Tilman Blumenbach (tblue)
Changed in quam-plures:
status: In Progress → Fix Committed
Daniel Hahler (blueyed) wrote :

I cannot decide anything in trunk:

When clicking the find link on an item file's "find target" link:
"""File «b2evolution8.png»: cannot be deleted because of the following relations

    1 linked items
    About this system
    Welcome to b2evolution!"""

Daniel Hahler (blueyed) on 2010-08-06
Changed in b2evolution:
status: New → Fix Released
status: Fix Released → New
Changed in quam-plures:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers