GTK applications launched by firefox don't use in global menu

Bug #690009 reported by Connor Carney on 2010-12-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
Undecided
Unassigned
DBus Menu
Invalid
Undecided
Unassigned
firefox (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: indicator-appmenu

In natty alpha 1, GTK applications that are launched by double-clicking a file in the firefox download window don't use the global menu bar. So if I double-click a PDF in the downloads window, evince launches without global menu. Same thing happens with totem if I double-click an mp3 file (unless it's already running, in which case firefox uses the existing instance).

(Thanks to seb128 for the tip-off). This is probably down to the UBUNTU_MENUPROXY=libappmenu.so environment variable, probably as a result of:

  grep -r UBUNTU_MENUPROXY /etc/alternatives/
  /etc/alternatives/gnome-www-browser:unset UBUNTU_MENUPROXY
  /etc/alternatives/x-www-browser:unset UBUNTU_MENUPROXY

and which is created by 'firefox.postinst'.

(I'm still unclear what the preferred "holding package" for this bug would be).

Package: indicator-appmenu 0.0.13-0ubuntu4
SourcePackage: indicator-appmenu

Connor Carney (cscarney) wrote :
Paul Sladen (sladen) wrote :

Confirming this. Opening a PDF via Firefox, such as:

  http://www.fsilaw.com/%7E/media/Files/Publications/IP_Media/Assange%20Skeleton%20Argument%2011_01_2011%20pdf.ashx

uses a different codepath to opening "evince ..." from the command-line. I cannot confirm whether this is related to handling by 'xdg-open/gnome-open' because those load the PDF file in Inkscape at the moment...

affects: indicator-appmenu (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in ayatana-ubuntu:
status: New → Confirmed
Changed in libdbusmenu (Ubuntu):
importance: High → Medium
Paul Sladen (sladen) on 2011-01-11
description: updated
Chris Coulson (chrisccoulson) wrote :

This is actually a firefox bug. We just need to drop the "unset UBUNTU_MENUPROXY" bit from the launcher script. That made it's way in from the firefox-4.0 nightly source (which needs that because the binary name doesn't match the blacklist in appmenu-gtk).

affects: libdbusmenu (Ubuntu) → firefox (Ubuntu)
Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Alex Launi (alexlauni) on 2011-01-21
Changed in dbusmenu:
status: New → Invalid
Chris Coulson (chrisccoulson) wrote :

Done

bzr commit -m '* Fix LP: #690009 - GTK applications launched by firefox don't use in
  global menu. Don't unset UBUNTU_MENUPROXY
  - update debian/firefox.sh.in' --fixes 'lp:690009'
Committing to: /home/chr1s/src/firefox/4.0/
modified debian/changelog
modified debian/firefox.sh.in
Committed revision 740.

Changed in firefox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0~b10+build1+nobinonly-0ubuntu1

---------------
firefox (4.0~b10+build1+nobinonly-0ubuntu1) natty; urgency=low

  * New upstream release v4.0 B10 (FIREFOX_4_0b10_BUILD1)

  [ Jamie Strandboge <email address hidden> ]
  * AppArmor:
    - allow access to defaults.list for all derivatives (LP: #664093)

  [ Chris Coulson <email address hidden> ]
  * Refresh patches after landing of bmo: #624267 aka Crash on Ubuntu
    [@ nsGNOMEShellService::SetDefaultBrowser ]
    - update debian/patches/lp185622_system_path_default_browser.patch
  * Refresh patches after landing of bmo: #624625 aka change home page of
    Google search plugin to google.com
    - update debian/patches/ubuntu_codes_google.patch
  * Remove debian/remove.binonly.sh from package, it's not used anyway
    (the one from mozilla-devscripts is used instead)
    - remove debian/remove.binonly.sh
  * Don't make DEB_ENABLE_THUMB2 configurable, this should just be totally
    automatic
    - update debian/rules
  * Bump NSS and NSPR minimum versions to 3.12.9 and 4.8.7 respectively
    - update debian/rules
  * Clean unused variable from debian/rules
    - update debian/rules
  * Use the smaller crashreporter-symbols.zip after landing of bmo: #588129 aka
    symbols.txt file missing from *.crashreporter-symbols.zip
    - update debian/firefox-mozsymbols.install.in
  * Run jstestbrowser and mochitest test suites
    - update debian/testsuite.mk
  * Fix LP: #690009 - GTK applications launched by firefox don't appear in
    global menu. Don't unset UBUNTU_MENUPROXY
    - update debian/firefox.sh.in
 -- Chris Coulson <email address hidden> Tue, 25 Jan 2011 21:50:54 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers