Ayatana Ubuntu Love Project

Rhythmbox missing the basic, normal syncing feature in Lucid

Reported by nUboon2Age on 2010-07-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
Undecided
Unassigned
rhythmbox (Ubuntu)
Wishlist
Unassigned

Bug Description

Lucid Rhythmbox is missing the normal synchronization feature (such as itunes has) where the music player and computer fully synchronize their libraries in both directions. The feature needs to be user friendly and it needs to be included at some point in Lucid since Lucids is an LTS. Syncing is such a basic feature of what Rythmbox aspires to be I believe it should be included in future versions of the Lucid LiveCD when it is updated.

Given that Rhythmbox is the default player in Lucid I believe it needs to 'just work' in order to give the fantastic user experience that Mark Shuttleworth has made the goal for Ubuntu.

nUboon2Age (nuboon2age) on 2010-07-17
summary: - Rhythmbox missing normal iPod/iPhone/mp3Player syncronization
+ Rhythmbox missing normal iPod/iPhone/mp3Player synchronization feature
affects: ubuntu → rhythmbox (Ubuntu)
summary: - Rhythmbox missing normal iPod/iPhone/mp3Player synchronization feature
+ Rhythmbox missing normal iPod / iPhone / mp3Player synchronization
+ feature
summary: - Rhythmbox missing normal iPod / iPhone / mp3Player synchronization
- feature
+ Rhythmbox missing normal synchronization feature with iPod / iPhone /
+ Audio player

the sync feature is available on Maverick version of Rhythmbox for ipods. the iphone support is not the best in rhythmbox atm but that's should be filed as another bug report , same for the portable audio players.

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Changed in ayatana-ubuntu:
status: New → Invalid
nUboon2Age (nuboon2age) wrote :

Based on Pedro Villavicencio's comment's actions it sounds like this bug should be narrowed to be more specific, so I'll narrow it to being Rhythmbox Sync Feature Missing on Lucid. It needs to be included in Lucid (and hopefully when the Lucid liveCD is remade since it is such a fundamental function) when it becomes available since Lucid is an LTS. After narrowing/specifying the scope of the bug I'll remark it as new.

summary: - Rhythmbox missing normal synchronization feature with iPod / iPhone /
- Audio player
+ Rhythmbox missing normal synchronization feature
nUboon2Age (nuboon2age) on 2010-07-19
description: updated
Changed in ayatana-ubuntu:
status: Invalid → New
Changed in rhythmbox (Ubuntu):
status: Invalid → New
description: updated
summary: - Rhythmbox missing normal synchronization feature
+ Rhythmbox missing the normal synchronization feature
nUboon2Age (nuboon2age) on 2010-07-19
summary: - Rhythmbox missing the normal synchronization feature
+ Rhythmbox missing the normal synchronization feature in Lucid

the sync code is lot of changes and will not go to a stable update

Changed in rhythmbox (Ubuntu):
importance: Low → Wishlist
nUboon2Age (nuboon2age) wrote :

@Sebastien Bacher i implore you to change your mind on this. Please hear me out.

"Can we not only emulate, but can we blow right past Apple?" Mark Shuttleworth, July 22 2008.

The answer is "definitely yes!" if we take care of these vital user experience details.

Bear in mind that Rythmbox = iTunes for the new customer to Ubuntu coming over from the Mac or Windows world. It has to compete head to head and at least roughly stack up or it creates an enormous hole for the Ubuntu customer who then can not achieve this functionality without keeping a Mac or Windows machine around. Contemporary versions of iTunes itself will not play on Linux even with Wine so Rhythmbox *has* to play this role. Millions of customers have iPods or other media players that they have become accustomed to syncing with iTunes on Mac or Windows so their expectations have been firmly set. Even before it is important to be 'Social from the start' it is much more important to be able to

This fix has actually been done since *summer of 2009* and released since 2, July 2010 in the 0.13.0 "Albatross" release of Rythmbox and there is plenty of time and its such a breathtakingly basic feature of the leading GNU/Linux distro's default modern media player to be missing from an LTS that it is compelling to incorporate into the 10.0.4.2 LiveCD and even earlier than that via updates for 10.04 and 10.04.1 . Would we really want LTS users to be stuck without such a fundamental capacity until April 2013??? Absolutely not.

Lucid is a very special release, not just because it is an LTS, but because of the truly revolutionary breakthrough it represents in ease of use for Ubuntu. Tremendous numbers of new Ubuntu customers are being exposed to Ubuntu and Linux through this release. In order to fully back up Mark Shuttleworth's vision of GNU/Linux that is as easy to use as the Mac, we must take care to fill in the basic functions of a modern OS and like it or not, support for basic synchronization of media players as iTunes has spoiled millions of customers with is very much one of those features. Even though it is challenging to move from 0.12.8 to 0.13.0, it is very important in order to do so to move toward the Ubuntu vision of Mark Shuttleworth.

The developer, Jonathan Matthew announced the fix release in the 0.13.0 and later versions:
https://bugzilla.gnome.org/show_bug.cgi?id=310774
Jonathan Matthew [rhythmbox developer] 2010-03-29

"I've just merged code based on Paul Bellamy's GSoC 2009 project into master.
iPod sync now works."

summary: - Rhythmbox missing the normal synchronization feature in Lucid
+ Rhythmbox missing the basic, normal syncing feature in Lucid
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Changed in ayatana-ubuntu:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Changed in ayatana-ubuntu:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.