Window management - 'Ctrl-Alt-Numpad 4' and 'Ctrl-Alt-Numpad 6' window placement shortcuts are broken

Bug #992697 reported by Wessel van Norel on 2012-05-01
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Autopilot
Medium
Marco Trevisan (Treviño)
Ayatana Design
Medium
John Lea
Compiz
Medium
Marco Trevisan (Treviño)
0.9.10
Medium
Marco Trevisan (Treviño)
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
autopilot (Ubuntu)
Undecided
Marco Trevisan (Treviño)
compiz (Ubuntu)
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

The "Ctrl + Alt + numpad 4" and "Ctrl + Alt + numpad 6" keyboard shortcuts are not working in 13.04.

See bug #878820 for the full specification of the numpad window placement shortcuts. Quoting from this bug:

"Ctrl-Alt-Numpad 4 - Place window on the left side of the screen in *semi-maximised* state (it is important that the window is actually semi-maximised, not just the same size and position as a semi-maximised window) Pressing a second time does nothing.

Ctrl-Alt-Numpad 6 - Place window on the right side of the screen (it is important that the window is actually semi-maximised, not just the same size and position as a semi-maximised window). Pressing a second time does nothing."

HOWTO:

The solution we want here are additional shortcuts to semi-maximize windows vertically and move them to left/right half of the screen...

The best way to achieve that:

1. Remove the changing of the standard shortcuts by debian/patches/ubuntu-config.patch, so the original ones will work again.
2. Add 2 quasi-duplicated shortcuts with the functions to semi-maximize windows vertically and move them to left/right half of the screen to Grid and make those functions use "Ctrl + Super + Cursor Left or Right" on Ubuntu.

Related branches

Neil Davis (davisnn) wrote :

I have issues with ctrl + alt + numpad (4 | 6). All other shortcuts seem to work. 12.04 was an upgrade for me from 11.10 which was an upgrade from 11.04 if that makes any difference.

Craig Hrabal (mathor) on 2012-05-11
Changed in ayatana-design:
status: New → Fix Committed
Wessel van Norel (delgurth) wrote :

I'm running 13.04 now. Fixed are Ctrl + Alt + numpad (0 | 5)

Still broken are Ctrl + Alt + numpad (4 | 6)

John Lea (johnlea) on 2013-05-15
summary: - A few Window Placement keys are broken in 12.04
+ Window management - 'Ctrl-Alt-Numpad 4' and 'Ctrl-Alt-Numpad 6' window
+ placement shortcuts are broken
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) wrote :

@John Lea:
Of course those shortcuts are broken, because the default shortcuts for Ubuntu (you decided those IIRC) are "Ctrl+Super+LeftCursor" and "Ctrl+Super+RightCursor" ;) Try those.

lp:compiz trunk is even more advanced regarding Grid (Compiz 0.9.10-dev only), see a video here: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/745159/+attachment/3660185/+files/GridAllFunctionalityFullyFixed.mp4

Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
MC Return (mc-return) wrote :

@John Lea:
I guess those shortcuts were changed, because (most) laptops do not have a numpad...
This inconsistency is quite bad though now, I agree.

MC Return (mc-return) wrote :

@everyone affected:
Hold the "Super" key to reveal a presentation of the most common shortcuts.

If you want to change the shortcut, simply "sudo apt-get install compizconfig-settings-manager", open CCSM->Grid->Bindings and adjust them accordingly...

John Lea (johnlea) wrote :

@MC Return: ideally we would like both to be supported (see https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit ) however if I remember the issue that has prevented us doing this so far is that compiz only supports the binding of a single shortcut to each action?

Agreed that the CTRL+SUPER+CURSOR KEYS shortcuts are more important, but it would be good to support the numpad shortcuts as well. But the ability for compiz to support binding multiple shortcuts to a single action would need to be implemented first? Ping me on IRC when you have a sec.

MC Return (mc-return) wrote :

@John Lea:
Pinged you, but will simply repeat it here:

Regarding the other problem:
It would be (easily) possible to have 2 different shortcuts doing the same thing, so I can implement that for Grid without any problems...

Btw, your document says: Ctrl + Super + Cursor Left or Right Semi-maximises current window, which is actually something else than what Grid does as Grid not only semi-maximizes, but also moves the window to a position.
We can of course have shortcuts to just semi-maximize as well, in fact those are already available, just not defined...

Changed in compiz:
assignee: nobody → MC Return (mc-return)
John Lea (johnlea) on 2013-05-15
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in compiz:
status: New → Triaged
MC Return (mc-return) wrote :

Okay, so the solution we want here are additional shortcuts to semi-maximize windows vertically and move them to left/right parts of the screen...
The best way to achieve that:

1. Remove the changing of the standard shortcuts by debian/patches/ubuntu-config.patch, so the original ones will work again.
2. Add 2 quasi-duplicated shortcuts with the functions to semi-maximize windows vertically and move them to left/right half of the screen to Grid and make those functions use "Ctrl + Super + Cursor Left or Right" on Ubuntu.

Changed in compiz:
status: Triaged → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
assignee: MC Return (mc-return) → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.9.11.0
importance: Undecided → Medium
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.1.1
importance: Undecided → Medium
Changed in autopilot:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 1.4
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:autopilot at revision 324, scheduled for release in autopilot, milestone 1.4

Changed in autopilot:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3789, scheduled for release in compiz, milestone 0.9.11.0

Changed in compiz:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.10 at revision None, scheduled for release in compiz, milestone 0.9.10.2

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3509, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-09-17
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Changed in autopilot (Ubuntu):
status: New → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130920-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Chris Townsend ]
  * Work done by Sam Spilsbury: - Ensure that the frame region is always
    set as soon as the window is decorated. - Further ensure that the
    window decoration isn't needlessly reset if the window already had
    one. - Refactored XShape usage into a common function. - Added tests
    to verify the behaviour of shape set on initially creating a
    decorated window and also upon changing the input frame window
    shape. (LP: #1158267)
  * Alt-Tabbing or Launcher selecting a window that is over 50% in a
    different viewport should not switch the viewport nor change the
    placement of the window. The fix is to add an option to turn this
    behavior on or off. By default, the option is on, but Ubuntu is
    patched to turn it off to fix this bug. (LP: #1092323)

  [ Marco Trevisan (Treviño) ]
  * debian/patches/ubuntu-config.patch: remove grid custom keybindings
    for window management We handle these directly in unity. (LP:
    #992697)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3789
 -- Ubuntu daily release <email address hidden> Fri, 20 Sep 2013 11:18:01 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Fred (eldmannen+launchpad) wrote :

What about non-Unity users?

Fred: the bug is fixed in compiz for everyone...

Thomi Richards (thomir) on 2013-09-25
Changed in autopilot:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package autopilot - 1.4+14.04.20131106.1-0ubuntu1

---------------
autopilot (1.4+14.04.20131106.1-0ubuntu1) trusty; urgency=low

  [ Jean-Baptiste Lallement ]
  * Forward port changes from 1.3.

  [ Marco Trevisan (Treviño) ]
  * Bamf: pass Gdk.Display to GdkX11.X11Window.foreign_new_for_display.
    (LP: #1234478)

  [ Automatic PS uploader ]
  * Remove a spurious log message. (LP: #1227852)

  [ Andy Doan ]
  * Forward port changes from 1.3.

  [ Jamie Strandboge ]
  * Forward port apparmor rules and functional test fixes.

  [ Christopher Lee ]
  * Forward port changes from 1.3.
  * Backout additions for logging when a process dies.
  * Update the autopilot funcational tests so they work under python 3.
    (LP: #1232973)
  * Changes how the proxy objects are created so the inheritance is
    correct . (LP: #1230046)
  * Keyboard backends: Add alias so Backspace and BackSpace work. . (LP:
    #1237675)
  * Fixes issue where a classes _Backend can be None causes uncaught
    exceptions. (LP: #1233972)
  * Add details to select_many docs re: order of objects returned not
    guaranteed. (LP: #1248336)

  [ Thomi Richards ]
  * Forward port changes from 1.3.
  * Remove a spurious log message. (LP: #1227852)
  * Forward port apparmor rules and functional test fixes.
  * Fix a missing test dependency, and add more logging when a process
    exits before we find the introspection interface.
  * Fix 1.4 documentation to include type ids in the examples. (LP:
    #1230038)
  * Forward port wait_select_single method (and associated changes &
    tests) to 1.4. (LP: #1231694)
  * Update autopilot documentation to fix porting guide, and add several
    objects to the documentation index. (LP: #1231690, #1230038)
  * Add support for 3D points. (LP: #1227131)
  * Make the default help text more useful. (LP: #1224771)
  * Add a warning when an autopilot query returns many items, and should
    probably be optimised. (LP: #1227830)
  * Update packaging details so upgrading from 1.3 -> 1.4 is seamless.
    (LP: #1227797)
  * Log an 'info' message when we set an environment variable, and when
    we delete one. (LP: #1236097)
  * Changes how the proxy objects are created so the inheritance is
    correct . (LP: #1230046)
  * Fixes issue where a classes _Backend can be None causes uncaught
    exceptions. (LP: #1233972)
  * Make client-side attribute reprs the same as their python types.
    (LP: #1237039)
  * Use the 'six' python module to help us get python 2/3 compatibility,
    rather than rolling our own. (LP: #1238257)
  * Fix documentation next/prev links. (LP: #1231690, #1239493,
    #1230038)
  * Add documentation for the autopilot type support for 3D points.

  [ Martin Pitt ]
  * Forward port changes from 1.3.

  [ Corey Goldberg ]
  * add tox config and packaging fixes.
  * added flake8 static test from tox and fixed lint errors.
  * unit tests only from tox.
  * make sphinx docs pretty.
  * updates and minor fixes to documentation. also added a short README.

  [ Leo Arias ]
  * Added the logging annotation to be used on emulators.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 357

autopilot (1.4+14...

Read more...

Changed in autopilot (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

marking as closed (0.9.10 series is obsolete)

tags: added: rls-w-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers