Pressing Enter in dash search box leads to inconsistent and unpredictable behavior

Reported by X on 2012-04-29
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Undecided
Unassigned

Bug Description

Steps to reproduce:
1.1 Press Super key, by default the home lens shows a mixed results of recently used applications, file and folders. Pressing Enter without performing any search does not launch the first application shown in the dash.

1.2 Without exiting the dash (from the previous step), press Super + a to enter the application lens. Pressing Enter will launch the first application.

2. If however, you proceed directly to the application lens and press enter, the first application is not launched. This behavior is also applicable to other lenses.

3.1 Press Super and type a search term and then press enter, the first search result is launched.

3.2 Press Super again, where the previously entered search term is shown and press enter, the first search result is not launched this time.

What is expected:
like gnome-shell, the first result is always selected, and always opens when enter is pressed. also, please make the selected background and animation the same one as unity-2d.

Nekhelesh Ramananthan (nik90) wrote :

Thank you for taking your time to report this bug. This inconsistent behavior can be seen in Ubuntu 12.04. It requires some discussion about what behavior to exhibit and requires design input. I have marked the bug incomplete until further input is received from the design team. Rest assured this will still be looked into.

summary: - pressing enter in dash search box leads to inconsistent results
+ Pressing Enter in dash search box leads to inconsistent and
+ unpredictable behavior
Changed in unity:
status: New → Incomplete
description: updated
Nekhelesh Ramananthan (nik90) wrote :

@ to the original reporter of this bug report,
Points 3.1 and 3.2 are being worked on in another bug report. I am currently unable to find that bug report. I will attach the link when I find it

@ Unity Developers and Ayatana Design Team
I have also included points 3.1 and 3.2 in this bug report, so that this is one bug report where the different dash behavior when clicking enter is addressed in one place instead of being scattered across multiple bug reports. Please do not mark this a duplicate. It is a valid issue pointed out by the original reporter of this bug report.

X (s-u) wrote :

@ nik90
yes, that was me commenting on https://bugs.launchpad.net/unity-2d/+bug/944499 , it was marked as a duplicate of https://bugs.launchpad.net/bugs/932092 , both reports are under unity 2d, and points 1 & 2 are actually behaving nicely in unity 2d (it did say fix released), "enter" does execute the first item. point 3 doesn't even work under unity 2d. (it doesn't remember previous key word if you reopen dash)

what else are needed? unity 2d does points 1.1 & 2 as expected, it's logical, add the right visual cue indicating the first item is selected, DONE.

Nekhelesh Ramananthan (nik90) wrote :

ok..but I also remember seeing another bug report which explicitly states points 3.1 and 3.2 for Unity 3D. It was a work in progress by Marco (Unity developer). I cant believe I can find it now...hopefully tomorrow (monday), i will ask the Unity developers for the link. Anyway the milestone was set to Unity 5.12 or 5.14 for release..so it should land soon. But points 1,2 were not addressed yet.

Nekhelesh Ramananthan (nik90) wrote :

Points 3.1 and 3.2 have been fixed in the bug report #980184 found at https://bugs.launchpad.net/unity/+bug/980184.

X (s-u) wrote :

https://bugs.launchpad.net/unity/+bug/980184/comments/5
I can't get to 5a, no matter where the mouse pointer is, gedit will not open. I'm on 12.04 64 bit.
well at least it's known, I can only wait.

Eric Casteleijn (thisfred) wrote :

Additional to 1.1: After hitting super, the dash text box shows the most recent search term (selected, so that typing will overwrite it,) which makes it even more confusing that hitting enter does nothing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers