Multimonitor, Launcher - When the Launcher is set to autohide and 'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure' seems to be broken when revealing the Launcher

Bug #987955 reported by John Lea on 2012-04-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Andrea Azzarone
6.0
Fix Released
Undecided
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Andrea Azzarone

Bug Description

[Test Case]
1. Have a multi-monitor environment (at least 2 monitors enabled)
2. Enable Launcher auto-hide in g-c-c
3. Make sure you have the launcher set to appear on all monitors
4. Disable sticky-edges
5. Move your mouse from the right-most screen to the screen to the left
   -> Verify that there is some pressure needed to move from one screen to another, caused by the fact that the Launcher auto-hide is enabled

[Regression Potential]
Trivial change, no other regression potential.

Original description:

Currently if the sticky edges are disabled, they are *all* disabled. However what should happen is that if 'sticky edges' is disabled AND the launcher is set to auto-hide, the sticky edges should remain active on a single edge (where the launcher is) from a single direction (the direction the pointer has to travel to reveal the Launcher)

What currently happens:

When the Launcher is set to autohide and 'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure' seems to be broken when revealing the Launcher. It is switched off on all edges

What should happen:

When the Launcher is set to autohide and 'Sticky edges' are turned off, the 'Launcher Edge Stop Overcome Pressure' should continue to be active *only* as part of the launcher reveal action. e.g. if the user moves the pointer from the right to left to reveal the Launcher it should be triggered and the monitor edge, but if the user moves the pointer from left to right (or down to up, or up to down) across a monitor border it should not be triggered.

Related branches

John Lea (johnlea) on 2012-04-24
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udp
Changed in ayatana-design:
importance: Undecided → Critical
status: New → Fix Committed
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → backlog
John Lea (johnlea) on 2012-04-24
description: updated
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: backlog → 5.14.0
Ilan Tal (ilan-tal) wrote :

I am experiencing a similar problem. I have a dual monitor setup. If I turn on sticky edges I can't move the cursor from one monitor to another. Thus sticky edges MUST be off for me.
I would like to use the auto hide feature for the launchers (I need all the real estate I can get). However if I enable auto hide I can never get the launchers back, no matter how close to the edge I put the cursor. Things might be different if I used sticky edges, but I simply can't use it with dual monitors.

Ilan

Andrea Azzarone (azzar1) wrote :

I cannot reproduce this bug.

John Lea (johnlea) on 2012-06-20
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-06-28
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
importance: Undecided → High
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
description: updated

Hello John, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

With unity from -proposed, auto hide on, and sticky edges off, I get resistance going right-to-left whether I am doing so to get to the left monitor, or to open the launcher, or indeed if I'm carrying a window with me. This seems counter intuitive, but the section "What should happen:" seems to indicate that's intended behaviour?

John Lea (johnlea) wrote :

@popy; *If the launcher is set to auto-hide*, there needs to be resistance to reveal the Launcher, even if sticky edges are turned off. But this resistence should only be in the right to left direction on the left edge of the monitor where the launcher is located, and not when the user is dragging a window. When sticky edges is turned on there should be resistance on all edges of the monitor, both when a user is moving the pointer and when they are dragging a window.

The proposed merge should fix one issue, which is the 'Launcher edge stop overcome pressure' (a sub-component of of the set of behavours that add edge resistance) is currently missing from the Launcher reveal when sticky edges are turned off. Could you open another bug for the resistance being triggered when the user drags a window? (this should not happen if sticky edges are switched off).

thanks!

Changed in unity:
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2012-08-21
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Cimitan (cimi) on 2012-09-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2012-09-06
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers