Dash - search field is hidden by tooltips

Reported by Fabio Marconi on 2012-04-10
150
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Andrea Azzarone
5.0
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Precise
Medium
Unassigned

Bug Description

[Test Case]
1. Click on the Dash button
2. Type search entry
3. Move mouse over the Dash button on the Launcher
   -> Verify that the Dash tooltip from the Launcher does not appear

[Regression Potential]
Broken Launcher tooltips.

Original description:

Steps to reproduce the bug:
-click the Dash button
-type something
- when you move the mouse around the dash button or not.

What happens:
- the dash button's tooltip partially hides what you type in the search field.

What is expected:
After two second the name of the button fade away

See attached sceenshot for more details.

-----------------------------------------------------
Desired resolution:

- As soon as the Dash or HUD is opened, the tooltip should be dismissed.

- No tooltip should be displayed when the pointer is moved over the BFB when either the Dash or HUD is open

Fabio Marconi (fabiomarconi) wrote :
Nekhelesh Ramananthan (nik90) wrote :

Thank you for reporting this bug to make Ubuntu better. This requires input from the design team. Marking this incomplete until further feedback is received from the design team.

Changed in unity:
status: New → Incomplete
description: updated
Omer Akram (om26er) on 2012-04-10
tags: added: needs-design
Changed in unity (Ubuntu):
status: New → Incomplete
summary: - search field hidden
+ Dash search field is hidden by tooltips
description: updated

I can't reproduce this bug. As soon as I click the dash button, its tooltip disappears.
Has this been fixed?

Hernando Torque (htorque) wrote :

Running Nux r611 and Unity r2275: I can confirm that behavior.

ender (ender46) wrote :

I can confirm the behavior. When you mouse over the Dash button to click it, a tooltip saying "Dash Home" appears. However when you click on the button, the tooltip stays (as the mouse is still hovering it) which covers the first 4 characters of any search you want to make. I think the solution is to make the tooltips disappear on click.

I am running an updated Precise Pangolin beta, with compiz enabled and 3.2.0-23-generic #36-Ubuntu x86_64 x86_64 x86_64 GNU/Linux. I have no idea on how to find the unity version I'm using though but I guess it's the latest one.

Sebastien Bacher (seb128) wrote :

Setting to triaged, I'm not sure there is lot of design input needed there, it feels like the tooltip should just be dismissed when the dash is opened

Changed in unity:
status: Incomplete → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
summary: - Dash search field is hidden by tooltips
+ Dash - search field is hidden by tooltips
John Lea (johnlea) on 2012-04-26
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
tags: added: udp
removed: needs-design
Changed in ayatana-design:
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → 5.14.0
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
William Ranvaud (wiranvaud) wrote :

I've installed/updated a dozen of computers since 12.04 release and noticed a correlation: those who have the tool-tip problem usually do not have the unity launcher icon size slider in the system settings > appearance and vice versa. In either cases it was annoying. Might this be related?

Sebastien Bacher (seb128) wrote :

right, what you said that is "it happens only in unity3d" (those who don't have the setting use the fallback which doesn't support that option), thanks but I think extra infos are not needed, Andrea has already proposed a fix for the bug

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu2

---------------
unity (5.12-0ubuntu2) quantal; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed

Hello Fabio, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I can confirm the fix there!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu1.1

---------------
unity (5.12-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
milestone: 5.14.0 → 6.0
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
description: updated
John Lea (johnlea) on 2012-08-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.