Fallback to Unity 2D for RTL locales

Bug #963682 reported by Shahar Or
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Nux
Won't Fix
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
Unity
Won't Fix
Undecided
Unassigned

Bug Description

Dear Friends,

Since Unity and Nux don't yet support RTL (Bug #654988) then until that support is released, Unity should fall back to Unity 2D, which does support RTL.

A branch for Nux, was written for this purpose and a merge was proposed. Please make freeze exception.

The rationale is that RTL users will get mighty confused because their shell is LTR while the rest of their apps are RTL.

It would be better to have a "boring", no bling shell than to have an LTR shell in a RTL language.

Test packages are available in the following PPA:
https://launchpad.net/~haggai-eran/+archive/nux-rtl-fallback-to-unity-2d

In order to test:

1. See that when user's language is one of the RTL languages (Hebrew, Arabic, Farsi, etc.) that a Unity session is replaced by a Unity 2D session.
2. See that this can be circumvented by setting the UNITY_ALLOW_RTL variable (I do it in .profile).
3. See that LTR locales sessions are not affected by this.

Thanks and Blessings,
Shahar

Shahar Or (mightyiam)
tags: added: precise rtl
Omer Akram (om26er)
summary: - Fall back to Unity 2D for RTL locales
+ Fallback to Unity 2D for RTL locales
David Planella (dpm)
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Omer Akram (om26er)
Changed in nux:
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Changed in nux:
status: Incomplete → New
Changed in unity:
status: Incomplete → New
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

So, is this meant to be a freeze exception bug? Then for that, could you follow the steps here: https://wiki.ubuntu.com/FreezeExceptionProcess ?

If that's the case, then this shouldn't be assigned to Ayatana Design either.

Changed in unity:
status: New → Incomplete
Changed in nux:
status: New → Incomplete
Revision history for this message
Shahar Or (mightyiam) wrote :

Dear Friends,

Please read description. I ask for freeze exception.

Thanks and Blessings,
Shahar

description: updated
Changed in nux:
status: Incomplete → New
Changed in unity:
status: Incomplete → Invalid
status: Invalid → New
Changed in ubuntu-translations:
status: Triaged → New
Revision history for this message
Martin Pitt (pitti) wrote :

From purely reading the description (not the code/branch) this seems to be a good idea indeed. The Unity team will do the actual branch review and land it (or follow up with suggestions how to improve it).

Changed in unity:
status: New → Confirmed
Revision history for this message
Haggai Eran (haggai-eran) wrote :

Hi,

Thanks for reviewing this bug, and the branch. When you look at the branch, please make sure you look at lp:~haggai-eran/ubuntu/precise/nux/rtl-fallback-to-unity-2d which is more updated than the previous link.

Regards,
Haggai

Gabor Kelemen (kelemeng)
Changed in ubuntu-translations:
status: New → Triaged
Revision history for this message
Shahar Or (mightyiam) wrote :

Dear Friends,

I've tested the package that is in:
https://launchpad.net/~haggai-eran/+archive/nux-rtl-fallback-to-unity-2d

And it works perfect. I've tested as thouroughly as I thought relevant.

Thanks and Blessings,
Shahar

Revision history for this message
Omer Akram (om26er) wrote :

that won't change since we are deprecating Unity-2d and RTL support shall be added to Unity itself.

Changed in unity:
status: Confirmed → Won't Fix
Changed in nux:
status: New → Won't Fix
Changed in ubuntu-translations:
status: Triaged → Won't Fix
Changed in ayatana-design:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers