Menu bar - add option for the global menu to make it always visible

Bug #955193 reported by John Lea on 2012-03-14
224
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
unity-control-center (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

[Test Case]

(1) enable menus in the window title bar System Settings > Appearance > Behavior > Show the menus for a window > In the menu bar
(2) run "gsettings set com.canonical.Unity always-show-menus true" in a terminal
(3) move the mouse around between windows

The menus should remain displayed

[Regression Potential]

Any change to the menu functionality has the potential to cause volunteer functionality in menu behaviour.

[Other Info]

The fix for Ubuntu 14.04 LTS was cherry picked from the Ubuntu "Vivid Vervet" dev release where it has been in production use for some time with no apparent regression.

Related branches

John Lea (johnlea) on 2012-03-14
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp
Aleve Sicofante (sicofante) wrote :

This was promised for 12.04 by the dictator. He recently said it won't be there. Can we at least expect it in point releases for those who don't like/can't install ordinary releases?

Pffst. Even dictators don't always get what they want. What's the point
in the dark glasses and braid, huh.

Richard Gaskin (rg4w) wrote :

It's encouraging that restoring the ability for apps to have their commands visible is an option in 12.04, but unless this becomes the default I fear it may not be not enough.

Hiding the menus makes it difficult for new users to know that they're there, and for experienced users it hinders the ability to acquire muscle memory in accessing them because they cannot be aimed for.

I very much appreciate and support the interest in designing a cleaner look, but menus are not noise, they're information. In fact, since they represent the primary means of accessing most applications' features, they're some of the most useful information on the screen.

No matter how good an OS is, ultimately its utility is defined by the scope of applications that run on it. As such, an OS is really just an app launcher; the term "application" itself is a good reminder for all of us, the means by which a user applies computing to their work.

Quick and easy access to applications is a primary goal of an OS, and Unity's Launcher does an excellent job of that.

The second goal of an OS is to stay out of the way and let the application provide quick and easy access to its commands.

Good application designers spend significant time laying out their menu bar. Altering or hiding it frustrates those developers as much as it hampers theirs users.

Frustrated developers are less encouraged to port their applications.

Applications are the features Ubuntu needs more than anything else.

Accessing their commands is central to the utility of an OS.

"...most of our competitors are interesting in doing something different, or want to appear new - I think those are completely the wrong goals. A product has to be genuinely better. This requires real discipline..."
    - Jonathan Ive

shane (shane-animail) wrote :

Didn't "The Dictator" already say in the mailing lists that this option will be available "in due course"?

Incidentally, I'm not sure terms such as "dictator" should be used in official streams such as this.
Regardless of personal opinions I don't think such labels are constructive or helpful, even if done in the hope of hitting a nerve/annoying certain people into action (in fact I would tend to say it may have the opposite affect with some people).

Probably best saved for the forums, or OMG Ubuntu! :)

Changed in unity-2d:
assignee: nobody → Pawel Stolowski (stolowski)
Aleve Sicofante (sicofante) wrote :

"Incidentally, I'm not sure terms such as "dictator" should be used in official streams such as this."

He chose it himself.

Aleve Sicofante (sicofante) wrote :

BTW: The question hasn't been answered. Can this feature be expected on point releases of the upcoming LTS or will LTS users have to wait for 14.04?

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
importance: Undecided → Medium
no longer affects: unity-2d
Changed in unity:
milestone: backlog → 7.3.2
Jeff Ward (jeff-ward) wrote :

2 years later... LIM in 14.04 is a poorly thought-out hack. What's more important, a window title, or the menus. I get the feeling that nobody on the Unity team actually uses local menus, so nobody really thinks about it.

At least in 12.04 I could disable the whole global menu nonsense and get back to a sane menu system. In 14.04, the much touted LIM is a flop without the "always visible" option.

Unbelievable.

Aleve Sicofante (sicofante) wrote :

A few months back I got the impression this would be implemented as a tweak in dconf or something equally hacky. While not the exact solution we're waiting for, it would have been an advance. What happened to that?

Changed in unity:
milestone: 7.3.2 → 7.3.1
status: Confirmed → In Progress
keito (audioactivist) wrote :

This is great news! I no longer use Ubuntu (switched to elementary), but this was one of my major gripes. Now, if they could see to it to add the ability to remove the launcher permanently, then I'd certainly be tempted back. Offering such user control and choice is a GOOD thing!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20150115-0ubuntu1

---------------
unity (7.3.1+15.04.20150115-0ubuntu1) vivid; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Andrea Azzarone ]
  * Disable Pointer Barriers during lockscreen. (LP: #1401911)
  * Use std::weak_ptr to avoid referencing an invalid barrier. (LP:
    #1238063)
  * Enable dash and hud if there is a fullscreen window. (LP: #1159249,
    #860970)
  * Show session dialog over fullscreen windows. (LP: #1404486)
  * Avoid running pontentially dangerous code paths when the screen is
    locked. (LP: #1410582)

  [ Marco Trevisan (Treviño) ]
  * MenuManager: make sure menus are always shown when mouse is over
    them or when the always-show-menus option is on (LP: #955193,
    #1390562, #1374942, #1312137)
 -- Ubuntu daily release <email address hidden> Thu, 15 Jan 2015 15:03:31 +0000

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.2 → 7.3.1
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-18
description: updated

Hello John, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20150316-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

* enable proposed repository & install unity package.

$ LANG=C apt-cache policy unity libunity-core-6.0-9 unity-services
unity:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

libunity-core-6.0-9:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

unity-services:
  Installed: 7.2.4+14.04.20150316-0ubuntu1
  Candidate: 7.2.4+14.04.20150316-0ubuntu1
  Version table:
 *** 7.2.4+14.04.20150316-0ubuntu1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.4+14.04.20141217-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/main i386 Packages
     7.2.2+14.04.20140714-0ubuntu1.1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/main i386 Packages

[CHECK: Test Case]
(1) enable menus in the window title bar System Settings > Appearance > Behavior > Show the menus for a window > In the menu bar
(2) run "gsettings set com.canonical.Unity always-show-menus true" in a terminal
(3) move the mouse around between windows

$ gsettings set com.canonical.Unity always-show-menus true
---> Global menu is always visible.
If a window is active, the LIM is same result, too.

$ gsettings set com.canonical.Unity always-show-menus false
---> Back to original.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20150316-0ubuntu1

---------------
unity (7.2.4+14.04.20150316-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Avoid running potentially dangerous code paths when the screen is
    locked. (LP: #1410582)
  * Ungrab the shoutdown dialog as soon as possible. (LP: #1398287)
  * Use COMPIZ_METAKEY where needed. (LP: #1363534)
  * disabled Pointer Barriers during lockscreen (LP: #1401911)
  * disabled markup for VolumeLauncherIcon quicklist menu items (LP:
    #1413411)
  * enable Dash, Hud, and session dialogs over full screen window (LP:
    #1159249, #860970, #1413773, #1404486)
  * made unity unlockable if user is in nopsswdlogin group (LP:
    #1413790)
  * skipped the animation of BGHash on startup to prevent unwanted fade-
    in (LP: #1241757)

  [ Luke Yelavich ]
  * extended accessible exploration of the Dash dynamic content (LP:
    #1066157)

  [ Marco Trevisan (Treviño) ]
  * MenuManager: make sure menus are always shown when mouse is over
    them or when the always-show-menus option is on (LP: #955193,
    #1390562, #1374942, #1312137)
  * PanelService: use gdbus to notfy upstart of service start/stop (LP:
    #1302955)
 -- CI Train Bot <email address hidden> Mon, 16 Mar 2015 17:30:35 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: added: rls-w-incoming
tags: added: rls-x-incoming
removed: rls-w-incoming
Bruno (brunonova) wrote :

I see this bug "affects" unity-control-center and is triaged.
So @Marco Trevisan and other developers, is an option going to be added to the Appearance settings in Unity Control Center in the next LTS to change the always-show-menus setting?
This would be very nice.

Unrelated to this bug: it would also be nice if an option to change the launcher_minimize_window setting ("click to minimize" ) was added as well. Even though it's labelled as "experimental", it seems to be working pretty well.

Changed in unity-control-center (Ubuntu):
status: Triaged → In Progress
importance: Undecided → Medium
milestone: none → ubuntu-16.04
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.04.20160209-0ubuntu1

---------------
unity-control-center (15.04.0+16.04.20160209-0ubuntu1) xenial; urgency=medium

  * Appearance: Add radiobox to toggle the always show menu option (LP:
    #955193)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 09 Feb 2016 01:20:34 +0000

Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers