HUD - Update the 'system' and 'indicator' icons used by the HUD to the new icons

Reported by John Lea on 2012-02-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Paul Sladen

Bug Description

Update the 'system' and 'indicator' icons used by the HUD to the new icons Rosie has designed. See attached design Matrix_Launcher_Open2.png to see how they will appear in context.

*Note that the icons must be mounted on a bfb style Launcher tile, that like the bfb this squircle tile should be tinted with the wallpaper average colour*

The final icon assets have been attached to this bug, see below.

John Lea (johnlea) on 2012-02-23
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
tags: added: udp
tags: added: hud
Ted Gould (ted) wrote :

Moving to the Ubuntu Mono project so that they icons can be added there. We just use the icon names, if larger sizes need to be used, that's where they go.

affects: unity → ubuntu-mono
Changed in ubuntu-mono:
milestone: backlog → none
affects: unity (Ubuntu) → ubuntu-mono (Ubuntu)
John Lea (johnlea) wrote :
description: updated
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
description: updated
Olli Ries (ories) on 2012-02-28
Changed in ubuntu-mono:
assignee: nobody → Paul Sladen (sladen)
Paul Sladen (sladen) wrote :

My understanding (from having spoken to Ted) is:

  (a) For system indicators (sound, datetime, session, systemdevices). A default icon is always shown by HUD
  (b) For application indicators (networking, bluetooth). The icon currently being shown is used for the HUD.

For networking, this means that HUD will try to display 'gsm-strength-2' rather than 'nm-signal-100'. Where-as for the volume control 'audio-volume-high-panel' will always be used.

The datetime system indicator (which doesn't have a default icon equivalent, only the textual time, this needs to be the new icon.

So most of these icons will just be larger versions of existing icons. However Ted notes surprise that since the originals are SVG, these assets aren't also SVG.

Paul Sladen (sladen) wrote :

An additional implementation point, is that these probably always want to be the light-on-dark indicators for Ambiance ("IconTheme=ubuntu-mono-dark") even when Radiance ("IconTheme=ubuntu-mono-light") is selected.

On Wed, 2012-02-29 at 15:30 +0000, Paul Sladen wrote:
> (a) For system indicators (sound, datetime, session, systemdevices). A default icon is always shown by HUD

Currently, this is what we're sending:

Date, icon: "office-calendar"
Device, icon: "system-devices-panel"
Users, icon: "avatar-default"
Sound, icon: "audio-volume-high-panel"
Messages icon: "indicator-messages"

The table can be found here:
http://bazaar.launchpad.net/~indicator-applet-developers/indicator-appmenu/trunk.0.4/view/head:/src/indicator-tracker.c#L43

Tim Penhey (thumper) on 2012-04-16
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
importance: Critical → Medium
John Lea (johnlea) on 2012-10-15
Changed in ayatana-design:
status: Fix Committed → Fix Released
assignee: John Lea (johnlea) → nobody
tags: removed: hud udp
Changed in ayatana-design:
status: Fix Released → Confirmed
no longer affects: ubuntu-mono (Ubuntu)
affects: ubuntu-mono → ubuntu-themes (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers