Search field not common to lenses

Reported by Greg Merchan on 2012-02-18
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
One Hundred Papercuts
Medium
Nick Tait
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After typing in the home lens's search field and seeing no results, I figured I was using the wrong lens so I switched to another one. Because the search field is specific to the lens, I had to retype my search terms.

I didn't realize until I started this report that the home lens search would search all the lenses. (Or, I'm assuming that's what it does now, based on a different search which produced results.)

Nekhelesh Ramananthan (nik90) wrote :

Thank you for reporting this bug. The searches made in the home lens is common to all the other lenses installed. However, some 3rd party lenses have the option to not display any results to searches made in the home lens.

For instance, I have 6 lenses installed (5 default - home,file,applications,music and video lens) and (1- 3rd Party lens - Askubuntu). Now a search made in the home lens would provide results from the default lenses installed but not from the askubuntu lens since the developers did enable it.

Hence the searches are common to all lenses and is not a bug. Hence marking this invalid.

Changed in unity:
status: New → Invalid
Greg Merchan (gregory-merchan) wrote :

I figured it would be clear that I meant the search field; in fact, I did specify that in the text of the report. Type something, switch to another lens, and the search field no longer contains what was typed.

Greg Merchan (gregory-merchan) wrote :

Furthermore, if the searches were common to all lenses, then searches made from a lens which is not the home lens would display results from all lenses. Adding "field" to the title and reopening.

summary: - Search not common to lenses
+ Search field not common to lenses
Changed in unity:
status: Invalid → New
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) wrote :

needs design input. But I am quite certain this has been rejected before.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Kirill Kabardin (kkabardin) wrote :

Bug that I filled was marked as a duplicate of this one. They are quite related, but not really duplicates each other. So I repeat there what I already suggested:

Home lens contains first matches from all lenses. So we can try search whatever we need right here. But if our query doesn't give us enough results we have to switch to more specific lens. But search box would be cleared in this case and we'll have to type query again.

It would be more reasonable not to clear search box when we switching to other lens but leave our query.

At least there should be an option for this.

Dario Ruellan (druellan) on 2012-10-24
Changed in unity:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Chris Wilson (notgary) wrote :

Dario, thanks a lot for being proactive in assigning bugs to the paper cuts team, but just make sure you only do it on the Hundred Papercuts bug task, rather than the package itself. To add a paper cuts task, click "Also Affects Project" and type "hundredpapercuts".

Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Changed in unity:
assignee: Papercuts Ninja (papercuts-ninja) → nobody
Changed in hundredpapercuts:
milestone: none → raring-round-3
Dario Ruellan (druellan) wrote :

Oh, sorry Chris. Taking notice.

No worries. Thanks for helping out :)

Chris Wilson (notgary) wrote :

Nick, can we have some input from design on this one please? Is this a valid bug or it the current behaviour there by design?

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
assignee: Papercuts Ninja (papercuts-ninja) → Nick Tait (jnick-tait)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers