Remove glow from Alt-tab edge and Search Field image assets

Reported by Paul Sladen on 2012-02-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Paul Sladen
unity-2d
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Glow is now being done in the software. Some of the existing assets still have glow (blur) in the image itself; this should be removed and the versions without glow uploaded.

This includes:

  1. Unity Dash Search box edge
  2. Unity Dash Search box Magnifying glass

Related branches

lp:~sladen/unity-2d/unity-2d-no-glow-lp933578
Merged into lp:unity-2d at revision 937
Gerry Boland: Approve (functional) on 2012-02-27
Xi Zhu (community): Approve (design) on 2012-02-27
Michał Sawicz: Needs Fixing on 2012-02-24
Paul Sladen: Pending requested 2012-02-24
lp:~sladen/unity/unity-3d-no-glow-lp933578
Merged into lp:unity at revision 2019
Gord Allott (community): Approve on 2012-02-24
Andrea Cimitan: Approve (design) on 2012-02-24
Paul Sladen (sladen) wrote :

Search field asset from Rosie.

Paul Sladen (sladen) wrote :

Keyboard shortcut apparently uses these (1/4):

Paul Sladen (sladen) wrote :

Keyboard shortcut apparently uses these (2/4):

Paul Sladen (sladen) wrote :

Keyboard shortcut apparently uses these (3/4):

Paul Sladen (sladen) wrote :

Keyboard shortcut apparently uses these (4/4):

Paul Sladen (sladen) wrote :

The corners/sides need to go to three places:

  Alt-tab
  Keyboard Shortcuts
  Shutdown dialogue

Omer Akram (om26er) on 2012-02-17
Changed in unity-2d:
status: New → Confirmed
Paul Sladen (sladen) wrote :

Unity 2D:

  Magnifying glass defined in 'unity-2d/shell/common/SearchEntry.qml' to be 'artwork/search_icon.png' (46x46) or 'artwork/cross.png' (46x46)
  Dash box defined in 'unity-2d/shell/common/SearchEntry.qml' to reference 'artwork/search_background.sci' which in turn loads 'artwork/search_background.png' (643x53)

Paul Sladen (sladen) wrote :

Replacement for 'artwork/search_icon.png' (46x46) cropped down from 'unity/plugins/unityshell/resources/search_magnify.png'

Paul Sladen (sladen) wrote :

Replacement for 'artwork/search_background.png' (643x53)' redrawn from components of 'search-field.png'

Paul Sladen (sladen) wrote :

For the avoidance of doubt; yes a bunch of this needs fixing in Unity-3D too…

The reason for doing Unity-2D first is because Unity-3D was uninstallable (bug # 938590) from staging at the point of trying to do Unity-3D first.

Paul Sladen (sladen) wrote :

Before.

Paul Sladen (sladen) wrote :

After.

Paul Sladen (sladen) wrote :

Difference map (Subject(Before,After). Zoom in and all of the changes should be visible. Sorry that the mouse pointer was not in precisely the same location.

Andrea Cimitan (cimi) on 2012-02-24
tags: added: top5p unity3p
Changed in ayatana-design:
assignee: nobody → Andrea Cimitan (cimi)
Changed in unity:
status: Confirmed → Fix Committed
Paul Sladen (sladen) wrote :

Xi: Per request of greyback, please could you look at the attached screenshot and if it's okay, add an "Approve" to:

  https://code.launchpad.net/~sladen/unity-2d/unity-2d-no-glow-lp933578/+merge/94597

Changed in unity-2d:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: none → 5.6.0
Changed in unity-2d:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Andrea Cimitan (cimi) on 2013-09-20
Changed in ayatana-design:
assignee: Andrea Cimitan (cimi) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers