Update 'desktop' menu so it is fully relevant to desktop functionality

Bug #932143 reported by John Lea on 2012-02-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
nautilus (Ubuntu)
High
Unassigned

Bug Description

Update 'desktop' menu so it is fully relevant to desktop functionality. Currently there are two options in the 'desktop' menu that are duplications of 12.04 launcher functionality. These are:

- The 'Bookmarks' menu. This has now been replaced by the Nautilus quicklist
- The "New Window" option in the "File" menu. Creation of new windows is handled by the Launcher, and this label is not informative.

The request is to remove these two items from the 'desktop' menu before UI freeze.

Related branches

John Lea (johnlea) on 2012-02-14
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Ted Gould (ted)
milestone: none → backlog
Ted Gould (ted) wrote :

Removing the "Fix Committed" on the design task as the spec needs to be updated accordingly: https://wiki.ubuntu.com/MenuBar#The_desktop

Changed in unity:
status: Confirmed → Invalid
affects: unity (Ubuntu) → nautilus (Ubuntu)
Changed in ayatana-design:
status: Fix Committed → In Progress
Changed in nautilus (Ubuntu):
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
John Lea (johnlea) wrote :

Wiki updated, bug status changed to fix-committed.

no longer affects: unity
Changed in ayatana-design:
status: In Progress → Fix Committed
Changed in nautilus (Ubuntu):
assignee: Ted Gould (ted) → nobody
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.90-0ubuntu2

---------------
nautilus (1:3.3.90-0ubuntu2) precise; urgency=low

  * debian/patches/05_desktop_menu_export.patch:
    - updated to the new design requirements, dropping the bookmarks menu and
      the new windows entry, those are availabe from the unity launcher
      (lp: #932143)
 -- Sebastien Bacher <email address hidden> Wed, 22 Feb 2012 19:41:16 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Bowmore (bowmore) wrote :

Why! What's wrong with multiple options to achieve something?

Furthermore, the bookmark menu in the launcher's quicklist is premature., i.e not sorted the right way and this is known but not acted upon.

Adolfo Jayme (fitojb) wrote :

@bowmore: design is against us :-P (no offense intended)

Bowmore (bowmore) wrote :

@Fitoschido: Nope ;)

Consider the case when a user unlocks the home icon in the launcher.

Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers