window management, multi-monitor - In multi-monitor environment, windows should spread on the monitor in which they reside

Bug #919139 reported by John Lea on 2012-01-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz Core
Low
Andrea Azzarone
compiz (Ubuntu)
High
Andrea Azzarone

Bug Description

In multi-monitor environment, windows should spread on the monitor in which they reside.

By way of example:

- if there is 1 terminal window on monitor A and 2 terminal windows on monitor B, and the terminal app is not in focus, clicking on the Launcher terminal icon in should focus the last used terminal app window *on the monitor that contains the clicked on Launcher*

- if there is 1 terminal window on monitor A and 2 terminal windows on monitor B, and the terminal app is in focus, clicking on the Launcher terminal icon in either of the Launchers should spread the windows on their current monitors. So 2 terminal windows should be spread on monitor A, and 1 terminal window is spread on monitor B.

Change discussed with JasonS, and is a critical to multi-monitor support in 12.04

Related branches

John Lea (johnlea) on 2012-01-20
affects: unity-greeter → ayatana-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udp
Changed in ayatana-design:
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in ayatana-design:
status: Triaged → Fix Committed
description: updated
Download full text (3.9 KiB)

On Fri, 20 Jan 2012, John Lea wrote:

> Public bug reported:
>
> In multi-monitor environment, windows should spread on the monitor in
> which they reside.
>
> By way of example:
>
> - if there is 1 terminal window on monitor A and 2 terminal windows on
> monitor B, and the terminal app is in focus, clicking on the Launcher
> terminal icon in either of the Launchers should spread the windows on
> their current monitors. So 2 terminal windows should be spread on
> monitor A, and 1 terminal window is spread on monitor B.
>
> Change discussed with JasonS, and is a critical to multi-monitor support
> in 12.04
>

Like many things, just an option change away - ccsm -> scale ->
multioutput_mode = "On current output device"

> ** Affects: ayatana-design
> Importance: Critical
> Assignee: John Lea (johnlea)
> Status: Fix Committed
>
> ** Affects: unity
> Importance: Undecided
> Assignee: Sam Spilsbury (smspillaz)
> Status: New
>
> ** Affects: unity (Ubuntu)
> Importance: Undecided
> Status: New
>
>
> ** Tags: udp
>
> ** Project changed: unity-greeter => ayatana-design
>
> ** Also affects: unity
> Importance: Undecided
> Status: New
>
> ** Also affects: unity (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: ayatana-design
> Assignee: (unassigned) => John Lea (johnlea)
>
> ** Tags added: udp
>
> ** Changed in: ayatana-design
> Importance: Undecided => Critical
>
> ** Changed in: ayatana-design
> Status: New => Triaged
>
> ** Changed in: unity
> Assignee: (unassigned) => Sam Spilsbury (smspillaz)
>
> ** Changed in: ayatana-design
> Status: Triaged => Fix Committed
>
> ** Description changed:
>
> In multi-monitor environment, windows should spread on the monitor in
> which they reside.
>
> By way of example:
>
> - if there is 1 terminal window on monitor A and 2 terminal windows on
> monitor B, and the terminal app is not in focus, clicking on the
> Launcher terminal icon in should focus the last used terminal app window
> *on the monitor that contains the clicked on Launcher*
>
> - if there is 1 terminal window on monitor A and 2 terminal windows on
> monitor B, and the terminal app is in focus, clicking on the Launcher
> terminal icon in either of the Launchers should spread the windows on
> their current monitors. So 2 terminal windows should be spread on
> monitor A, and 1 terminal window is spread on monitor B.
> +
> + Change discussed with JasonS, and is a critical to multi-monitor support
> + in 12.04
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/919139
>
> Title:
> window management, multi-monitor - In multi-monitor environment,
> windows should spread on the monitor in which they reside
>
> Status in Ayatana Design:
> Fix Committed
> Status in Unity:
> New
> Status in “unity” package in Ubuntu:
> New
>
> Bug description:
> In multi-monitor environment, windows should spread on the monitor in
> which they reside.
>
> By way of example:
>
> - if there is 1 terminal window on monitor A and 2 terminal windows on
> ...

Read more...

Yann Dìnendal (yannbreliere) wrote :

But this option spreads *all* windows in the current device, doesn't it? Not in their respective monitor like this bug is about.

Omer Akram (om26er) on 2012-01-20
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Tim Penhey (thumper) wrote :

Sam, multioutput_mode = "On all output devices"

gets this to work for me.

Changed in unity:
importance: Undecided → High
assignee: Sam Spilsbury (smspillaz) → Jason Smith (jassmith)
Omer Akram (om26er) on 2012-02-13
Changed in unity (Ubuntu):
importance: Undecided → High
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
importance: High → Critical
Andrea Azzarone (azzar1) on 2012-03-30
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-03-30
Changed in unity:
milestone: none → 5.10.0
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3083

Changed in compiz-core:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 0.9.7.6
affects: unity (Ubuntu) → compiz (Ubuntu)
no longer affects: unity
Andrea Azzarone (azzar1) on 2012-04-01
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz core 0.9.7.6

Changed in compiz-core:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.6-0ubuntu1

---------------
compiz (1:0.9.7.6-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Memory leak in dlloaderListPlugins (LP: #968985)
    - priv->invisible is not updated when the window is mapped (LP: #969102)
    - window management, multi-monitor - In multi-monitor environment, windows
      should spread on the monitor in which they reside (LP: #919139)
    - Drop-down menus look disembodied from their titles (LP: #659816)
    - Improve performace of the shadow clipping code (LP: #931883)
    - DecorWindow::computeShadowRegion called way too much (LP: #969101)
    - white box randomly shows up at top left corner blocking application
      from using stuff under it (LP: #940603)
  * Rebuild against latest metacity to get the HUD key configuration
    exposed in unity 3D as well (LP: #969256)
  * debian/patches/ubuntu-config.patch:
    - set multioutput_mode to all outputs (windows to be scaled on each the
      monitor they are on only) (LP: #919139)
  * debian/patches/fix_976467.patch:
    - Fix shadows being clipped incorrectly (LP: #976467)

  [ Oliver Grawert ]
  * update the GLES2 patch for the new upstream release.
 -- Didier Roche <email address hidden> Wed, 11 Apr 2012 18:35:39 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
walterav (walterav) wrote :

As of today with all updates and compiz 0.9.7.6 the spread/maximize/enlarge on a multimonitor setup with each screen having a different resolution is still broken in the following way.

It will always enlarge/spread/maximize to the biggest screen although the window position and the maximize action was initiated from the smaller screen, in the condition that the window that is subjected to enlarging has a "vertical" and or "horizontal" resolution that is larger than the resolution of the smaller screen! Eventhough the orange opacity grid (related to the maximize/enlarge/spread activity) lifts up on the first smaller screen where it was initiated but the window it self appears on the other second larger screen maximized.

Nick Tait (jnick-tait) on 2012-04-26
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers