Dash - Pressing "Page Down/Page Up" does not work in Dash

Bug #913612 reported by Brendan Griffin on 2012-01-09
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Christopher Townsend
7.2
Fix Committed
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend
Trusty
Medium
Unassigned

Bug Description

When trying to page down or page up in the Dash it never works.

Steps to reproduce:
1.) press Super+A
2.) expand the "Installed" category so that all installed applications are viewable, resulting in lots of rows of icons
3.) press the "Page Down" key with the intention of advancing the view of icons down one page. Nothing happens. The "page down" key will not move the view down one page.

Please make it so that "Page Down" and "Page Up" work in the dash so users can use these keys when looking at lots and lots of icons.

--------------------------------------------------
Desired Solution:

- When the Dash is open the PAGE UP and PAGE DOWN keys should scroll the Dash up and down.

(note this behaviour was specified in section "2.4.2.2 Keyboard navigation" of the original Dash spec.

[Test Case]
1. press Super+A
2. expand the "Installed" category so that all installed applications are viewable, resulting in lots of rows of icons
3. Make sure the pressing "Page Down" and "Page Up" correctly scroll down/up the dash results

[Regression Potential]
None

Related branches

lp:~townsend/unity/fix-dash-page-up-down
Marco Trevisan (Treviño): Approve on 2015-05-08
PS Jenkins bot: Approve (continuous-integration) on 2015-05-05
lp:~unity-team/unity/trusty-sru-7.2.6
Andrea Azzarone: Approve on 2015-10-15
Bilal Akhtar (bilalakhtar) wrote :

Successfully reproduced on Precise.

Changed in unity:
status: New → Triaged
importance: Undecided → Low
Bilal Akhtar (bilalakhtar) wrote :

Not an accessibility issue, though, since users will still be able to use the arrow keys to change focus, one icon at a time.

Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Omer Akram (om26er) on 2012-02-28
description: updated
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
John Lea (johnlea) on 2012-04-19
description: updated
John Lea (johnlea) on 2012-04-19
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
status: Triaged → Confirmed
Changed in unity (Ubuntu):
status: Triaged → Confirmed
Changed in unity:
milestone: none → backlog
Tim Penhey (thumper) wrote :

At the moment, page up and page down jump between section headings, and change the focus. I'm happy though to change them to be entirely scroll based.

Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-04-23
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
John Lea (johnlea) on 2012-05-14
summary: - Pressing "Page Down/Page Up" does not work in DASH
+ Dash - Pressing "Page Down/Page Up" does not work in Dash
Andrea Azzarone (azzar1) on 2012-07-19
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: backlog → 6.2
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
milestone: 6.4 → 6.6
Omer Akram (om26er) wrote :

@Andrea, are you still working on this?

Andrea Azzarone (azzar1) on 2012-09-14
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
status: In Progress → Triaged
Changed in unity:
milestone: 6.6 → 7.0
Luis Alvarado (luisalvarado) wrote :

For me it works the following way:

When pressing Page Down/Up it goes from one section to the other, while pressing the arrow keys it goes from one item to the next. In the Case of the App lens, it goes from Recently Used section to Installed Section if I press Page down. If I however press the down key it goes one item at a time, going from each app for example in the Installed section. If this is the intended behaviour I find it perfect.

John Lea (johnlea) on 2012-10-15
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
milestone: 7.0.1 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Changed in unity:
assignee: Andrea Azzarone (azzar1) → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → Christopher Townsend (townsend)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150522-0ubuntu1

---------------
unity (7.3.2+15.10.20150522-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Chris Townsend ]
  * Add necessary signaling to set the BFB icon's tooltip and the Home
    Scope's default search string to accurately reflect if searching
    online is enabled or disabled in unity-system-settings. (LP:
    #1202160, #1101662)
  * Enable real page up/page down key navigation in the Dash. When using
    these keys the view scrolls the length of the visible view. (LP:
    #913612)
  * If Spread/Expo is active, then terminate it when entering Launcher
    keynav mode. (LP: #1447810)
  * If dragging an application:// uri type from the Dash to the desktop,
    change it to a file:// uri type so Nautilus can understand the type
    a make a copy of it on the desktop. (LP: #1241972)
  * Wait on Spread to be terminated before showing the Quicklist. (LP:
    #1441626)

  [ Luke Yelavich ]
  * Implement scope bar icon accessibility (LP: #1457073)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative
    result needs the Preview (LP: #1447372, #1291950)

 -- CI Train Bot <email address hidden> Fri, 22 May 2015 13:21:14 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2015-10-23
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello Brendan, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
Bruno Nova (brunonova) wrote :

I've upgraded the packages unity, libunity-core-6.0-9 and unity-services to the version in trusty-proposed (7.2.6+14.04.20151021-0ubuntu1).

Page Up/Down correctly scrolls the results up and down.

However, the focused application doesn't change. Which means that, after pressing Page Up/Down multiple times, if I try to use the arrow keys, it will scroll back to that application.
Additionally, the Home/End keys do nothing.

I'm setting this as verification-done since the bug is fixed, but this feature could be improved.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers