Scrollbars - difficult to resize panels with overlay scrollbar

Reported by f_padia on 2011-12-22
166
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
overlay-scrollbar
High
Brandon Schaefer
overlay-scrollbar (Ubuntu)
High
Brandon Schaefer

Bug Description

With the new overlay scrollbar in 12.04 the handle appears anywhere on the scrollbar you move the mouse to, but this makes it very difficult to resize the window on the right side. It is especially difficult on a laptop. The only way I have figured it can be done is to leave the mouse on the edge until the handle disappears but this is not very convenient. I think the usability of the new scrollbars needs improvement

Note: A good application to use when reproducing this behaviour is Evolution calendar.

-----------------------------------------
Desired resolution:

- Clicking and dragging the overlay scrollbar at right angles to the scroll direction should resize subpanels (in exactly the same way as this currently works with whole windows)

- When the pointer is positioned over either of the long sides (left or right sides for a vertical scrollbar) of the thumb, the pointer icon should change from the normal single arrow to a 'two way resizing arrow' to signal to the user that they can resize by dragging. This 'two way resizing arrow' should also appear when the pointer 2px away from the thumb on either side so there is in total a 3px draggable area (similar to the invisible dragable border around windows).

Related branches

lp:~andyrock/overlay-scrollbar/fix-907837
Merged into lp:overlay-scrollbar at revision 368
Brandon Schaefer: Approve on 2013-02-05
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-02-02
lp:~brandontschaefer/overlay-scrollbar/lp.907837-v-resize-fix
Merged into lp:overlay-scrollbar at revision 369
Andrea Azzarone: Approve on 2013-02-04
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-02-02
lp:~brandontschaefer/overlay-scrollbar/lp.907837-fix
Merged into lp:overlay-scrollbar at revision 379
PS Jenkins bot: Approve (continuous-integration) on 2013-08-26
Andrea Azzarone: Approve on 2013-08-26
Alistair Buxton (a-j-buxton) wrote :

Here is a video demonstrating the bug:
http://www.youtube.com/watch?v=o9CrDDX6i0E

This affects resizing of both windows and sub-components of windows which are resizable and also have scrollbars, such as the one shown in the video.

Changed in ayatana-design:
status: New → Confirmed
Maciej Bęcławski (hakkatuka) wrote :

You can resize using the scroll handle now.

Changed in ayatana-design:
status: Confirmed → Fix Released
Alistair Buxton (a-j-buxton) wrote :

I guess you didn't watch the video. You cannot resize window subpanels from the overlay scrollbar, therefore this bug is not fixed.

Alan Pope ㋛ (popey) wrote :

I agree, this isn't fixed. Whilst you can resize a main window by grabbing the overlay scrollbar, it doesn't work for resizing panels within a window.

John Lea (johnlea) on 2012-04-20
Changed in ayatana-design:
status: Fix Released → New
John Lea (johnlea) on 2012-04-20
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
summary: - difficult to resize window with 12.04 overlay scrollbar
+ Scrollbars - difficult to resize window with 12.04 overlay scrollbar
tags: added: udp
John Lea (johnlea) on 2012-04-23
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Andrea Cimitan (cimi)
affects: unity (Ubuntu) → overlay-scrollbar (Ubuntu)

Windows are already resizeable using horizontal dragging (proposed solution a), this bug instead is related to resizing sub panels.

no longer affects: unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Invalid
Aethralis (aethralis) wrote :

I should also mention that this makes the split view of nautilus inconvenient to use, as it is very hard to resize the split. Only possibility that I found is to resize the split with the handle in the breadcrumbs area. And even this handle there is so thin that it is very difficult to catch.

summary: - Scrollbars - difficult to resize window with 12.04 overlay scrollbar
+ Scrollbars - difficult to resize panels with 12.04 overlay scrollbar
John Lea (johnlea) on 2012-07-02
description: updated

Trying to resize the side pane in Evince document viewer is nearly impossible; providing that the handle shows up everywhere on the scrollbar.

Daniel Schürmann (daschuer) wrote :

This is a also an annoying problem to me.
The Ubuntu 12.04 fixes the problem by using the handle for resizing only with those applications where the scroll bar is the next to the window border.

For me the underlying issue is the way the scrolling handle appears!

Moving the Mouse from right to the scroll bar, the handle does not appear next to the mouse as one might expect, but on the apposite side of the scroll bar. When trying to scroll you have to continue moving the Mouse until you finally reach the handle. When the handle is not reached, it is moving with the mouse like scrolling, but without scrolling. Thats annoying to.

So what to do?
* The scrolling handle should appear LEFT of the scroll bar. In the position where the static scroll bar would visible too. The current overlay scroll bar act this way, if you move a window like "Terminal" To the right border of your Screen.
* Once the handle appears, it should not be move with the mouse if not scrolling.

Taking both steps, window resizing should be possible and easy like having a static scroll bar.
.. and scrolling with the overlay scroll bar would be more intuitive (at least for me)

Kind regards,

Daniel

Daniel Schürmann (daschuer) wrote :

Attached you will find a patch against
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/overlay-scrollbar/precise/
It changes two things:

1. I if you leave the thumb in moving direction there is a zone of 16 Pixel where the thump is not moved before redraw. This allows to use normal resizing in conditions where the thump resizing from Precise does not work.

2. The thumb does not follow the mouse when mouse is in proximity area. This allows to move the mouse direct to the page-up/down buttons without detours.

I hope this patch solves most of the resize issues and not at least improves the convenience of the overlay scrollbar.
I have also considered to move the thumb to the right, but I think it brakes the design intention of this scrollbar.

I had trouble to test the trunk version on my system (12.4) , but if you also think this is candidate for merge, I can provide a patch against trunk.

Daniel Schürmann (daschuer) wrote :

The attachment "thumb_moving.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-10-09
Changed in unity:
importance: Undecided → Critical
Changed in overlay-scrollbar (Ubuntu):
importance: Undecided → Critical
Changed in unity:
status: Confirmed → Triaged
Changed in overlay-scrollbar (Ubuntu):
status: Confirmed → Triaged
Andrea Cimitan (cimi) on 2012-10-09
Changed in unity:
assignee: Andrea Cimitan (cimi) → nobody
no longer affects: unity
John Lea (johnlea) on 2012-10-10
Changed in unity (Ubuntu):
importance: Undecided → Critical
importance: Critical → Undecided
John Lea (johnlea) on 2012-10-12
no longer affects: unity (Ubuntu)

Changed the importance of this bug from "critical" to "high" because while fixing it is very important, it does not meet the criteria of a shipstopper bug.

Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Unity Maintainers (unity-maintainers-team)
importance: Critical → High
summary: - Scrollbars - difficult to resize panels with 12.04 overlay scrollbar
+ Scrollbars - difficult to resize panels with overlay scrollbar
Changed in overlay-scrollbar:
importance: Undecided → High
assignee: nobody → Andrea Azzarone (andyrock)
Changed in overlay-scrollbar (Ubuntu):
assignee: Unity Maintainers (unity-maintainers-team) → Andrea Azzarone (andyrock)
Changed in overlay-scrollbar:
status: New → In Progress
Changed in overlay-scrollbar (Ubuntu):
status: Triaged → In Progress
Changed in overlay-scrollbar:
status: In Progress → Triaged
Changed in overlay-scrollbar (Ubuntu):
status: In Progress → Confirmed
Changed in overlay-scrollbar:
assignee: Andrea Azzarone (andyrock) → nobody
Changed in overlay-scrollbar (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in overlay-scrollbar:
status: Triaged → In Progress
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in overlay-scrollbar (Ubuntu):
status: Confirmed → In Progress
Changed in overlay-scrollbar:
assignee: Brandon Schaefer (brandontschaefer) → Andrea Azzarone (andyrock)
Changed in overlay-scrollbar (Ubuntu):
assignee: Brandon Schaefer (brandontschaefer) → nobody
Stephen M. Webb (bregma) on 2013-02-04
Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in overlay-scrollbar:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.16+r359daily13.02.06-0ubuntu1

---------------
overlay-scrollbar (0.2.16+r359daily13.02.06-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Scrollbars - difficult to resize panels with overlay scrollbar (LP:
    #907837)
  * Coverity UNUSED_VALUE - CID 13652 (LP: #1109113)
  * Coverity UNUSED_VALUE - CID 13653 (LP: #1109114)

  [ Andrea Azzarone ]
  * Scrollbars - difficult to resize panels with overlay scrollbar (LP:
    #907837)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 369
 -- Automatic PS uploader <email address hidden> Wed, 06 Feb 2013 00:00:54 +0000

Changed in overlay-scrollbar (Ubuntu):
status: In Progress → Fix Released
A M (adrian-v) wrote :

Does this fix address the issue of not being able to resize panels within a window (as opposed to the window itself) using the overlay scroll bars?

I'm relatively new at Ubuntu and Linux in general, aren't this kind of fixes available through the usual update mechanism? If so, I'm wondering why it's still not fixed on my box, as I have run "sudo apt-get update" recently.

If not, how do I install it?

Thanks,

AM

Yann Dìnendal (yannbreliere) wrote :

adrian-v: "Fix released" for a package (here, it is for "overlay-scrollbar (Ubuntu)") means the current development release (currently, "raring"). If it is backported to the current stable or LTS release, it will be specified in the bug report.

But...
I'm currently on raring with an up-to-date overlay-scrollbar (0.2.16+r359daily13.02.06-0ubuntu1) and I tried resizing the left panel in Nautilus, but it doesn't seem to work. Nothing has changed from before: I only get the horizontal resize cursor for a fraction of second before the overlay scrollbar appears, and then, I can't get the "resize" cursor to appear on the thumb.
Even if I try resizing from the thumb, nothing happens.

I see both branches are "Needs Fixing" by jenkins, so maybe the fix never actually got anywhere?

John Lea (johnlea) wrote :

Reverting status to "Triaged", see comment above. If after re-testing this is now fixed, please change back to fix-released

Changed in overlay-scrollbar:
status: Fix Committed → Triaged
Changed in overlay-scrollbar (Ubuntu):
status: Fix Released → Triaged
Changed in overlay-scrollbar:
status: Triaged → In Progress
Changed in overlay-scrollbar (Ubuntu):
status: Triaged → In Progress
Changed in overlay-scrollbar:
assignee: Andrea Azzarone (andyrock) → Brandon Schaefer (brandontschaefer)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:overlay-scrollbar at revision None, scheduled for release in overlay-scrollbar, milestone Unknown

Changed in overlay-scrollbar:
status: In Progress → Fix Committed
Changed in overlay-scrollbar (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.16+r359+13.10.20130826-0ubuntu1

---------------
overlay-scrollbar (0.2.16+r359+13.10.20130826-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Remove the check if a GtkPaned is H/VPaned, as its deprecated in gtk
    3.0. Now just use the priv->side to tell if which way its facing. If
    its true on the side, then allow paned to be resized. (LP: #907837)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 379
 -- Ubuntu daily release <email address hidden> Mon, 26 Aug 2013 22:04:43 +0000

Changed in overlay-scrollbar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers