alt-backtick doesn't work properly

Reported by Martin Pool on 2011-12-22
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
metacity
New
Medium
metacity (Ubuntu)
Status tracked in Trusty
Precise
Medium
Unassigned
Trusty
Undecided
Unassigned
unity-2d (Ubuntu)
Status tracked in Trusty
Precise
Medium
Unassigned
Trusty
Undecided
Paul Sladen

Bug Description

In Unity (and I presume unity-2d) alt-backtick (alt-grave, alt-key-above-tab) is meant to flip between the active windows of the current application. In precise unity-2d for me it shows a switcher window with 4 icons for the four windows of my current app (chrome), but repeated presses of backtick while holding alt just flip between the focussed window and the next window, not around all four.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-2d 4.12.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-5.11-generic 3.2.0-rc5
Uname: Linux 3.2.0-5-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Dec 22 16:23:53 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SourcePackage: unity-2d
UpgradeStatus: Upgraded to precise on 2011-12-15 (7 days ago)

Martin Pool (mbp) wrote :

I think this may be "by design" in Unity 2d, since the alt-tic behavior is a compiz feature, and 2d uses metacity. Assigned to paul to get the design team perspective to know if this is a bug.

Changed in unity-2d (Ubuntu):
assignee: nobody → Paul Sladen (sladen)
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Albert Astals Cid (aacid) wrote :

Seems to work here, can you guys confirm that pressing the backtick key actually creates a backtick (i.g. in a firefox text box)?

Daniel Miller (bonsaiviking) wrote :

@aacid `yes` it does.

Changed in metacity:
importance: Unknown → Medium
status: Unknown → New
Jeffrey Knockel (jeff250) wrote :

I've filed a metacity bug upstream with a proposed patch.

In the meantime, as a workaround, if your gconf setting for /apps/metacity/global_keybinds/switch_group is '<Alt>Above_Tab', then try setting it to '<Alt>grave' (ensure a lowercase 'g'), assuming the key above your tab key is a backtick. Then log out and log back in again to make sure metacity is using the new setting.

Jeffrey Knockel (jeff250) wrote :

Here's a debdiff incorporating the proposed patch.

The attachment "Proposed debdiff for trusty" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Dimitri John Ledkov (xnox) wrote :

Unity-2d is last present in Precise. Whilst the bug is "metacity" component, it is used exclusively by unity-2d in such a way. Thus this metacity patch should go into precise, direct as SRU, as the only mean to fix unity-2d in Precise.

Please update the bug description as per: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Changed in metacity (Ubuntu Trusty):
status: New → Invalid
Changed in metacity (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
importance: Low → Medium
Changed in unity-2d (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in unity-2d (Ubuntu Trusty):
status: Confirmed → Invalid
importance: Low → Undecided
Jeffrey Knockel (jeff250) wrote :

Dimitri, I use metacity in saucy/trusty via gnome-session-flashback, so shouldn't the bug/patch be valid for trusty as well?

Timo Jyrinki (timo-jyrinki) wrote :

Jeffrey, you're correct regarding metacity if the same problem is seen outside of unity-2d, so the bug should be valid for trusty even though there are now fewer environments using it.

I think ideally metacity would be in universe, but it's still depended upon by compiz packaging wise.

Changed in metacity (Ubuntu Trusty):
status: Invalid → Triaged
Timo Jyrinki (timo-jyrinki) wrote :

And... Thanks! I've built and successfully tested the patched metacity on trusty at ppa:timo-jyrinki/ppa :)

I installed gnome-session-fallback, and with the patched metacity I was able to use alt-grave to switch between 3+ same windows (similar to Compiz/Unity), unlike without the patch. I also tested a few combinations of different apps, and I didn't find anything to complain. Debdiff looked good too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.34.13-0ubuntu4

---------------
metacity (1:2.34.13-0ubuntu4) trusty; urgency=low

  * debian/patches/22_fix_above_tab_switching.patch:
    - For Above_Tab, don't compare keysym (fixes group switching).
      (LP: #907640)
 -- Jeffrey Knockel <email address hidden> Wed, 22 Jan 2014 22:28:15 -0700

Changed in metacity (Ubuntu Trusty):
status: Triaged → Fix Released
Brian Murray (brian-murray) wrote :

I'm unsubscribing the ubuntu sponsors team at this point in time as there is no debdiff to upload to precise to fix this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.