use symbolic icons

Bug #903819 reported by Andrea Cimitan on 2011-12-13
88
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Application Indicators
Invalid
Wishlist
Unassigned
Ayatana Design
Undecided
Unassigned
indicator-messages (Ubuntu)
Wishlist
Unassigned
indicator-network (Ubuntu)
Wishlist
Unassigned
indicator-session (Ubuntu)
Wishlist
Unassigned
indicator-sound (Ubuntu)
Wishlist
Unassigned
ubuntu-themes (Ubuntu)
Wishlist
Unassigned

Bug Description

Indicators should use symbolic icons.

That has various benefits, counting the two more important:
1. Only need to supply one theme between Ambiance/Radiance whatever.
2. It's way easier to deal with situations like when the unity dash is opened, and icons should turn white: you just need to set the white color and it'll be recolored.

This may depend on bug 599448.

Tags: euv Edit Tag help
Andrea Cimitan (cimi) on 2011-12-13
affects: indicator-applet → indicator-application
Bilal Akhtar (bilalakhtar) wrote :

Don't they use symbolic icons already? The last time I checked with the messaging menu, it used a symbolic icon. I may be wrong, though.

Bilal Akhtar (bilalakhtar) wrote :

As for indicator-application, its the job of the individual app developers to provide symbolic icon, not indicator-application

Changed in indicator-application:
status: New → Invalid
Conor Curran (cjcurran) on 2012-03-30
Changed in indicator-sound:
status: New → Triaged
Olli Ries (ories) wrote :

will need some assets from design

Changed in indicator-application:
importance: Undecided → Wishlist
Changed in indicator-messages:
importance: Undecided → Wishlist
Changed in indicator-network:
importance: Undecided → Wishlist
Changed in indicator-session:
importance: Undecided → Wishlist
Changed in indicator-me:
importance: Undecided → Wishlist
Changed in indicator-sound:
importance: Undecided → Wishlist
Changed in indicator-me:
status: New → Incomplete
Changed in indicator-session:
status: New → Confirmed
Changed in indicator-me:
status: Incomplete → Confirmed
Changed in indicator-sound:
status: Triaged → Confirmed
Changed in indicator-network:
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
no longer affects: indicator-me
Andrea Cimitan (cimi) on 2012-05-02
tags: added: euv
description: updated
Jeremy Bicha (jbicha) wrote :

Could this be higher importance than Wishlist please? It's a fairly old bug and makes third-party themes look bad including Adwaita.

Lars Uebernickel (larsu) wrote :

There are some subtle uses of color in the indicator icons:

 * messaging turns blue (and even had full colored icons briefly last cycle)
 * power cog (indicator-sesision) turns red when there's a problem in online accounts
 * sound turns dark when muted

Right now, this is handled by different icon names for the diffeterent states. For example, indicator-messages-new is a blue version of indicator-messages. I don't know if that can be easily replicated with symbolic icons. At the simplest, we'd need a way to specify the white color (maybe indirectly through widget state or so) when giving GtkImage an icon name.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-03-04
affects: ubuntu-mono (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Ted Gould (ted) on 2013-09-11
Changed in indicator-network:
status: Confirmed → Invalid
Changed in ayatana-design:
status: New → Invalid
Changed in indicator-messages:
status: Confirmed → Invalid
Changed in indicator-session:
status: Confirmed → Invalid
Changed in indicator-sound:
status: Confirmed → Invalid
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) wrote :

Ted, please don't close bugs like this without leaving an explanation.

Adolfo Jayme (fitojb) on 2014-05-26
Changed in ubuntu-themes (Ubuntu):
status: Invalid → Triaged
Adolfo Jayme (fitojb) on 2015-11-28
affects: indicator-messages → indicator-messages (Ubuntu)
affects: indicator-sound → indicator-sound (Ubuntu)
affects: indicator-session → indicator-session (Ubuntu)
affects: indicator-network → indicator-network (Ubuntu)
Changed in indicator-messages (Ubuntu):
status: Invalid → Triaged
importance: Wishlist → High
Changed in indicator-network (Ubuntu):
status: Invalid → Triaged
importance: Wishlist → High
Changed in indicator-session (Ubuntu):
status: Invalid → Triaged
importance: Wishlist → High
Changed in indicator-sound (Ubuntu):
status: Invalid → Triaged
importance: Wishlist → High
Changed in ubuntu-themes (Ubuntu):
importance: Wishlist → High
Ted Gould (ted) on 2016-01-19
Changed in indicator-messages (Ubuntu):
importance: High → Wishlist
Changed in indicator-network (Ubuntu):
importance: High → Wishlist
Changed in indicator-session (Ubuntu):
importance: High → Wishlist
Changed in indicator-sound (Ubuntu):
importance: High → Wishlist
Changed in ubuntu-themes (Ubuntu):
importance: High → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers