Launcher, Spread - Clicking on a Launcher app icon a second time to close a spread is broken

Bug #893670 reported by John Lea on 2011-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
High
Andrea Azzarone
compiz (Ubuntu)
High
Andrea Azzarone
nux (Ubuntu)
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

Launcher, Spread - Clicking on a Launcher app icon a second time to close a spread is broken

To Reproduce:
1. Open two Chromium windows
2. Open Thunderbird, and open a new email window
3. Click on the Chromium icon to focus one of the Chromium windows
4. Click on the Thunderbird Launcher icon to focus the Thunderbird new email window
5. Click on the Thunderbird Launcher icon again to spread the two Thunderbird windows
6. Wait one second
7. Click on the Thunderbird Launcher icon again to close the spread

What currently incorrectly happens:
- Nothing! The focus arrow jumps briefly but the spread does not close. Also the App title integrated into the top bar is displaying the wrong application name; it is displaying the name of the Chromium window however it should be displaying 'Thunderbird' because this application got the focus in step 4 above.

What should happen:
- Clicking on the Thunderbird Launcher icon when the Thunderbird spread is open should close the spread and return the user to exactly the same state they were in before the spread opened (step 4).

A screencast of this bug in action is available at https://chinstrap.canonical.com/~johnlea/problem_closing_spread.ogv

To reproduce this bug read here: https://bugs.launchpad.net/unity/+bug/893670/comments/1

Workaround:
When the spread starts move the mouse pointer on a scaled window.

Related branches

John Lea (johnlea) on 2011-11-22
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp
John Lea (johnlea) on 2011-11-22
description: updated
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
importance: Undecided → High
Andrea Azzarone (azzar1) wrote :

After spending two days trying to figure out how to fix this bug, I've found the right way to reproduce this bug:
[*] Open two or more windows of gnome-terminal
[*] Open a window of gedit
[*] Put the gedit window behind the gnome-terminal launcher icon
[*] Focus a gnome-terminal window
[*] Click on gnome-terminal launcher icon
[*] The spread should start

What happens now is that the gedit window gets the focus (because it's behind the gnome-terminal launcher icon, of course it's weird) so clicking again on gnome-terminal launcher doesn't work.

description: updated
Andrea Azzarone (azzar1) on 2012-01-13
description: updated
John Lea (johnlea) wrote :

@andyrock; thanks! I remember this was a hard one to reproduce.

Andrea Azzarone (azzar1) on 2012-01-14
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
importance: Undecided → High
status: New → In Progress
Changed in nux (Ubuntu):
status: New → In Progress
Changed in nux:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Omer Akram (om26er) wrote :

/me wonders where did the 5.2.0 milestone vanish :/

Changed in unity:
milestone: backlog → none
Andrea Azzarone (azzar1) on 2012-01-17
Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-01-17
Changed in compiz-core:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Undecided → High
Changed in compiz-core:
status: New → In Progress
Changed in compiz (Ubuntu):
status: New → In Progress
Changed in compiz-core:
importance: High → Medium
Changed in compiz (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in compiz-core:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Andrea Azzarone (azzar1) on 2012-01-18
Changed in unity:
milestone: none → 5.2.0
Tim Penhey (thumper) on 2012-01-23
Changed in nux:
milestone: none → 2.2
Jay Taoko (jaytaoko) on 2012-02-02
Changed in compiz-core:
status: In Progress → Invalid
Changed in compiz (Ubuntu):
status: In Progress → Invalid
Changed in unity:
status: In Progress → Fix Committed
no longer affects: compiz-core
no longer affects: nux
Changed in unity (Ubuntu):
status: In Progress → Invalid
Changed in nux:
status: New → Fix Released
Didier Roche (didrocks) on 2012-02-02
Changed in nux:
milestone: none → 2.2
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.2.0-0ubuntu1

---------------
nux (2.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - Launcher, Spread - Clicking on a Launcher app icon a second time to
      close a spread is broken (LP: #893670)
    - launcher not hiding in one design-specified case (LP: #919162)
    - compiz crashed with SIGSEGV in
      nux::GridHLayout::KeyNavIterationRowOrder() (LP: #916088)
  * Cherry-pick an additional fix for boot time
 -- Didier Roche <email address hidden> Fri, 03 Feb 2012 11:35:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
Nick Tait (jnick-tait) on 2012-03-07
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Changed in unity (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers