Dash - Most Frequently Used apps change to Recently Used, without Launcher favorites

Bug #893214 reported by John Lea on 2011-11-21
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
High
Mikkel Kamstrup Erlandsen
unity-lens-applications
High
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

The apps shown in the default view of the 'Most frequently used' category header in the App Lens and Dash Home should exclude applications that are currently in the Launcher (both pinned and running).

Desired resolution:
- Exclude apps that are currently in the Launcher from the 'Most frequently used' *default view* (the 'default view' is the results that are presented to the user before any search query is entered or any search filters are used).
- When a search query is entered and/or a search filter is used, the results returned should include apps that are currently in the Launcher.
- The category header text should be renamed from "Most frequently used" to "Recently Used"

Related branches

John Lea (johnlea) on 2011-11-21
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
summary: Dash - The apps shown in the default view of the 'Most frequently used'
- category header should exclude application that are currently in the
+ category header should exclude applications that are currently in the
Launcher
John Lea (johnlea) on 2011-11-21
description: updated
John Lea (johnlea) on 2011-12-05
description: updated

There are three coding tasks related to this bug:

 - Change the Zeitgeist query and string in unity-lems-applications (easy)
 - Add API in libunity to enumerate favorite apps in the launcher (bug #900219, medium)
 - Given said new API, extract favorite apps from the result (easy)

summary: - Dash - The apps shown in the default view of the 'Most frequently used'
- category header should exclude applications that are currently in the
- Launcher
+ Dash - Most Frequently Used apps change to Recently Used, without
+ Launcher favorites
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
milestone: backlog → 5.0.0
status: Confirmed → Triaged
Changed in unity-lens-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
milestone: none → 5.0.0
status: New → Triaged

My attached branch does as requested; modulo a bug in how we query Zeitgeist.

FIXME: For some reason the query we send doesn't get the apps sorted for most recent, but some other hard-to-decipher way. If I send an identical query from the 'talis' command line tool I *do* get the correct sorting. ?!

The problem from my comment #2 has been addressed in the branch now. It was bug #912719. The only thing missing in order to make this ready to go is to update the apps lens automatically whenever new apps are detected.

Gord Allott (gordallott) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Changed in unity-lens-applications:
milestone: 5.0.0 → 5.0.2
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Changed in unity:
status: Triaged → Fix Committed
Changed in unity-lens-applications:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in unity-lens-applications (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.2.0-0ubuntu1

---------------
unity-lens-applications (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Apps Lens passes wrong arguments to Zeitgeist search (LP: #912719)
  * debian/control:
    - ensure we continue building with vala 0.14
    - put the transitional package to extra priority
    - build-dep on latest libunity-dev
 -- Didier Roche <email address hidden> Fri, 03 Feb 2012 11:40:17 +0100

Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-02-08
Changed in ayatana-design:
status: Triaged → Fix Committed

Pined launcher apps are still l showing in recently used in home lens and application lens.

Omer Akram (om26er) wrote :

Corey no they are not I just tried using unity from staging ppa and the issue is not here.

Alrite if it is fixed in staging great. but the report said fixed released as of 5.2 I'm on 5.4 it still happens. Could it caused because most of my launcher icons are customized and saved in ~/.local/applications? They overwrite stock launchers as far as the menu is concerned, but perhaps the filter isn't catching them?

Nick Tait (jnick-tait) on 2012-03-12
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers