Launcher - The Launcher icon alert animation should repeat with decreasing frequency until user reveals the Launcher

Reported by John Lea on 2011-11-21
130
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend

Bug Description

The Launcher icon alert animation should repeat with decreasing frequency until user reveals the Launcher. This is Unity's way of notifying you that a window has been updated.

Currently when a application issues an alert command to the Launcher and the Launcher is hidden, the icon (but not the Launcher) pops out on to the desktop and performs a short wiggle. If the Launcher is hidden and the user does not spot this single alert, there is currently nothing visible on the screen to notify the user that the application has a outstanding alert signal.

Desired Resolution:

- When a application issues an alert and the Launcher is hidden, the application icon should pop out, wiggle, then hide again, with decreasing frequency for a total of 32 minutes.
- The application icon should pop out at the following intervals after the alert is issued: 1 minute, 2 minutes, 4 minutes, 8 minutes, 16 minutes, 32 minutes.
- As soon as the user reveals the Launcher, all applications that have current outstanding alerts should do a short wiggle inside the Launcher. The current outstanding alerts are then all cancelled (the icons will stop popping out and wiggling) .
- When the Launcher is visible, application alerts should should be indicated by a short wiggle (in addition to the existing blue pips). This short wiggle should not repeat.

Tags: udp Edit Tag help

Related branches

lp:~townsend/unity/fix-urgent-icon-wiggle
Merged into lp:unity at revision 3367
Marco Trevisan (Treviño): Approve on 2013-06-10
PS Jenkins bot: Approve (continuous-integration) on 2013-06-10
Brandon Schaefer: Approve on 2013-05-31
John Lea (johnlea) on 2011-11-21
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
tags: added: udp
summary: Launcher - The Launcher icon alert animation should repeat with
- decreasing frequency until user clicks on app icon
+ decreasing frequency until user reveals launcher
description: updated
summary: Launcher - The Launcher icon alert animation should repeat with
- decreasing frequency until user reveals launcher
+ decreasing frequency until user reveals the Launcher
description: updated
description: updated
description: updated
description: updated
Tim Penhey (thumper) on 2011-11-25
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
importance: Undecided → Medium
status: Confirmed → Triaged
Jens Finkhäuser (unwesen) wrote :

Please also see #883000 - just repeating the notification isn't good enough when you don't know which window issued the notification.

Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) on 2012-02-09
Changed in unity (Ubuntu):
importance: Undecided → Medium
John Lea (johnlea) on 2012-03-05
description: updated
Thiago (copocaneta) wrote :

Such an old bug and nothing has been done towards that? I already gave up on Ubuntu because of this same exact missing "feature" before, giving it a check now so I can try again, please guys make this happen!

Jaceq (dzacek83) wrote :

Any update on this? Is repeating notification such a problem?
This is the biggest issue with unity (second is fact I can't move launcher to the bottom).

Adolfo Jayme (fitoschido) wrote :

@Jaceq: I think that we would like to see all our bugs fixed in a timely manner. But you could tell from the bug status that no progress has been made and this is available for any developer who wants to fix it.

From https://help.ubuntu.com/community/ReportingBugs: "Please do not complain about how long it takes to fix a bug [...] Especially, if you have not followed the directions mentioned in this article, let alone contributed code upstream. This type of behavior is unconstructive, irritating to others who read your e-mail, and spammy".

John Lea (johnlea) wrote :

@dzacek83; patches welcome ;-) It would be great to see this fixed, the sooner someone volunteers to make this improvement the sooner it will land in Ubuntu.

Stephen M. Webb (bregma) on 2013-04-25
Changed in unity:
milestone: backlog → 7.1.0
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.19-0ubuntu1

---------------
unity (7.0.0daily13.06.19-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Bump libunity-core SONAME and adjust debian.

  [ Ted Gould ]
  * Make Unity depend on bamfdaemon.

  [ Iain Lane ]
  * Start unity-panel-service using upstart user session jobs.

  [ Brandon Schaefer ]
  * Fixes the use of Alt+` and Right arrow when in detail mode. Now it
    goes to the next window instead of closing detail mode. (LP:
    #1190798)
  * When in detail mode, you are now allowed to use UP/DOWN keys to move
    around. (LP: #1131646)

  [ Chris Townsend ]
  * Add functionality to wiggle urgent icons at certain time intervals
    when the Launcher is hidden. (LP: #893196)
  * Add support to close social previews by clicking anywhere in the
    preview bubble. (LP: #1190007)

  [ Nick Dedekind ]
  * Added check for x-unity-no-preview. Do not preview; send direct
    activation to scope. (LP: #1188705)

  [ Xiao-Long Chen ]
  * SessionView: Fix build when building without precompiled headers.
    (LP: #1191097)

  [ Andrea Azzarone ]
  * Fix failing AP test. (LP: #1191039)
  * Fix failing test. (LP: #1191059)
  * Skip tests if not in desktop mode. (LP: #1191053)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3378
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:29:36 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints