Keyboard shortcut - shortcuts need to updated as part of the 12.04 upgrade

Bug #891757 reported by John Lea on 2011-11-17
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
compiz (Ubuntu)
Medium
Didier Roche
compiz-plugins-main (Ubuntu)
Undecided
Didier Roche
metacity (Ubuntu)
Undecided
Didier Roche

Bug Description

The SUPER+D shortcut to minimise all windows works on some computers but not on others, perhaps due to the upgrade process carrying over previous keyboard shortcut settings??? As part of the 12.04 upgrade process, SUPER+D should be mapped to 'minimise all windows' so that this shortcut works on both computers that are upgraded as well as on fresh installs.

Desired solution:

- Ensure that all of the keyboard shortcuts detailed in the following google doc work on all computers that are upgraded to 12.04 (in addition to working on fresh installs). If a existing keyboard shortcut setting conflicts with one of the shortcuts detailed here, the existing keyboard shortcut should be overwritten. However where there is no conflict between the existing keyboard shortcuts and the new shortcuts, the existing shortcuts should always be preserved.

See https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit?authkey=CLGG9NkJ&hl=en_GB for full details

John Lea (johnlea) on 2011-11-17
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
status: New → Confirmed
tags: added: udp
Changed in ayatana-design:
status: New → Triaged
summary: - SUPER+D shortcut to minimise all windows does not work on some computers
+ SUPER+D shortcut to minimise all windows does not work on some
+ computers, and keyboard shortcuts need to updated when upgrading
summary: SUPER+D shortcut to minimise all windows does not work on some
- computers, and keyboard shortcuts need to updated when upgrading
+ computers, and keyboard shortcuts need to updated as part of the 12.04
+ upgrade
summary: - SUPER+D shortcut to minimise all windows does not work on some
- computers, and keyboard shortcuts need to updated as part of the 12.04
- upgrade
+ Keyboard shortcuts need to updated as part of the 12.04 upgrade
description: updated

Do we have a tag to track items that should be explicitly set on upgrade
/ login-to-upgraded-system? And a document listing the test plans for that?

Mark

I'm running a fresh installed oneiric on my notebook and Super+D doesn't work (Ctrl+Alt+D does).

Omer Akram (om26er) on 2011-11-18
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2011-12-12
summary: - Keyboard shortcuts need to updated as part of the 12.04 upgrade
+ Keyboard shotcut - shortcuts need to updated as part of the 12.04
+ upgrade
tags: added: keybinding
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - shortcuts need to updated as part of the 12.04
+ Keyboard shortcut - shortcuts need to updated as part of the 12.04
upgrade
Didier Roche (didrocks) on 2012-02-22
affects: unity (Ubuntu) → compiz (Ubuntu)
Didier Roche (didrocks) on 2012-02-22
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in compiz (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in metacity (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu5

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu5) precise; urgency=low

  * Change some keybindings as per design (LP: #878820, #891757, #751050)
    debian/patches/ubuntu-config.patch:
    - Show desktop is now Super + d
    - Super + Up maximize the window
    - Super + Down restore the window
    - Super + W initiate scale for all windows on current ws
    - Control + Alt + NumPad 5 is used to switch/restore maximize state
    - Control + Alt + NumPad 0 is used to minimize current window
    - Ensure we don't have any conficting keys anymore (LP: #922354)
  * 01_ctrl_alt_*tea*.patch:
    - Merged into ubuntu-config.patch, no reason to keep it separated
  * debian/compiz-gnome.gconf-defaults, debian/rules, debian/unity.ini:
    - Set the new plugin order with the incoming unity change as the default
 -- Didier Roche <email address hidden> Wed, 22 Feb 2012 13:44:25 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu3

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu3) precise; urgency=low

  * apply design changes for the keybindings (LP: #878820, #891757, #751050),
    debian/patches/ubuntu_config.patch:
    - Control + Alt + KP_5: don't center, used for toggling maximize state
      by core
    - Remove Control + Alt + KP_0 to not maximize, (used to minimize in core)
    - Super + Left, Right key to semi maximize and stack on left or right
    - Remove zoom in/out/box (like in oneiric and before). Those should be
      enabled in g-c-c with the a11y tools.
 -- Didier Roche <email address hidden> Wed, 22 Feb 2012 15:04:30 +0100

Changed in compiz-plugins-main (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.34.1-1ubuntu6

---------------
metacity (1:2.34.1-1ubuntu6) precise; urgency=low

  * debian/metacity-common.gconf-defaults:
    toggling keybindings value as per design request (metacity and integration
    with gnome-control-center part for compiz): (LP: #891757)
    - Show desktop is <Super>d
    - Maximize is <Super>Up
    - UnMaximize is <Super>Down
    - Toggle Maximize is <Control><Alt>KP_5
    - Minimize is <Control><Alt>KP_0
    - Navigate to ws is <Super><Shift> + cursor keys
    - Move focus window to a different workspace is <Super><Alt>Cursor Keys
 -- Didier Roche <email address hidden> Wed, 22 Feb 2012 16:15:27 +0100

Changed in metacity (Ubuntu):
status: New → Fix Released
nick rundy (nrundy) wrote :

Why are Microsoft Windows shortcuts being adopted? Microsoft's keyboard shortcuts are not necessarily better.

Please don't adopt the Super+Down-arrow shortcut key to restore and minimize windows. This is inconvenient because when users want to minimize a window that is presently maximized they have to press Super+Down+Down instead of simply pressing Alt+F9.

Using thunderbird is a good example. When Thunderbird is opened, user maximizes window, deals with emails and then taps Alt+F9 to minimize the window. Later user notices new emails have arrived so he taps Super+3 and opens Thunderbird. This is much simpler than having to tap Super+Down+Down every time to minimize the window.

Why are existing long-standing keyboard shortcuts suddenly deemed as unacceptable and in need change? And why are Microsoft Windows' keyboard shortcuts being adopted for everything that's changing. It is better to be able to tap Alt+F5 and KNOW you get a restored window. Or tap Alt+F9 and KNOW you get a minimized window.

PLEASE rethink this!

nick rundy (nrundy) wrote :

What does it mean that the Alt+F1 keyboard shortcut is crossed out in the Google Docs document?

I prey this doesn't mean this keyboard shortcut has been canceled! This keyboard shortcut is enormously helpful and productive! A great example comes from users who hide the Launcher and use Alt+F1 to reveal the Launcher and keep it revealed until the user taps Esc. The user may want to keep the Launcher revealed temporarily to monitor the status of a download while they read from a window on the other side of the display, etc.

nick rundy (nrundy) wrote :

Guys, how about keeping the same "traditional" pattern for window-controls (e.g., minimize and maximize) but simply switch ALT for SUPER as the modifier?:

Alt+F10 becomes Super+F10
Alt+F5 becomes Super+F5
Alt+F9 becomes Super+F9
etc.

And the Launcher Keyboard Navigation Mode keyboard shortcut could even be switched from Alt+F1 to Super+F1

HERE'S A FULL LIST OF MY PROPOSED SHORTCUTS (For shortcuts I changed from the current Google Doc I added *** to the beginning):

Launcher:
Super (press) Open Launcher, displays shortcuts
***Super + F1 Open Launcher keyboard navigation mode
Super + Tab Switch applications via launcher
Super + 1 to 9 Same as clicking on a Launcher icon
Super + Shift + 1 to 9 Open new window of the app
Super + T Open the Rubbish Bin

Dash:
Super (Tap) Open the Dash home
Super + A Open the Dash App Lens
Super + F Open the Dash Files Lens
Super + M Open the Dash Music Lens
Ctrl +Tab Switches between Lenses
Cursor Keys Moves the focus
Enter & Return Open currently focused item

Switching:
Alt + Tab Switch between applications
Alt + Grave Switch windows of current application
Cursor Left or Right Moves the focus

HUD and Top Bar:
Alt (Tab) Open the HUD
Alt (Press) Reveals application menu
Alt + F10 Open the indicator menu
Cursor Left or Right Moves focus between indicators

Windows:
Super + W Spreads all windows in the current workspace

***Super + F12 Horizontally maximize the current window (i.e., stretch the left and right sides of window to screen maximum)
***Super + F11 Vertically maximize the current window (i.e., stretch the top and bottom of window to screen maximum)
***Super + F10 Maximise the current window
***Super + F9 Minimise the current window
***Super + F8 Move the current window
***Super + F7 Move the current window to the "right half" of the screen
***Super + F6 Move the current window to the "left half" of the screen
***Super + F5 Restore the current window
***Super + F4 Resize the current window
***Super + F3 Minimize ALL windows
***Super + F2 Run command (or Alt+F2)
***Super + F1 activate "Launcher Keyboard Navigation Mode "

Alt + F4 Close current window
Alt + Space Opens window accessibility menu
Ctrl + Alt + Num Places window in corresponding positions on the screen
Alt + Left Mouse Drag Move window
Alt + Middle Mouse Drag Resize window

Workspaces:
Super + S Spread workspaces
***Super + Alt + Cursor Keys Switch workspaces
***Super + Shift + Alt + Cursor Keys Move focused window to different workspace

Nick Tait (jnick-tait) on 2012-03-07
tags: added: furtherdesignreviewrequiredp
HaddadR (hr-haddad) wrote :

when trying to resize windows using shortcuts ( super +up/left/right) , the summery shortcuts windows is open and stay on screen

John Lea (johnlea) on 2012-04-26
tags: added: reviewedbydesignp
removed: furtherdesignreviewrequiredp keybinding udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers