search quicklist items [$50]

Bug #888776 reported by Daniel Fore on 2011-11-10
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Slingshot
Wishlist
Adam Bieńkowski
Synapse
Wishlist
Jeremy Munsch
Unity
Opinion
Wishlist
Unassigned
unity-lens-applications
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned
unity-lens-applications (Ubuntu)
Wishlist
Unassigned

Bug Description

There's currently a trend of application developers to provide multiple .desktops for their apps in order to get to different parts of the app (for example private browsing in a web browser). One possible way to fulfill that need without needing multiple .desktops littered around would be to have popular search-based launchers also search through quicklist items in a .desktop. In this way, power users who need quick access to those other functions can have them without littering menus or grids with extra icons.

It's also important to note that many apps already use Quicklist items this way (as that's the designed use); adding the ability to search them would be an improvement to everyone as it'd expose those quicklist items via keyboard rather than requiring users to right-click on the launcher item.

Related branches

lp:~donadigo/slingshot/search-quicklist
Florian Angermeier (community): Approve (code) on 2015-09-24
Daniel Fore: Approve (ux) on 2015-09-20
elementary Pantheon team: Pending (code) requested 2015-09-20
lp:~jeremy-munsch/synapse-project/desktop-file-actions
Rico Tzschichholz: Approve on 2015-11-10
Bilal Akhtar (bilalakhtar) wrote :

Sorry Dan if I'm not able to understand it well, but do you mean to say that applications with multiple desktop files should be listed as one application in Unity, etc and the remaining desktop files of that particular app should be shown as quicklist items for that same application?

Let's get down to an example:

Imagine firefox has three desktop files: Firefox, Firefox (safe mode) and Firefox (private browsing)

In Unity, firefox should be displayed as just one application. When added to the launcher, Firefox should have 2 more options in the right click menu; safe mode and private browsing. Unity and other launchers should do all the hard work of finding desktop files for the same app and making appropriate quicklists for those.

Is that what you mean by this bug? If yes, then I'll mark this bug accordingly. If no, then please correct me.

Daniel Fore (danrabbit) wrote :

No, not at all. What I meant was that Unity quick list items should show up in search results. That's all :p

Omer Akram (om26er) on 2011-12-01
Changed in unity:
importance: Undecided → Wishlist
Bilal Akhtar (bilalakhtar) wrote :

All right, needs design discussion then. Should be good to go without it, but I prefer the safe way

tags: added: needs-design
Changed in unity:
status: New → Incomplete
Changed in unity-lens-applications:
status: New → Incomplete
Changed in unity-lens-applications (Ubuntu):
status: New → Incomplete
John Lea (johnlea) on 2011-12-12
Changed in ayatana-design:
status: New → Opinion
David Gomes (davidgomes) on 2012-01-14
Changed in slingshot:
status: New → Confirmed
importance: Undecided → Wishlist

Bilal, to expand on your previous example:

Firefox should provide ONE .desktop file, then have quicklist items for the Private Browsing and Safe Mode items. In that case, those items should be searchable in Unity/Synapse/Slingshot. It'd prevent having multiple listings for the same app while also utilizing an already-present method of exposing apps' features to Unity.

description: updated
Cody Garver (codygarver) on 2013-04-16
Changed in midori:
status: New → Incomplete
importance: Undecided → Wishlist
Changed in slingshot:
status: Confirmed → Incomplete
Changed in unity-lens-applications:
importance: Undecided → Wishlist
Changed in ayatana-design:
status: Opinion → Invalid
status: Invalid → Opinion
Daniel Fore (danrabbit) on 2014-03-01
no longer affects: midori
Changed in slingshot:
status: Incomplete → Confirmed
Daniel Fore (danrabbit) on 2015-03-26
Changed in slingshot:
milestone: none → loki-beta1
Daniel Fore (danrabbit) wrote :
summary: - search quicklist items
+ search quicklist items [$50]
Andrea Azzarone (azzar1) on 2015-09-18
Changed in unity:
status: Incomplete → Opinion
Changed in unity (Ubuntu):
status: Incomplete → Opinion
Changed in unity-lens-applications:
status: Incomplete → Opinion
Changed in unity-lens-applications (Ubuntu):
status: Incomplete → Opinion
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in slingshot:
status: Confirmed → In Progress
assignee: nobody → Adam Bieńkowski (donadigo)
Daniel Fore (danrabbit) on 2015-09-29
Changed in slingshot:
status: In Progress → Fix Committed
Sam Thomas (sgpthomas) wrote :

I think that all the actions for an application should show up when you search for it, not just when you search for the particular action. This is because a user might not know the particular name of the action they want, instead thy would only know the name of the application.

Changed in synapse-project:
assignee: nobody → Kwaadpepper (jeremy-munsch)
status: New → In Progress
Changed in synapse-project:
status: In Progress → Fix Committed
Changed in synapse-project:
status: Fix Committed → In Progress
Daniel Fore (danrabbit) on 2015-10-22
Changed in slingshot:
milestone: loki-beta1 → loki-alpha1
Changed in synapse-project:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in synapse-project:
status: In Progress → Fix Committed
importance: Undecided → Wishlist
milestone: none → 0.2.99.2
Changed in synapse-project:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2016-08-14
Changed in slingshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers