Dash lens bar should be keyboard navigable.

Reported by Luke Yelavich on 2011-10-26
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

 affects unity

 affects ubuntu/unity
 status triaged

 affects unity-2d

 affects ubuntu/unity-2d
 status triaged
 tag a11y

Navigating the dash in both unity and unity 2d is pretty much the same, however navigating the lenses at the bottom of the dash window differs between the two dash implementations. In Unity 2d, at the moment, you navigate between the lenses by using the arrow keys to move down to the bottom of the window, using the left/righ tarrow keys to select the lens you want, and press enter. In unity 3D, to navigate between lenses, you use the tab, and shift + tab keys to move between lenses, which immediately moves you to the next/previous lens in the list.

I think it would be a good idea if the keyboard navigation for lenses was the same.

Related branches

lp:~andyrock/unity/lens-bar-keynavigation
Merged into lp:unity at revision 1916
Thomi Richards: Approve on 2012-02-07
Andrea Cimitan: Approve (design) on 2012-02-06
Michał Sawicz (saviq) on 2011-10-26
tags: added: needs-design
Gerry Boland (gerboland) on 2011-10-26
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: Triaged → Confirmed
tags: added: delta-with-3d
Didier Roche (didrocks) on 2011-11-22
Changed in unity:
status: New → Triaged
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
summary: - Inconsistant keyboard navigation in both unity dash environments.
+ Dash lens bar should be keyboard navigable.

Andrea, could you please explain why this bug does not affect unity-2d? This bug is about the different keystrokes required to navigate between lenses for unity 2D and 3D, and that the keyboard navigation keystrokes need to be the same in both environments.

Andrea Azzarone (andyrock) wrote :

@Luke
Because we should adapt the unity 3d dash keyboard navigation to the unity 2d one because the latter is the wanted behaviour.

Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: none → 5.2.0
Omer Akram (om26er) on 2012-01-21
no longer affects: unity-2d
no longer affects: unity-2d (Ubuntu)
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
milestone: 5.2.0 → 5.4.0
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers