calendar applet no longer grays out days for months other than current

Reported by Matt Hanyok on 2011-10-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Matthew Paul Thomas
Indicator Date and Time
Undecided
Unassigned
Ubuntu theme
Undecided
Adolfo Jayme
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Sorry for the clunky summary. I couldn't come up with a different way to phrase it. A picture is worth a thousand words, though.

In 11.10, 64 bit, the calendar applet isn't displaying days the way it did in 11.04.

Previous behavior in 11.04, I found an image of it via google:

http://cdn.omgubuntu.co.uk/wp-content/uploads/2010/12/Screenshot-4.png

If that link doesn't work, it's a few pictures down on this page:

http://www.omgubuntu.co.uk/2010/12/ubuntu-11-04-alpha-1-released/

Well, in 11.10 with the available updates (just checked update manager and it came up empty), instead of fading out those days, all of the days are in the same white text (see attached picture).

This makes it more difficult to utilize the applet as it no longer contrasts between the current month displayed and previous/next month.

I haven't made any changes to the default appearance options or theme, using the regular Ubuntu release with the default Unity desktop. If I can provide other information, please let me know what/how.

Related branches

lp:~fitoschido/ubuntu-themes/876167
Merged into lp:ubuntu-themes at revision 273
John Lea: Approve (design) on 2013-02-11
Mathieu Trudel-Lapierre: Approve on 2013-02-11
PS Jenkins bot: Pending (continuous-integration) requested 2013-02-13
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Javier Jardón (jjardon)
Javier Jardón (jjardon) wrote :

Add ayatana-design to get feedback from designers

Matthew Paul Thomas (mpt) wrote :

Thanks for the report. I've made a preliminary update to the specification: "Each date should be sensitive only if it is in the current month and Evolution is installed". <https://wiki.ubuntu.com/TimeAndDate?action=diff&rev2=37&rev1=36>

There are two awkward things about that solution, though.

First, the behavior of the GTK calendar widget is that if you click on a date that isn't in the current month, it navigates to the month that it is in. I don't think mere navigation is appropriate for the calendar in the menu -- clicking a date should either open it in the calendar, or do nothing -- but that does leave make dates a bit slower to navigate than they would be.

The bigger problem is that we no longer have a calendar application shipped by default, and as long as we don't, all the dates will be insensitive, so we'll still have no distinction between those that are and aren't in the current month. And it would be tricky to devise a visual distinction, because we'd then have four states to distinguish: (1) not in the current month, (2) in the current month, Evolution not installed, (3) in the current month, Evolution installed, and (4) has events.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Confirmed
Matt Hanyok (matthew-hanyok) wrote :

Huh. I'm gonna be honest, I hadn't noticed that with the loss of evolution there was no longer a calendar app installed - I use a little black moleskine - but doesn't that seem like a pretty glaring user-friendliness omission?

I realize that Thunderbird took up the email capabilities, did anyone consider including Lightning with it to cover the calendar? Or perhaps shipping Sunbird by default?

Matt Hanyok (matthew-hanyok) wrote :

Alternately, mpt, since that behavior just depends on whether or not evolution is installed, what about this:

- First check for Evolution.
- If installed - behavior as normal (previous behavior)
- If not installed - only differentiate between current / not current month.

Matt Hanyok (matthew-hanyok) wrote :

I was just thinking of this today and decided to install Evolution, just to see if that would make it work.

Even with Evolution installed this still doesn't gray out the days from other months. Is that intentional? Or is it supposed to function as previously (11.04) when Evolution is installed?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Olli Ries (ories) on 2012-03-30
Changed in indicator-datetime:
status: New → Confirmed
Changed in ayatana-design:
importance: Undecided → Medium
John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
importance: Medium → Undecided
status: Confirmed → New
Tom Jaeger (thjaeger) wrote :

The bulk of this needs to be done in ido, but it doesn't seem complicated. And support for marking days that are not in the current month could be added at the same time.

Tom Jaeger (thjaeger) on 2012-10-20
Changed in ido:
status: New → Invalid
Tom Jaeger (thjaeger) wrote :

Sorry, no changes are necessary in ido, since this can be implemented in the theme. Adding the following to '/usr/share/themes/Ambiance/gtk-3.0/gtk-widgets.css' or '/usr/share/themes/Radiance/gtk-3.0/gtk-widgets.css' fixes the issue for me.

.menuitem GtkCalendar:inconsistent {
    color: shade (@bg_color, 0.6);
}

affects: light-themes → ubuntu-themes
affects: ido → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
status: Invalid → Confirmed
Changed in ubuntu-themes:
assignee: nobody → Adolfo Jayme Barrientos (fitoschido)
status: New → In Progress
no longer affects: indicator-datetime (Ubuntu)
Changed in indicator-datetime:
status: Confirmed → Invalid
Changed in ubuntu-themes:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 13.04daily13.02.14-0ubuntu1

---------------
ubuntu-themes (13.04daily13.02.14-0ubuntu1) raring; urgency=low

  [ Adolfo Jayme Barrientos ]
  * calendar applet no longer grays out days for months other than
    current (LP: #876167)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 273
 -- Automatic PS uploader <email address hidden> Thu, 14 Feb 2013 00:01:53 +0000

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-themes:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers