In spread mode, nothing indicates which window is selected

Reported by Simon on 2011-10-16
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

To reproduce the bug
1
,Open multiple windows of any application
2,Trigger spread mode by pressing Super +W
You can select the preview with your keyboard, but there is no indication on the preview themselves that they are selected (unlike Expo mode where there is some sort of halo). You can only see the arrow on the launcher moving. The problem is that when you use your keyboard to select a preview, the keyboard input is interpreted as if you were selecting from the preview area and not from the launcher. Alright, I am not sure that this is very clear, so I am going to make an example with pictures.

In my first picture, the current window is chrome.
I pressed Super+W to activate spread mode (1, Chrome)
Then, I pressed down and it selected libreoffice (2. Libreoffice). Considering that the indication (the little white arrow on the right) as to which preview is selected is only displayed in the launcher, I would expect to be selecting thunderbird instead of libreoffice, since it's the icon underneath chrome in the launcher. Of course, if there were some sort of indications on the previews themselves, then this wouldn't be a problem.
Then I pressed right and it selected Thunderbird (3. Thunderbird) and the white arrow went up in the launcher.

It is a confusing behavior.

Related branches

lp:~3v1n0/unity/scale-window-glow
Merged into lp:unity at revision 2776
John Lea: Approve (design) on 2012-10-01
Andrea Azzarone: Approve on 2012-09-28
Simon (nowis74) wrote :
Simon (nowis74) wrote :
Simon (nowis74) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-17
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
John Lea (johnlea) wrote :

Yes this is confusing and is something we are aware of. Watch this space ;-)

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: Incomplete → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in ayatana-design:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers