top bar, integrated menu - when a application is first launched, the integrated menu should be displayed for 2 seconds before fading out of view

Reported by John Lea on 2011-10-14
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity-2d
High
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

When a application is first launched, the integrated menu should be displayed in the top bar for 2 seconds before fading out of view. Fade should be fast, but experimentation is required to determine exact values.

John Lea (johnlea) on 2011-10-14
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: onew udo
Changed in ayatana-design:
importance: Undecided → High
status: New → Fix Committed
Omer Akram (om26er) on 2011-10-14
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
manny (estelar57) wrote :

glad to see this, it should really help

John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in ayatana-design:
status: Triaged → Fix Committed
Owais Lone (loneowais) wrote :

This should also work when focusing an already open application to indicate that menu got focus.

Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress

A first question, the fade in/out timings should be lower or the same of the default ones?

Tim Penhey (thumper) wrote :

Marco, what are the timings now?

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress

@Tim we use these timings (duration of the animation in ms, of course):

#define PANEL_ENTRIES_FADEIN 100
#define PANEL_ENTRIES_FADEOUT 120

However I'd use greater values for this task.

John Lea (johnlea) on 2011-11-23
description: updated
description: updated
description: updated

Ah, I forgot another question: would you like that the menus are shown just once during a session, or simply every time that an application (currently not launched) is opened? I'm currently doing this, not to waste memory to keep trace of the all the opened applications during a session, but I can switch if you want.

Also... If an application A opens, and suddenly another B application is opened (before than the two seconds are ended). Should we show the menus again when switching the focus to the new A application?

And, in the similar case, if we open a new A application, menus are shown but after less than 2 seconds we switch the focus to another application (not new). When we switch back the focus to the A application, should be the menus shown again?

John Lea (johnlea) wrote :

@Treviño; to answer your questions:

- menus should be shown every time a application is launched (not once per session)
- If another application opens less than 2sec after app A is opened, the top bar switches to displaying the new application's menus (for 2 seconds).
- If the user switches focus from and back to the application in under 2 seconds after opening it, the menus should not be displayed a second time. After a menu stops showing, it should not start showing again.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-12-14
Changed in unity:
milestone: backlog → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
Bartosz Kosiorek (gang65) wrote :

I would like to implement this feature in Unity-2d.
What is your opinion about that?
Is it possible to do that?

manny (estelar57) wrote :

I think the motive was good: make it more discoverable.

but those 2 seconds go extremely fast...

i know where it is and even i miss it (yes even by staring at it).

the problem is when a window opens people focus their eyes on the window and not the top bar. When they focus the top bar the 2 seconds already passed....

so a few solutions might be:

-increase the second amount.

-visible again for a couple of seconds when you restore a window.

or

-confirm the user knows where it is, by keeping it visible for a while or till the first time the user hovers on it.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
tags: added: delta-with-3d
Changed in unity-2d:
assignee: nobody → Bartosz Kosiorek (gang65)
status: Confirmed → In Progress
Albert Astals Cid (aacid) wrote :

Hi Bartosz, you still working on this? I see you've got a Merge Request up, but seem to not have tried to fix Gerry comments in more than a month.

Changed in unity-2d:
assignee: Bartosz Kosiorek (gang65) → nobody
status: In Progress → Confirmed
Bartosz Kosiorek (gang65) wrote :

HI Albert. Not I'm not working on that issue. Unfortunately I'm stuck with it. Feel free to take this task.

tags: added: reviewedbydesignq
removed: udp
tags: removed: reviewedbydesignq
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers