window management, alt-tab - After using 'show desktop' to minimise all windows, opening any new window also incorrectly restores all the minimised windows

Bug #871801 reported by John Lea on 2011-10-10
104
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
Unity Distro Priority
High
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
unity (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Unassigned

Bug Description

After using 'show desktop' to minimise all windows, opening any new window also incorrectly restores all the minimised windows.

---------------------------------------------

To Reproduce (example 1):

1. Open two windows from different applications (say Chromium and Software Center)
2. Press Alt-tab and select the 'show desktop' option. This minimises all open windows
3. Launch a new application (say Firefox)

What currently incorrectly happens:
- all windows minimised by the 'show desktop' command are magically restored the moment the Firefox window opens

Desired correct behaviour:
- When Firefox is launched, only the Firefox window should open. The minimised windows should remain minimised.

---------------------------------------------

To Reproduce (example 2):

1. Open two windows from different applications (say Chromium and Software Center)
2. Press Alt-tab and select the 'show desktop' option. This minimises all open windows
3. Press Alt-tab again and select one of the applications (say the Software Center)

What currently incorrectly happens:
- all windows minimised by the 'show desktop' command are magically restored the moment a single application is selected using Alt-tab

Desired correct behaviour:
- Only the selected application or window should be restored. The other minimised applications and windows should remain minimised.

---------------------------------------------

Desired Resolution:

- Selecting a window or application using either the Launcher, Spread (triggered from the Launcher) or Alt-Tab should not restore unrelated windows that have been minimised using the 'show desktop' function.

- If 'show desktop' is used twice in a row and the user has not opened or restored any windows in the meantime, the second time it is triggered all the windows that were minimised the first time it was triggered should be restored. But if any window has been opened or restored since the first time it was triggered, triggering it again should minimise all open windows. The use case is:

1. User has several windows open
2. User triggers the 'show desktop' function using alt-tab
3. All open windows are minimised
4. User triggers the 'show desktop' function a second time using alt-tab
5. All windows that were minimised the in step 3 above are restored. Windows that were already minimised before alt-tab was triggered in step 2 should remain minimised.

Related branches

John Lea (johnlea) on 2011-10-10
description: updated
description: updated
description: updated
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in ayatana-design:
status: Fix Committed → Triaged
tags: added: udp
John Lea (johnlea) on 2011-10-20
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Revision history for this message
Omer Akram (om26er) wrote :

this bug is not fixed with the linked branch.

Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello John, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Miklos Juhasz (mjuhasz) wrote :

The proposed version did not fix the bug for me. I tried both testcases in the description and all minimized windows were restored each time.

Revision history for this message
John Lea (johnlea) wrote :

@mjuhasz; thanks for testing!

@om26er; could you test again as well?

Revision history for this message
Omer Akram (om26er) wrote :

Yes the issue is not fixed I tested it before it got into -proposed, comment#2

John Lea (johnlea) on 2012-01-15
Changed in unity:
status: Fix Committed → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Omer Akram (om26er) on 2012-01-18
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
Omer Akram (om26er) on 2012-01-18
Changed in unity (Ubuntu):
importance: Medium → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
John Lea (johnlea) on 2012-02-03
Changed in unity (Ubuntu Oneiric):
status: Fix Released → Confirmed
Revision history for this message
Sam Spilsbury (smspillaz) wrote :

Case one was fixed a while ago, Case two is in progress.

Didier Roche (didrocks) on 2012-02-14
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Didier Roche (didrocks) on 2012-02-14
Changed in unity:
milestone: backlog → 5.4.0
Michal Hruby (mhr3) on 2012-02-14
Changed in unity:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2012-02-14
tags: added: compiz-ff-precise
Changed in unity:
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2012-02-15
Changed in compiz-core:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.0
Tim Penhey (thumper) on 2012-02-16
Changed in compiz-core:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu2

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu2) precise; urgency=low

  * debian/compiz-kde.install, debian/control, debian/rules:
    - disable right now kde build for compiz-kde package. It's using
      deprecated kde libraries and fails to build on armel. It's
      probably as well not needed anymore as most of kde users are using
      kwin which is better integrated to kde than compiz. There is not
      anymore upstream compiz maintenance on this plugin as well.
      (LP: #931500)
  * debian/patches/fix_931958.patch:
    impossible to click on keyring dialog since the upgrade. Doesn't really
    fix 931958 as per say, but another issue impacting seahorse.
  * debian/patches/fix_871801.patch:
    window management, alt-tab - After using 'show desktop' to minimise
    all windows, opening any new window also incorrectly restores all
    the minimised windows (LP: #871801)
  * debian/patches/fix_925293.patch:
    Add support for key "tap" detection (LP: #925293)
  * debian/patches/fix_933226.patch:
    Fix FTBFS in previous commit (LP: #933226)
  * debian/patches/fix_932087.patch:
    Initialize the _NET_WM_STATE_FOCUSED (LP: #932087)
  * debian/patches/fix_931473.patch:
    - Menus don't fully appear (LP: #931473)
    - Rendering menus leaves transparent areas (LP: #932813)
  * debian/patches/fix_931927.patch:
    - Customized shortcuts don't work in compiz 1:0.9.7.0~bzr2995-0ubuntu1
      (LP: #931927). Breaks API/ABI.
 -- Didier Roche <email address hidden> Thu, 16 Feb 2012 15:11:51 +0100

Changed in compiz (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Oneiric):
status: New → Confirmed
Changed in compiz-core:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: onew udo udp
Revision history for this message
Mathew Hodson (mhodson) wrote :

The unity package in oneiric-proposed was moved to -updates, and another fix for oneiric has not been committed, so removing the verification-needed tag.

tags: added: oneiric
removed: verification-needed
Revision history for this message
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-03
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers