Ubuntu right-to-left consistency

Reported by Stéphane Graber on 2011-10-10
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
Unity
Wishlist
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-greeter (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Most toolkits properly deal with right-to-left, properly inverting the UI.

When doing ISO testing, I noticed it's not quite the case for unity greeter and unity, here are some notes of the inconsistencies I noticed:

= Unity =
- Launcher is on the left, identical to a left-to-right system
- Indicators are on the right, identical to a left-to-right system

I'm not sure what's the best as I'm not a right-to-left user myself, but we should either have Unity also invert its UI, making it consistent with what's done in the greeter's panel.

[This report previously also covered RTL in the greeter, which is tracked separately in bug 834386.]

Sebastien Bacher (seb128) wrote :

the lightdm gtk greeter is centred, I guess your issue is with the unity-greeter, reassigning there

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Adam Niedling (krychek) wrote :

There is a bug in the release notes:

https://wiki.ubuntu.com/OneiricOcelot/ReleaseNotes
"For languages that are read left to right (arabic, hebrew), there is some inconsistency in display between the login screen (lightDM) and the desktop environment (unity). (871764)"

Arabic and Hebrew are read right to left.

David Planella (dpm) on 2011-10-19
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity-greeter (Ubuntu Oneiric):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
tags: added: rtl
hatul (amiadb) on 2011-10-30
tags: added: arabic hebrew i18n l10n persian
Robert Ancell (robert-ancell) wrote :

The greeter RTL feature is being tracked in bug 834386. Not sure if you want to close the unity greeter task on this one.

description: updated
Changed in unity-greeter (Ubuntu Precise):
status: Confirmed → Invalid
Changed in unity-greeter (Ubuntu Oneiric):
status: Confirmed → Invalid
description: updated
tags: added: rls-mgr-p-tracking
David Barth (dbarth) wrote :

Deferring to john to verify if supporting RTL in those elements would be consistent with other design requirements. For example, the intangibility of the position of the launcher, for support reasons.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu Precise):
status: Confirmed → Incomplete
Yaron (sh-yaron) wrote :

How can we assist promoting this bug?
Most Israeli users did not install Ubuntu 11.10 in Hebrew and this is a
great loss, we can't afford another version like that...

Uri Shabtay (uri.shabtay) wrote :

We sure can't - but see this bug Haggai reported a while back : https://bugs.launchpad.net/unity/+bug/654988

The bug has a fix released - but guess what - not quite yet. Due to the fact it needs to be thoroughly tested.. and i haven't received any response yet about the availability in the upcoming LTS..

I doubt we'll see this being fixed any time soon - but if it does, it will probably be a part of the customization options in Precise such as these: http://www.omgubuntu.co.uk/2012/01/unity-global-menu-to-become-optional/

and these (at 2.2 - Appearance Settings): https://docs.google.com/document/d/1ILTJDiDCd25Npt2AmgzF8aOnZZECxTfM0hvsbWT2BxA/edit?hl=en_GB

Shahar Or (mightyiam) wrote :

As a Hebrew user* here's my humble opinion: Qt and GTK have it right. The whole interface should be mirrored. That is the path that should be followed in Unity/2D and the greeter.

The fact that there is uncertainty is very bad. It is an indicator of the passivity of the RTL users - even the ones most involved!

Let me get this clear, please, for everyone who finds himself writing from the let side of the page to the right: We RTL users must have our translated interface mirrored. Otherwise it is strange, funny and hard to get the mind around.

Much work has been put into translating the Linux Desktop into RTL languages. Hebrew, Arabic and Persian together have one million and seventy two thousand translated strings according to Rosetta. Much of that by people subscribed to this bug.

The release of two versions of the most popular distro, with GUI bugs in RTL has been a huge damage to the image of the Linux Desktop and Free Software amongst those locales.

Let us not allow this to happen again. Either pull together the mirroring of the interface in the default shell or drop those locales back to the known good shells, please. <- (This line has the bottom line)

Thanks,
Shahar

Shahar Or (mightyiam) wrote :

*I'm a Hebrew user but I don't use Hebrew because I prefer English. So in the computer Hebrew is my second language :)

We'll gladly accept patches for RTL mapping of Unity in RTL languages.

Haggai Eran (haggai-eran) wrote :

I think the state of Unity and Unity-2d are quite different. Unity-2d is based on Qt, so they got very good RTL support from the toolkit. The Oneiric version already contained patches to mirror the desktop. There was some bug in Qt that caused it to crash in the RTL version (#836498), but a workaround was found.

The Unity desktop is based on Nux, which is a less mature toolkit, without such support. I've been trying to promote patches to Nux for some RTL support (lp:~haggai-eran/nux/rtl-logical-packing), but it takes a very long time. I also started working in the past on mirroring the Unity desktop, but I'd rather not work on it until the Nux patches are accepted (or until there is some other RTL support in it), since Unity is a moving target, and I rather not keep merging patches.

David Barth (dbarth) on 2012-02-17
Changed in unity:
importance: Undecided → Wishlist
milestone: none → backlog
Shahar Or (mightyiam) wrote :

Dear Haggai, thank you for the input and the work.

Dear Mark, thank you.

Dear David, can you tell me why this is Wishlist, please?

Unity 2D is, in my opinion, the preferred over Unity proper for RTL locales in precise. It is mirrored and it works nicely!

Here are a few RTL related bugs in Unity 2D:
https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bugs?field.tag=rtl

Thanks and blessings,
Shahar

Uri Shabtay (uri.shabtay) wrote :

Folks, thanks to Haggai's work there's something to look forward to RIGHT NOW - check Bug #654988 : https://bugs.launchpad.net/unity/+bug/654988 and behold - Unity-2d works flawlessly with RTL in 12.04, while as mentioned, Unity-3d needs work. see attachments below

hopefully the bloggers will apply the call for help and get this thing rolling

cheers

Uri

Uri Shabtay (uri.shabtay) wrote :

Thanks again, Haggai

Yaron (sh-yaron) wrote :

I don't think it's critical but still worth mentioning, the arrow near the
category title is pointing the wrong direction, I hope we will get to that
also pretty soon ☺

Kind regards,
Yaron Shahrabani.

tags: added: rls-p-tracking
Tim Penhey (thumper) wrote :

I think with a little focus, this would be something achievable with unity itself. What I feel that we are missing are issues around which bits are mirrored right to left, and which bits aren't. For example the underlying structure of the dash needs to be mirrored, but the text has to be written "post-mirror".

Haggai Eran (haggai-eran) wrote :

@Tim, Its true that the solution isn't a literal mirror image of a left-to-right desktop. Right-to-left text shouldn't be mirrored in the literal sense. However, we do need to mirror its alignment, i.e: right-aligned instead of left-aligned.
The character ordering itself is of course from right to left, but that is already supported by Unity and Nux through their use of pango.

tags: removed: rls-p-tracking
Shahar Or (mightyiam) wrote :
Shahar Or (mightyiam) wrote :
Shahar Or (mightyiam) wrote :
Shahar Or (mightyiam) wrote :
David Barth (dbarth) on 2012-04-06
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Eslam Mostafa (cseslam) wrote :

LIgthDM loginbox appears on the left side, not the right side.

i am using gnome classic right this moment, my nusername and settings menu appear on the right of indicators, but my username should be on the very left of the screen, then app indicators.

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers