most genres do nothing

Reported by Curtis Hovey on 2011-09-15
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Music Lens
Medium
Alex Launi
Unity
Low
Unassigned
unity-lens-music (Ubuntu)
Medium
Alex Launi
Precise
Low
Unassigned

Bug Description

Test case:
1. Open the dash
2. Switch to the music lens
3. Click on different genres on the filter
   -> See them triaged

===

I apparently have 4 of the 18 listed genres. Why show genres that yield zero results? Banshee shows my more than 20 genres.

Alex Launi (alexlauni) wrote :

There is a mapping that needs expanded to go from the list of genre's provided by design, and what's in the collection. A better approach to genres needs designed but this is what we have for now

Changed in unity-lens-music (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Alex Launi (alexlauni)
tags: added: bitesize
Alex Launi (alexlauni) on 2011-09-21
Changed in unity-lens-music:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Alex Launi (alexlauni)
Alex Launi (alexlauni) on 2011-09-27
Changed in unity-lens-music:
milestone: none → 0.2.6
Alex Launi (alexlauni) on 2011-09-28
Changed in unity-lens-music:
milestone: 0.2.6 → none
Alex Launi (alexlauni) on 2011-09-28
Changed in unity-lens-music:
milestone: none → 0.3.0
Alex Launi (alexlauni) on 2011-09-28
Changed in unity-lens-music:
status: Triaged → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Triaged
Changed in unity-lens-music:
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Triaged
Alex Launi (alexlauni) on 2011-10-03
Changed in unity-lens-music:
status: Triaged → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity-lens-music:
status: Confirmed → Triaged
Mark Tully (markjtully) wrote :

The genre mapping appears to be as follows at the moment:

blues --> blues
classic --> classic, classical
country --> country
disco --> disco
funk --> funk
rock --> rock, heavy, hard
metal --> metal, heavy
hip hop --> hip-hop
house --> house, chillout, minimal, hard, electronic
new wave --> new-wave
r-and-b --> r-and-b
punk --> punk, punk rock, hardcore, heavy
jazz --> jazz
pop --> pop
reggae --> reggae
soul --> soul, gospel
techno --> techno, minimal, trance, chillout, electronic, electronica
other --> other, african, alternative, ambient, asian, brazilian

Having glanced through my own music collection, I have the following genres present which aren't represented: Folk, Traditional, Dance, World, Ambient, Oldies, Heavy Metal, Christmas, Latin, Celtic, Soundtrack, R&B, Rap, Rap & Hip Hop, Rock and Roll, Opera
There are bound to be others (all the many, many varieties of metal, for example) that I'm missing. Many of these fit fairly nicely with the existing genre filters, so the mapping could be easily extended to add more genres in without having to add any more filter options to the lens. The genre mapping is defined in http://bazaar.launchpad.net/~unity-team/unity-lens-music/trunk/view/head:/src/genre.vala

Changed in unity-lens-music:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: none → 5.12.0
Changed in unity-2d:
status: Triaged → Invalid
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-music:
status: Fix Committed → Fix Released

Hello Curtis, or anyone else affected,

Accepted unity-lens-music into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-lens-music (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Curtis Hovey (sinzui) wrote :

unity-lens-music-5.12.0-0ubuntu1 does not fix this issue.

Most the the listed genre show nothing: blues, country, disco, funk, hip-hop, metal, r&b, soul. Other appears to match: Alternative, World, and Ambient music...three very different genera that I would not ever mix in a playlist. I do not see the general that Banshee (or rhythmbox) shows me: Ambient, Alternative, Indie, Britpop, World

I cannot use the music lens because it is not possible to select a category of music that is in my collection. Other people who my try the lens might believe I have no music, or conclude that I myself must be categorised as "other" because the my music is uncategorisable.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 5.12.0-0ubuntu1

---------------
unity-lens-music (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Music Lens doesn't work for albums in Precise with Rhythmbox
      (LP: #970509)
    - most genres do nothing (LP: #851424)
    - Missing album art (LP: #976067)
  * debian/control:
    - add a build-dep on libtdb-dev
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 11:33:01 +0200

Changed in unity-lens-music (Ubuntu):
status: Triaged → Fix Released
Changed in unity-lens-music (Ubuntu Precise):
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) wrote :

I disagree that this is fixed, as I wrote in comment #4. I do not see ANY change between 5.10.0-0ubuntu1 and 5.12.0-0ubuntu1. maybe you added some extra mappings of genres. if you did, those genres are not in rhythmbox or banshee.

"""
Most the the listed genre show nothing: blues, country, disco, funk, hip-hop, metal, r&b, soul. Other appears to match: Alternative, World, and Ambient music...three very different genera that I would not ever mix in a playlist. I do not see the general that Banshee (or rhythmbox) shows me: Ambient, Alternative, Indie, Britpop, World

I cannot use the music lens because it is not possible to select a category of music that is in my collection. Other people who my try the lens might believe I have no music, or conclude that I myself must be categorised as "other" because the my music is uncategorisable.
"""

The filters are broken by design. Half the filters match nothing...they should not be active. I should not be permitted to filter to a zero result. The filters could use the genres known to rhythmbox and banshee to inform the user about what is in the collection and encourage the user to filter the results.

Changed in unity-lens-music:
status: Fix Released → Triaged
Changed in unity-lens-music (Ubuntu):
status: Fix Released → Triaged
Changed in unity-lens-music (Ubuntu Precise):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

@Curtis: could you give details on a buggy case? The lens has 18 genre buttons on my precise install, which ones are you missing or consider as being wrong?

Changed in unity-lens-music (Ubuntu Precise):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Changed in unity-lens-music (Ubuntu):
status: Triaged → Incomplete
Changed in unity-lens-music (Ubuntu Precise):
status: Triaged → Incomplete
Changed in unity-lens-music:
status: Triaged → Incomplete
Curtis Hovey (sinzui) wrote :

@Sebastian: I have 18 buttons as well, but those buttons do not reflect the contents of my collection, so most buttons do nothing:

* I do not have music that that is blues, country, disco, funk, hip-hop, metal, r&b, and soul.
   * The lens should not list these genres because they lead to zero-results.
   * Or the lens should not allow me to use filters that create zero-results
      * This probably means the UI has to clear show which filters are disabled

I have Alternative, Adult Alternative, Indie, Goth, Darkwave, DreamPop, BritPop Genres that may appear when I choose the Other genre.

The lens does not have a mapping for the World genre, so I cannot find my Irish and Bulgarian recordings

I expect the filters to list only the genres (and decades) that are in my music collection. I have only two genres from 1 decade, then there should be two genre buttons and 1 decade button.

Sebastien Bacher (seb128) wrote :

so you would like the ui to dynamically change and relayout according to the content of your music collection? that would require design input but it doesn't seem a good solution, interface that keep changing are harder to use since you have to relearn where to click every time

Curtis Hovey (sinzui) wrote :

I agree that a changing interface is hard to learn. How often do we look at other people's collection thought the lens? The only UI I need to learn is my own lens. On import, I would be impressed that the lens knows about my collection and assume everything works. Instead I saw half of the UI not right, so I had to ponder if my collection was wrong, or learn if the generic genres search a store -- total failure. If I saw all my genres in my collection, then saw someone else's collection, I would assume those are the genres the user has. Instead I see a set of genres that I might have learned do not map to the collection, they cannot be trusted, so I do not know which genres I can select to find music.

The problem with the current interface is that it fails more than 50% of the time for any time I use it -- it is still broken by design.
* The current design assumes there are a common set of genres in every users collection.
  * I assert every user will have genres or decades that do nothing.
* The current design assumes developers can maintain a mapping of sub-genres
  * I do not see the genres I have listed in the source code,
     but allmusic.com and wikipedia knows about my genras them,
  * The U1 music store genres are not listed in the lens genres;
    the Canonical lens dos not support the Canonical store!
  * Do I need to file a bug and harass a developer to add it?
  * Can the genres and mappings be translated?
  * Do mappings work in other cultures? are J-Pop and K-Pop always Pop?

The central issue here is that this is a filter operation over data that I know. The music lens is repeating the mistake of early desktop search apps. It wants to find everything and has present to assume the user is searching. Desktop data is not search. The user knows something exists and the UI should return the minimal set that matches the user's memory.

Sebastien Bacher (seb128) wrote :

requesting ayata-design inpu on the issue, that will need design work

you have some good points, some small comments:
- you seem to assume an user collection is a fixed set, it's not, most users buy music and copy things around, the genre and decade represented in their collection change
- categorisation helps, even if it's not a perfect match of how you would sort your music, go on amazon or any website selling music, they will have section for different genres
- empty categories (or decades) should be listed, the same way your email client doesn't stop listing your inbox when it's empty, or that menu prefer to make items unactive rather than hide them, bookmarks in nautilus don't go away when the directory they point to is empty, etc ... the reason i.e menu items are not hidden is because it would make the interface harder to learn and use, hidding a decade on the timescale would also be weird

Omer Akram (om26er) on 2012-05-28
no longer affects: unity-2d
Maxim Kuznetsov (mackuzzz) wrote :

Why can't Music lens show only that genres that I am using in my files, already indexed by Rhythmbox?
And periods may differ for users, so some user needs 1400-s but other don't have any song from 1950-s.

tags: added: needs-design
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers