Hitting Alt-Tab does not display Libre Office in list of switchable open applications

Reported by Sean Sosik-Hamor on 2011-09-07
288
This bug affects 90 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
BAMF
High
Marco Trevisan (Treviño)
Unity
High
Marco Trevisan (Treviño)
Unity Foundations
Undecided
Unassigned
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
libreoffice (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Hitting Alt-Tab to bring up a list of switchable open applications does not display the running Libre Office instance. In order to switch to Libre Office and bring it to the foreground I must move other windows around with the mouse and click the Libre Office window.

To reproduce:
 * Open Libre Office Writer
 * Open a few other applications such a Firefox and Thunderbird
 * Hit Alt-Tab and switch to Firefox
 * Hit Alt-Tab again while keeping Alt depressed

Expected behavior:
 * Libre Office should be in the list of available switchable applications

Actual behavior:
 * Libre Office is not in the list of available switchable applications when hitting Alt-Tab and keeping Alt depressed
 * Libre Office is not switched back to when tapping Alt-Tab quickly (the last-used application before Libre Office is jumped to)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice-common 1:3.4.2-2ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Wed Sep 7 13:47:30 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/libreoffice
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
InterpreterPath: /bin/dash
PackageArchitecture: all
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Sean Sosik-Hamor (sciri) wrote :
Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid

adding bamf, marking invalid in Libreoffice for now.
Simplest scenario to reproduce:libreoffice
1) type 'libreoffice' in starter (not the startcenter, not writer or one of the apps) and start it
2) start nautilus

expected behavior:
 - icon for the start center
 - alt-tabbable
actual behaviou:
 - no icon for the start center
 - not alt-tabbable

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity:
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → Invalid
Takashi Oshie (oshie) on 2011-10-15
description: updated
Changed in unity (Ubuntu):
status: New → Confirmed
Krzysztof Nowak (novacellus) wrote :

As for now installing 'lo-menubar' package (sudo apt-get install lo-menubar) did the trick for me.

thomas (thomas-heuer) on 2011-10-20
tags: removed: amd64
Oskar Rittsél (mail-rittsel) wrote :

tags: removed: amd64

This is affecting me as well Ubuntu 11.10 64bit

infernet (guattari) wrote :

This bug is still present in 12.04 LTS (32 and 64 bit).

Marco Penno (marcosbiro) wrote :

On 12.04 LTS (64 bit) I installed 'lo-menubar' package, as Krzysztof Nowak (novacellus) suggested, and it solved now.

oknieps (ubuntu-knieps) wrote :

This bug is still present in 12.04 LTS (64 bit).
I UNinstalled 'lo-menubar' package, and it solved now :-) Thank You marcosbiro

Matthias Niess (mniess) wrote :

I confirm this is still present in Ubuntu 12.04. It happens to me no matter if I have lo-menubar installed or not. I can't alt-tab to libreoffice documents. This happens on all my installations of Ubuntu. The Icon correctly shows up in the launcher and in the ALT TAB view. The application just won't focus.

As far as I can see this only happens when LO is opened by double-clicking a file (which is probably the way people usually open it). I also don't have the default shortcuts so LO in the launcher.

John Lea (johnlea) on 2012-10-15
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in bamf:
status: Confirmed → Triaged
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Changed in libreoffice (Ubuntu):
status: Invalid → Triaged
Changed in unity-foundations:
status: New → Confirmed
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in bamf:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
no longer affects: unity-2d
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in libreoffice (Ubuntu):
importance: Undecided → High
tags: added: udp
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in libreoffice (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in bamf (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in libreoffice (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Andrew Walker (syneil86) wrote :

Small note: a better way of switching to your libreoffice windows until this is fixed is not to move windows around but use SUPER+W to display all open windows and select.

Is this fixed by bug #1026426 for you?
If you're using 12.04, there's a link to a ppa which contains a fixed bamf version.

RomanIvanov (ivanov-jr) wrote :

2 Matthias Niess (mniess):
Thanks for workaround, switching works fine if open SpreadSheet from Dash and then open files from Cntl+O.
but do not work if open file by double click as all users do.

rg (rob-themayfire) wrote :

Bug still present (maybe even worse?) with Ubuntu 12.10 and LibreOffice 1:3.6.2.

If I open LibreOffice Calc from dashboard, I get no icon in the launcher, no icon in the alt-tab switcher.

If I open a Calc doc from nautilus, email, etc. I get a grey question-mark icon in the launcher, no icon in the alt-tab switcher. Clicking the question-mark icon has NO effect.

So either way, after switching to another app I'm unable to switch back to Calc.

John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers