UIFe: Dash - Shape and positioning of most of the elements in the Dash need adjustment

Reported by John Lea on 2011-09-05
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Medium
Mirco Müller
unity (Ubuntu)
Medium
Mirco Müller

Bug Description

The shape and positioning of most of the elements in the Dash need adjustment. There are many many of these small issues, so rather then open 25+ separate bugs I will list them as bullet points.

Before reading the list, open the following image: https://chinstrap.canonical.com/~johnlea/11_10/Dash_layout.png

In this image the current implementation is laid on top of the signed off design with 80% opacity. Look at where elements are placed relative to where they should be placed according to the design, and also look at the different shape of elements compared to the design.

When fixing these issues, keep taking screenshots of the implementation and matching them up to the design (as done with the Dash_layout.png) to check how the layout is progressing. When this process stops showing variations this bug is resolved ;-)

----------------------------------

List of positioning issues:
- The Category Headers are positioned wrong (too far left, too low)
- The search box is positioned wrong (centre should align with the center of the BFB, should start a few px to the left)
- The magnifying glass inside the search box is positioned wrong (should be further to the left)
- There is too much space between the individual icons in the search result
- There is too much space below each category header
- The desktop dash box is much too large (both height and width)
- "Filter results" header is positioned wrong (should be right and slightly up)
- The "All" button is aligned incorrectly relative to the other filter buttons (right sides should fall on the same vertical axis)

----------------------------------

List of shape issues:
- Category header icons are too large
- The font size of category header titles is too large
- The search result icons are too small
- "Filter results" is the wrong font size and weight
- The search filter toggle boxes are too high
- The search filter toggle boxes are too narrow
- The corner radius of the search filter toggle boxes is wrong
- The 'rating' stars are the wrong size
- the un-selected 'rating' star has the wrong border
- the search box is too short
- the 1px dividers in-between the categories should be narrower with 15px margin on each side
- the dividers in between the filter results categories are missing
- the 'All' button's shape is very wrong
- the filter results category headers are with wrong font size and weight
- the expand/collapse triangle is the wrong shape and size
- the expand/collapse triangle is missing from the filter results category headers
- The the font size of the text underneath each icon in the search results is too large
- The size and shape of the arrow that points to the currently selected Dash Lens is incorrect

John Lea (johnlea) on 2011-09-05
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
Mirco Müller (macslow) wrote :

Exact spacing and sizing specs (instead of just a mockup-screenshot) would be the right way to see this fixed in a timely fashion. If I keep measureing Design-mockups and compare them with screenshots of the implemenation, I'll be busy for weeks.

Rosie tried to export the grids from Illustrator but this didn't work out, so all we could do is best guessing for the moment.

I don't see this as "fix committed" from the Design-team.

David Barth (dbarth) on 2011-09-05
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
status: New → Triaged
milestone: none → 4.14.0
John Lea (johnlea) wrote :

@macslow

I thought a exact spacing and sizing spec had been provided at the Dublin sprint, my apologies, I'll make sure this is our no. 1 priority to get done and sent over tomorrow. If you are every waiting on anything design related please escalate to me promptly so I can make sure it is sorted out.

Re. comparing the implementation to the final design, it is good practice to do this frequently as implementation progresses, but this is in addition to, and not replacing, the sizing and spacing spec.

thx!

John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :

@macslow

I just checked with Rosie and she showed me the size and positioning specs for the desktop dash that were handed over in Dublin. They look good to me, I have attached them to this bug. Could you double check these specs and let me know what are the issues with these specs as they stand, so we can fill in the gaps asap.

thanks,
John

Mirco Müller (macslow) wrote :

I've emailed Rosie already, that the part of the filter-page is missing from the now provided files. Again what was provided in Dublin were .ai files and exported .svg files, which did not keep any of the grid information intact when trying to open them with inkscape.

Changed in unity:
status: Triaged → In Progress
Neil J. Patel (njpatel) on 2011-09-06
Changed in unity:
importance: High → Low
importance: Low → Medium
Changed in unity (Ubuntu):
status: New → Confirmed
Mirco Müller (macslow) wrote :

Added downstream bug to comply with the UIF-exception guidelines. Rationale for the UIFe is stated in the bug-description.

affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
status: New → In Progress
milestone: none → ubuntu-11.10-beta-2
Mirco Müller (macslow) wrote :

There are no string changes for this UIFe bug, so no work needs to be done by the translators of the ubuntu-doc-team here.

Mirco Müller (macslow) on 2011-09-07
summary: - Dash - Shape and positioning of most of the elements in the Dash need
- adjustment
+ UIFe: Dash - Shape and positioning of most of the elements in the Dash
+ need adjustment
Martin Pitt (pitti) wrote :

Approved. This is actually half a bug fix, as the current dash is too wide for netbook screens, so removing all the excess space is highly appreciated.

On 7 September 2011 09:30, Mirco Müller <email address hidden> wrote:
> There are no string changes for this UIFe bug, so no work needs to be
> done by the translators of the ubuntu-doc-team here.

This probably does affect the ubuntu-doc team, this sounds like it
will affect screenshots, which also need to be finalised prior to the
documentation string freeze. Please make any final changes asap!

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Mirco Müller (macslow) wrote :

Because fixing all this is so much effort only 50% of the stated issues were merged with unity trunk today. Because such mega/meta-bugs are not very convinient to track, I'll close this one as "Fix Committed" and open a new one with the remaining issues stated... as my work on thoese continues.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

@macslow; What is the bug number of the new bug? Could I suggest opening a new bug that contains the fixed issues, and then marking the new bug as fix released (while leaving this bug as 'in progress' until it is completely closed). This is because there is a lot of information attached to this bug, and this will be easier that moving all the attachments and comments over to the new bug description each time. I'll update the bug description for this bug after reviewing the fixes that have landed.

Dmitry Shachnev (mitya57) wrote :

@John: new bug is bug #844889.

Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Still many outstanding issues, but bug signed off because these issues are tracked in new bugs

tags: added: reviewedbydesigno
removed: onew udo
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers