Dash - unable to select multiple search filters within the same filter category simultaneously

Bug #841847 reported by John Lea on 2011-09-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
unity-lens-applications
High
Michal Hruby
unity-lens-files
High
Michal Hruby
unity-lens-applications (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned

Bug Description

Unable to select multiple search filters within the same Dash filter category simultaneously.

Desired resolution:
- It should be possible to select multiple filter options within the same filter category simultaneously.
- For example, in the file lens it should be possible to select all files that are either "Images" or "Videos" at the same time by selecting both the "Videos" and "Images" options.
- Think of the filter categories as containing checkboxes, not radio buttons.

Related branches

John Lea (johnlea) on 2011-09-05
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
importance: High → Medium
tags: added: onew udo
Omer Akram (om26er) on 2011-09-21
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released

This is a bug in the files and apps lenses. They use a RadioOptionFilter, that doesn't allow for multiple selections. This behavior was carried over from Natty, and punted from Oneiric because we were busy revamping the lenses infrastructure.

This bug should be targeted at the early parts of the P cycle.

Changed in unity:
assignee: Gord Allott (gordallott) → nobody
Changed in unity (Ubuntu):
assignee: Gord Allott (gordallott) → nobody
Changed in unity-lens-applications:
importance: Undecided → High
status: New → Confirmed
Changed in unity-lens-files:
importance: Undecided → High
status: New → Confirmed
Changed in unity:
importance: Medium → High
status: Triaged → Confirmed
Changed in unity (Ubuntu):
importance: Medium → High
status: Triaged → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Michal Hruby (mhr3) on 2012-01-25
Changed in unity-lens-applications:
status: Confirmed → In Progress
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.2
Michal Hruby (mhr3) on 2012-01-27
Changed in unity-lens-files:
status: Confirmed → In Progress
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.0.2
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-02-13
no longer affects: unity
no longer affects: unity-2d
no longer affects: unity-2d (Ubuntu)
no longer affects: unity (Ubuntu)
Jeremie Tamburini (jeremie2) wrote :

I have noticed this new behaviour and I was wondering whether this could be a bug or a new feature. Finally I found this page.

I think this setup might be useful to search files, but it tends to be annoying with the Application lens. For instance if I'm watching the "System" category, then selecting the "Games" category all the softwares will be mixed together.
This means every time you select a filter item you have to deselect the previous category. The app lens already requires many clicks (to open the category filter, to show all the results...) before "reaching" all the installed softwares in a category. This beaviour add a another step.

I mean, a setup which result proper for one lens, might not be the best for another lens.
Anyway... I presume I can't ask you to reintroduce this bug ;D

Cheers!

I think all filters in all lenses should be multi-selectable. But it should be made consistent with all IconView-ish widgets in browse mode. That is, only select one icon at a time when left-clicking, but enable the user to select more by pressing ctrl or shift.

In this case, since there's no actions to perform, I think left clicking should select only one, but middle-clicking should add to the selection, and right-clicking should remove form it. That should make the GUI both more consistent with other software, and more comfortable when using a mouse.

manny (estelar57) wrote :

agree with #3

Also, another issue with multi-select is that everything gets mixed up , so you can't easily distinguish which individual category or selected filter an app belongs to.

submitted a bug:
https://bugs.launchpad.net/unity-lens-applications/+bug/941550

Jeremie Tamburini (jeremie2) wrote :

I agree with #3 too.

That could be the best solution.

Michal Hruby (mhr3) on 2012-03-07
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Changed in unity-lens-files (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-03-12
tags: added: furtherdesignreviewrequiredp
Nick Tait (jnick-tait) on 2012-04-20
tags: added: reviewedbydesignp
removed: furtherdesignreviewrequiredp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-20
tags: removed: udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints