Workspaces, Launcher - The workspace Launcher icon should change depending on which workspace is currently being utilised

Reported by John Lea on 2011-09-01
164
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

The workspace Launcher icon should change depending on which workspace is currently being utilised.

The four different icons that represent the four different workspaces are attached to this bug, see file "workspace-switcher-icons.zip"

If the user is using any workspace configuration other than a 2x2 square, the workspace Launcher icon should not change, it should always use the icon that indicates that the currently selected workspace is the top left.

------------------------------------

This change is part of a larger set of Launcher icon changes, see attached image "preview-new-launcher-icons.png" for how the launcher will appear when the full set of changes are made.

The other bugs that are part of this same change request are:

bug #1081704 (Dash - update the 'App Lens' icon asset in the Dash bottom lens nav bar)
bug #1081702 (Update the default wallpaper in 13.04)
bug #838854 (Workspaces, Launcher - The workspace Launcher icon should change depending on which workspace is currently being utilised)
bug #1081697 (Launcher - Update BFB icon to use a new special asset)
bug #1081687 (Launcher - Update Launcher tile assets)
bug #1081691 (Launcher - Update the icons used for the Software Centre, Nautilus, and Software Updater)

Related branches

lp:~andyrock/unity/fix-838854
Merged into lp:unity at revision 2952
Marco Trevisan (Treviño): Approve on 2012-12-03
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-04
lp:~andyrock/unity-asset-pool/ws-icons
Merged into lp:unity-asset-pool at revision 64
Marco Trevisan (Treviño): Approve on 2012-12-03
PS Jenkins bot: Pending (continuous-integration) requested 2012-12-04
John Lea (johnlea) on 2011-09-01
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Omer Akram (om26er) on 2011-09-21
Changed in unity:
importance: Undecided → Low
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed

This bug is a duplicate of bugs 716825 and 754713. This one seems to have received the most developer attention and progress, though.

Omer Akram (om26er) wrote :

Thanks Chris :-)

John Lea (johnlea) on 2012-10-15
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
assignee: Jason Smith (jassmith) → nobody
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) wrote :
description: updated
John Lea (johnlea) wrote :
description: updated
tags: added: launcherassets
John Lea (johnlea) on 2012-11-21
description: updated
MC Return (mc-return) wrote :

We have to think about a new problem now:

* How should the workspace switcher icon behave if someone uses more than 4 workspaces/viewports ?

I would say, let's cycle them then: workspace 5 == icon 1, workspace 6 == icon 2 and so on...

MC Return (mc-return) wrote :

@johnlea:

Ups, just re-read the description, where you already anticipated the non-default configuration problem... ;)

I would nevertheless suggest to still switch the icon, no matter if the configuration is non-2x2. I use 4x1 for example and I still want the icon to change accordingly, although my config is a non-2x2 one.
What do you think about a solution that links workspace 1 with the topleft-icon, workspace 2 with the topright-icon, workspace 3 with the bottomleft-icon and workspace 4 with the bottomright-icon, no matter if the configuration is 2x2, 1x4 or 4x1 ?

For more workspaces than 4 the cycling I suggested in comment #9 above would also work...
Using less workspaces than 4 (like 2 or 3) should also change the icon accordingly, no ?

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: backlog → 7.0.0
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

Andrea you didn't link any branch to it? If you didn't mention even the bug # from the commit message, can you please add it manually to debian/changelog?

Stephen M. Webb (bregma) on 2013-01-28
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints