Update 'user-desktop.svg' with new version for Alt-Tab Show Desktop switcher

Reported by Paul Sladen on 2011-08-31
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Xi Zhu
humanity-icon-theme (Ubuntu)
Undecided
Unassigned
ubuntu-mono (Ubuntu)
Undecided
Unassigned

Bug Description

Note: /a/ replacement was uploaded in 'ubuntu-mono=0.0.33'. This has generated two new bug reports so far, plus discussion below about alternative designs:

  bug #841885 (Too small, because of border left for glow/blur)
  bug #842578 ("Show Desktop" icon shows a background picture I'm not using) - mpt

=================================
The Alt-tab switcher does not currently match the rest of the desktop and needs updating to be more closer to the design of the current design; the current icon is:

  /usr/share/icons/Humanity/places/128/user-desktop.svg

And this should be fixed/redrawn. This the icon is currently provided in seven individual sizes:

  16, 22, 24, 32, 48, 64, 128

  /usr/share/icons/Humanity/places/16/user-desktop.svg
  /usr/share/icons/Humanity/places/22/user-desktop.svg
  /usr/share/icons/Humanity/places/24/user-desktop.svg
  /usr/share/icons/Humanity/places/32/user-desktop.svg
  /usr/share/icons/Humanity/places/48/user-desktop.svg
  /usr/share/icons/Humanity/places/64/user-desktop.svg
  /usr/share/icons/Humanity/places/128/user-desktop.svg

Primary focus is probably 128x128-pixels.

To save space and updating hassle is should be possible link (rather than embed) directly to the background image, location which is:

  /usr/share/backgrounds/warty-final-ubuntu.png

This can be done in Inkscape, using:

  File->Import… and selecting "Link"

Paul Sladen (sladen) on 2011-08-31
Changed in ayatana-design:
assignee: nobody → Xi Zhu (xi.zhu)
status: New → In Progress
Changed in humanity-icon-theme (Ubuntu):
status: New → Confirmed
assignee: nobody → Paul Sladen (sladen)
milestone: none → ubuntu-11.10
Changed in ayatana-design:
milestone: none → release
description: updated

I think this bug is duplicate as : https://bugs.launchpad.net/humanity/+bug/840477

and I made some proposals to fix these. ( hope you like )

Paul Sladen (sladen) wrote :

These are the 'user-desktop.svg' icons sent over by Rosie last week. These are the ones that were specified in the Unity Alt-tab designs and previously mocked up (in raster form): Rosie's raw SVG files finished with:

  1. blur added (at 50% to get closer match to 20% specified)
  2. background component added (xlink:href="file:///usr/share/backgrounds/warty-final-ubuntu.png")
  3. cut up and saved

(Note that these were already queued for upload). Somebody with a good visual overview of the default interface (eg. probably Otto Greenslade) needs to review Rosie's designs here against the ones that Daniel (Planas Armangue)'s has just done for 'user-desktop' and make a decision about which one(s) to go with if it needs changing.

Daniel Fore (danrabbit) wrote :

I would strongly advise against using actual blur in the icon. It usually doesn't have good results rendering real-world. In-fact, I've noticed there's a tendency in GNOME to just not render any object that is using any significant amount of blur.

Paul Sladen (sladen) on 2011-09-05
Changed in ubuntu-mono (Ubuntu):
status: New → Fix Committed
Changed in humanity-icon-theme (Ubuntu):
status: Confirmed → Won't Fix
Sérgio Faria (sergio91pt) wrote :

Should bug 841885, 'New desktop icon looks too small', be marked as a duplicate of this one?

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Anders Feder (afeder) wrote :

/usr/share/backgrounds/warty-final-ubuntu.png is the default wallpaper. Is it possible to link to the current one instead?

I made a new proposal becose i don't like actuals
hope you like

icons in all sizes, I add new background

Changed in humanity-icon-theme (Ubuntu):
assignee: Paul Sladen (sladen) → Daniel Planas Armangue (daniplanas.a)
Eylem (eylemkoca) wrote :

I love the icons Daniel, I hope they're going to be default.

Paul Sladen (sladen) wrote :

Anders: Yes, 'warty-final-ubuntu.png' is the default rather than the current (user configured) wallpaper. I believe that the intent is that the desktop looks predictable‒I can ask Rosie/Otto to comment here if that's helpful? In an extreme case, a configured background, with a screenshot that looks like another application) might not serve its function as well.

Daneil (Planas Armangue): Good icons: I particularly like the idea of testing them against the noisy background in the preview. I'm not an icon designer, but I wonder if the design perhaps over-emphasises the weight of the Launcher (I normal running with maximised windows and so never see the Launcher—except when trying to hit the back-button in Firefox). With "Show Desktop" I'd think I'd tend to associate that with just being able to see the Top Bar and the Wallpaper.

Anders Feder (afeder) wrote :

Predictable is good, but for someone who has never seen that background (say, using someone else's Ubuntu laptop, with a non-default wallpaper), that image is going to signify absolutely nothing.

Yes Anders, but I think we can not predict all the changes that users will do, so we have to focus on providing a good experience by default, so the icon should represent the default background with default unity configuration (top panel and launcher ).

Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Daniel Planas Armangue (daniplanas.a)
Changed in ayatana-design:
status: In Progress → Confirmed

I attach some screenshots with test my last propsals. If anybody can send my the wallpaper on vectorial format, I change the actuals in the icons, becose now they are png's optimized by gimp.

Paul Sladen (sladen) wrote :

Anders: If a user has never seen the bare post-login default desktop, we're going to be stuck with whatever icon :-) The use-case is so slight that it's probably best not to focus on it.

Daniel (Planas Armangue): An icon that presumes a left-hand Launcher is going to be less meaningful in Right-to-Left environments. Admittedly that's not entirely working in Unity at the moment, but it's more of a focus emphasis the consistent parts /of the default experience/ (background and top bar). This is where I think it's worth spending time focusing. It's more about giving a recognisable impression, than an exact match.

Daniel (Foré): I'm inclined to agree about avoiding pre-generated blur—I'd certainly personally prefer to see it being done at the point of render in cases where it is needed. (Far easy to add something back in, than try to remove it in the first place).

Sérgio: No, bug #841885 is not a dup. It's a result of this upload. Being too small is an issue everyone and current new icons do look lost within their cell at the smaller sizes.

Paul Sladen (sladen) on 2011-09-06
description: updated
Happy R (razz-dulce) wrote :

It is , from my point-of-view, a "must" to express the desktop icon with a semi-maximised dash "on top" of the default wallpaper (in your case, just add a Dash to that already presented icon), that would make the icon easy to be perceived but all users (specially the new ones)

Changed in humanity-icon-theme (Ubuntu):
assignee: Daniel Planas Armangue (daniplanas.a) → nobody
Changed in ubuntu-mono (Ubuntu):
assignee: Daniel Planas Armangue (daniplanas.a) → nobody

I made 0.3 version without launcher, ( Paul Sladen suggestion )
hope you like

Icons 0.3 .tar

Dmitry Shachnev (mitya57) wrote :

After today's ubuntu-mono update, show-desktop icon is just a white recktangle, see the screenshot.

Paul Sladen (sladen) wrote :

dmitry: thank you. Please could you file it as a new bug [covering the regression], and linking back to, and from this bug report.

Adolfo Jayme (fitoschido) wrote :

dmitry, sladen: bug 862040 filed.

Yann Dìnendal (yannbreliere) wrote :

I think the icon should be updated with the default 12.04 wallpaper (from Bug 968399).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers