Alt-tab - Reduce the spread delay for all items other than the initial item the select lands on after alt-tab opens

Reported by John Lea on 2011-08-31
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

Reduce the spread delay for all items other than the initial item the select lands on after alt-tab opens. After the user moves the select off it's opening position, spread delay should be shortened. This change is because a longer spread delay is only required for the initial item to allow the user time to scan the items in alt-tab without being disrupted. The spread delay on all other item can be shorter, which should give a more responsive feel.

----------------------------------
Note from User Testing:

In user testing, participants did not find the spread because they moved between applications too quickly. When I pointed out the spread to them, they commented that the delay was too long. Power users said that it would be faster for them to find what they were looking for without the spread.

-------

Note: Re-opening bug because user testing has shown us that the spread delay needs to be shortened even further.

Related branches

lp:~andyrock/unity/fix-838232-2.0
Merged into lp:unity at revision 2558
John Lea: Approve on 2012-08-08
Tim Penhey (community): Approve on 2012-08-08
Francis Ginther: Abstain on 2012-08-01
jenkins (community): Approve (continuous-integration) on 2012-07-17
John Lea (johnlea) on 2011-08-31
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
tags: added: onew udo
description: updated
John Lea (johnlea) on 2011-09-20
summary: - Alt-tab - Increase the spread delay for *only* the initial item the
- select lands on after alt-tab opens
+ Alt-tab - Reduce the spread delay for all items other than the initial
+ item the select lands on after alt-tab opens
description: updated
Omer Akram (om26er) on 2011-09-21
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Omer Akram (om26er) on 2011-09-21
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
description: updated
tags: added: utest
John Lea (johnlea) on 2011-10-21
description: updated

Have you already tested the desired timeout?

Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Changed in unity:
milestone: backlog → none
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 5.10.0
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udo udp
John Lea (johnlea) wrote :

Re-opening bug because user testing has shown us that the spread delay needs to be shortened even further.

tags: added: udp
removed: reviewedbydesignp
Changed in ayatana-design:
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
milestone: 5.10.0 → backlog
description: updated
description: updated
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: backlog → 6.2
Tim Penhey (thumper) on 2012-08-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package unity - 6.4.0-0ubuntu1

---------------
unity (6.4.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Home lens: Applications show up in Music category (LP: #1040101)
    - WARN unity.hud.hud Hud.cpp:185 Attempted to close the hud connection
      without starting it (LP: #1039451)
    - Text field textures do not update when maximum width changes.
      (LP: #1037187)
    - An application is closed if manually removed from favorites on gsettings
      (LP: #1032157)
    - The switcher (Alt+Tab) is showing incorrect windows after using Deskop
      Wall (Ctrl+alt+<direction>) (LP: #1031959)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Screen flickers when changing launcher icon size. (LP: #1024113)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - [previews] Music album tracks do not have a scroll-bar when needed.
      (LP: #1039462)
    - [USE_MODERN_COMPIZ_GL] With unity scrollbar support enabled, hotplugging
      monitors doesn't work (LP: #1039410)
    - [previews] Track titles aren't escaped (LP: #1039020)
    - Launcher - Edge of tiles (with backlight disabled) is too opaque
      (LP: #1038138)
    - [USE_MODERN_COMPIZ_GL] Benchmark window appears behind the Unity shell
      now (LP: #1036609)
    - [GLES] [USE_MODERN_COMPIZ_GL] Unity shell (Launcher and Panel) are
      missing if framebuffer_object is disabled (LP: #1036569)
    - [USE_MODERN_COMPIZ_GL] Benchmark window is mostly invisible, shrunken
      and displaced (LP: #1036528)
    - Unity quicklist menu items leak memory (LP: #1036338)
    - Icon resized between 32 - 48 - 64 look jaggy (LP: #1036231)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - [regression] Selecting an item of the BFB quicklist when the dash is
      open, causes it to hide (LP: #1035641)
    - Launcher - Switch on "backlight toggles" mode by default (LP: #1033866)
    - Unity spends 15% of time in PlacesGroup::ComputeContentSize when opening
      dash (LP: #1033306)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Bottom - Up key navigation is broken in dash filterbar (LP: #1028810)
    - Launcher - SD card can not be ejected by drag-n-dropping to trash
      (LP: #960910)
    - Alt-tab - The app name in the integrated menu should not change during
      Alt-tab switching (LP: #950782)
    - Dash - If only one Category Header is displayed, it should be
      automatically expanded (LP: #950710)
    - Launcher - Unity mouse wheel scroll too small (LP: #906072)
    - boot moves desktop icons (LP: #886667)
    - Alt-tab - Reduce the spread delay for all items other than the initial
      item the select lands on after alt-tab opens (LP: #838232)
    - Launcher - Launcher should never autohide when the cursor is positioned
      over the Launcher (e.g. When ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Andrea Cimitan (cimi) on 2012-09-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Released → Fix Committed
Christian Giordano (nuthinking) wrote :

@andyrock, as discussed, this change created bigger issues. Please revert the delay value to what it was in Precise. Sorry for the hassle.

tags: added: reviewedbydesignq
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers