Alt-tab - In the window spread, the currently selected window should display a title bar

Reported by John Lea on 2011-08-31
82
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Related branches

lp:~3v1n0/unity/switcher-glowing-decorations
Merged into lp:unity at revision 2901
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-11-15
Andrea Azzarone: Approve on 2012-11-14
John Lea: Approve (design) on 2012-11-14
Thomi Richards: Pending requested 2012-11-14
John Lea (johnlea) on 2011-08-31
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: onew udo
Jason Smith (jassmith) wrote :

Short of major changes in the way libmetacity works this is not reasonably possible. Changes appear to be breaking with upstream GNOME Shell work so will likely require a fork of libmetacity to support.

Changed in unity:
status: New → Won't Fix
importance: Undecided → Low
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
status: Won't Fix → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp
Changed in ayatana-design:
importance: Low → Medium
Changed in unity:
importance: Low → Medium
Changed in ayatana-design:
status: Fix Committed → Triaged
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Omer Akram (om26er) on 2011-11-24
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
assignee: nobody → Jason Smith (jassmith)
Tim Penhey (thumper) on 2012-02-08
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
Henry Gomersall (hgomersall) wrote :

Can someone confirm this is fixed in Saucy (but not in Raring)?

Stephen M. Webb (bregma) wrote :

@hgomersall

This is definitely fixed in both Saucy and in Ubuntu 13.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints