RFC 3339 date format option in 'Time & Date Settings...'

Reported by James Haigh on 2011-08-27
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Indicator Date and Time
Wishlist
Unassigned

Bug Description

See http://tools.ietf.org/html/rfc3339 and:
date --rfc-3339=date

I always put dates in this format wherever possible:
2011-08-27

That's '%F' in strftime.

There should be an 'RFC 3339 date' option on the 'Clock' tab of 'Time & Date Settings...'.

Javier Jardón (jjardon) wrote :

Currently you can set this for the panel in dconf-editor if you want.

Changed in indicator-datetime:
status: New → Fix Released
James Haigh (james.r.haigh) wrote :

Javier, I am aware of dconf-editor, this is how I have currently formatted my date.

However, it's not a fix. dconf-editor is not bundled with Ubuntu and is generally for advanced users. There should be a more accessible option for this format which is widely and increasingly adopted on the Internet. It's advantageous because it is compact whilst still being unambiguous.

Changed in indicator-datetime:
status: Fix Released → Confirmed
Ted Gould (ted) on 2011-09-02
Changed in indicator-datetime:
importance: Undecided → Wishlist
Javier Jardón (jjardon) wrote :

Add ayatana design team to get feedback about this

Charles Kerr (charlesk) wrote :

Can't proceed without feedback from Design

Changed in indicator-datetime:
status: Confirmed → Incomplete
Paul Sladen (sladen) wrote :

James: are you able to suggest a mockup of how you think the setting might be presented in the Date & Time control panel? (Ideally a before and after screenshot/mockup). It is often easier for designers to comment on visual demonstrations, and then make any suggestions (such as repositioning or renaming of the setting).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers