Current timezone duplicates with saved locations

Reported by James Haigh on 2011-08-24
114
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Matthew Paul Thomas
Indicator Date and Time
Low
Charles Kerr
indicator-datetime (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

In the screenshot notice that London appears twice. The first is my current timezone and the rest are saved locations.

Subtask of bug #823181.

James Haigh (james.r.haigh) wrote :
James Haigh (james.r.haigh) wrote :

Screenshot of my saved locations.

tags: added: regression-release
Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
status: New → Confirmed
importance: Undecided → Low
Javier Jardón (jjardon) on 2011-10-05
Changed in indicator-datetime:
status: Confirmed → In Progress
Ted Gould (ted) on 2011-10-13
Changed in indicator-datetime:
status: In Progress → Fix Released
Changed in indicator-datetime (Ubuntu):
milestone: none → oneiric-updates
status: New → Confirmed
Javier Jardón (jjardon) wrote :

I think this is not completely fixed, see my comments in https://code.launchpad.net/~jjardon/indicator-datetime/fix-833337/+merge/79332

Hello James, or anyone else affected,

Accepted indicator-datetime into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-datetime (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Oneiric:
I have reproduced the problem with indicator-datetime 0.3.0-0ubuntu3 in oneiric and have verified that the version of indicator-datetime 0.3.1-0ubuntu1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.1-0ubuntu1

---------------
indicator-datetime (0.3.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    * Drop an unused icon (LP: #746176)
    * Fix showing a timezone that we're currently set to (LP: #833337)
    * Remove check for libunique as it's unused
  * debian/control: Drop libunique requirements, it was unused
 -- Ted Gould <email address hidden> Thu, 13 Oct 2011 13:40:21 -0500

Changed in indicator-datetime (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in indicator-datetime (Ubuntu Oneiric):
status: Fix Committed → Fix Released

I'm experiencing this with indicator-datetime-0.3.1-0ubuntu1, from oneric-proposed with the following specifics:
My current location is listed twice consecutively in the indicator menu;
My current location is not defined in the locations dialog;
Defining my current location in the locations dialog has no effect;
When setting another location as "home" in the indicator menu, the extraneous home-location disappears;
When selecting the original home location in the indicator menu, the extraneous home-location reappears;
Defining additional locations with the same timezone as my home location and switching to and from them produces inconsistent, confusing results;

Reinstalling indicator-datetime and restarting is has no effect;
Installing all pending upgrades and rebooting did not help;
Running dpkg-reconfigure on tzdata does not help;

I was unable to find neither the settings file for the indicator my home directory nor any related entries in gconf.

What steps should i take to help resolve this issue?

Doug McMahon (mc3man) wrote :

Simon -
at least here, yes, the upgrade created a duplicate of my "home" location when I had it set to display time in other locations.
Though at least here switching the "home" location to another , then switching back to my orig "home" location did remove the dupe which didn't back

However - the upgrade to indicator-datetime 0.3.1-0ubuntu1.1 (oneiric-proposed) has again created a dupe of the "home" & can't be gotten rid of when showing add. locations, at least ant way I've found
look here
bug 802384

I am still experiencing this issue with up-to-date Precise. Switching the location back and forth does not solve it: When switching back to my home location, the duplicate entry appears again.

Charles Kerr (charlesk) wrote :

Frederik, could you please trigger the behavior again s.t. the duplicate entry appears again, and while it's still showing, run this command from a terminal and paste its values into this ticket:

    gsettings list-recursively com.canonical.indicator.datetime

Thanks!

Sure, here is the output:

com.canonical.indicator.datetime custom-time-format '%l:%M %p'
com.canonical.indicator.datetime locations ['UTC']
com.canonical.indicator.datetime show-calendar true
com.canonical.indicator.datetime show-clock true
com.canonical.indicator.datetime show-date true
com.canonical.indicator.datetime show-day true
com.canonical.indicator.datetime show-events true
com.canonical.indicator.datetime show-locations true
com.canonical.indicator.datetime show-seconds false
com.canonical.indicator.datetime show-week-numbers false
com.canonical.indicator.datetime time-format 'locale-default'
com.canonical.indicator.datetime timezone-name 'Europe/Berlin Berlin'

Indicator currently shows:

  Berlin
• Berlin
  UTC

Charles Kerr (charlesk) wrote :

Javier's second branch makes a lot of sense to me -- showing /exactly/ what's in the "Time in Other Locations" list, nothing more, nothing less. Easy for programmers to write, and (one hopes) easy for everyone to understand.

IMO the first step for this ticket is to get Design to revise the spec <https://wiki.ubuntu.com/TimeAndDate#Time_in_other_locations> to talk about what items should go in Other Locations (the geo_location and current_location entries that we use now aren't in the spec) and how to sort them (should they follow the ordering specified by the user in Time & Date Settings? or sorted by timezone as per bug #833325)?

Charles Kerr (charlesk) on 2012-02-17
Changed in indicator-datetime:
status: Fix Released → Triaged
Matthew Paul Thomas (mpt) wrote :

I agree with Charles that the simplest fix is not to include geo_location and current_location in the menu at all.

Later we could add an option for whether you want to include a geo-detected location, but that probably should be its own settings checkbox with its own string.

On an up to date precise install.

Changed in indicator-datetime (Ubuntu Precise):
status: Fix Released → New
Charles Kerr (charlesk) on 2012-03-02
Changed in indicator-datetime:
status: Triaged → In Progress
Charles Kerr (charlesk) wrote :

I'm not sure that my earlier "simplest fix" position will work: if someone is physically located outside of their custom timezone list, there's no longer an easy way to click-to-set the current timezone from the geo timezone. This regression would certainly be reported & force us to revisit this issue anyway.

After hacking & rehacking this code for the last day, I think I've found a code approach that follows some of the ideas in Javier's second patch wrt removing the special case code, but preserves the older beahvior wrt geo/current location. It improves detection & removal of duplicate entries, and also picks up a fix for Bug #833325 :)

Charles Kerr (charlesk) on 2012-03-03
Changed in indicator-datetime:
status: In Progress → Fix Committed
Olli Ries (ories) on 2012-03-05
Changed in ayatana-design:
status: New → Incomplete
Ted Gould (ted) on 2012-03-08
Changed in indicator-datetime (Ubuntu Precise):
status: New → Fix Released
status: Fix Released → In Progress
Changed in indicator-datetime:
milestone: none → 0.3.91
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.91-0ubuntu1

---------------
indicator-datetime (0.3.91-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Make GSettings readonly to fix DConf service starting on boot
    * Explicitly give types to GVariant Builder
    * Confirm scanf usage for Coverity (LP: #943747)
    * Remove unused code (LP: #943746)
    * Fix timezone ordering in the menu (LP: #833325, LP: #833337)
 -- Ted Gould <email address hidden> Thu, 08 Mar 2012 16:58:28 -0600

Changed in indicator-datetime (Ubuntu Precise):
status: In Progress → Fix Released
Charles Kerr (charlesk) on 2012-03-16
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
John Lea (johnlea) on 2012-04-20
Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in ayatana-design:
importance: Undecided → Medium
John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
importance: Medium → Undecided
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints